Xbox One controller

This topic contains 12 replies, has 8 voices, and was last updated by  k3nsh1r0 2 years, 9 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
  • #82850


    Found this neat project over the weekend and decided to build a Retropie for myself. I’m curious if anyone has gone through the trouble to make an Xbox One controller work on it yet. I see that the latest Linux kernel 3.17 has support, but it was released after the latest build of this image. I’ve never really messed with Linux much so I’m at a loss on where to even start to try to update the kernel. My 360 controller took some damage from a drop so it’s not reliable anymore, but I find the Xbox One controller to be much better so I’d like to try to get it working if possible.

    Thanks for any help that can be provided.



    ^^^ Same as this post’s author. I have zero experience with Linux and zero experience with terminal commands. Most of the recommendations expect you’ll know what buttons to push and how to save files. There seems to be some knowledge that is presumed.

    I’ve yet to find a video that provides a working solution for the current retropie release and none that walk nOObs through this. I’ve spend more than 10 hours trying to get a controller set up.

    I’m confused at how such a popular emulation platform for such a popular computer doesn’t have a very straight forward process for something as basic as controller set-up.

    Secondarily I’m surprised that given the number of people reporting trouble getting their controllers to work that someone hasn’t created a definitive walk-through for beginners or that a patch hasn’t been released to make this better.

    It took me all of a few hours to get the image flashed to the SD card, and put some Roms on it. At least 3 times that has been spent on controller configuration failures.



    the issue with creating a “definitive” walkthrough is that most people don’t have more than just one or two different controllers. i setup my WIRED xbox 360 controller quite easily without any hassles using only the built-in scripts that retropie’s setup gave me. i setup another controller: the Tomee SNES-style usb controller, this was done the EXACT same way as my xbox 360 one

    as for the xbox one… i’m not even sure thats possible to setup? are you talking about a WIRED xbox one controller?



    Xboxdrv supports Xbox One controllers now:


    I started with absolute zero Linux knowledge and found all the information I needed on this forum. It does require some tinkering to get RetroPie setup to your liking, personally I found learning about Linux along the way interesting and worthwhile. If you want something plug and play get an Android box. Or if you need help start a thread here detailing your issues and what you have tried so far.

    If you have found the solution to your problem please mark the topic as resolved.



    argh… i’m not sure if this is allowed here or not but I didn’t see anything against it yet so here goes…
    if you want, you can purchase a pre-setup retropie from myself…
    i will not include any copyrighted software in it but I will (try to) setup any controller you want with it. I have gotten the following to work:
    Scraping, NES, SNES, GBA, GBC, GB, MasterSystem, MegaDrive, Final Burn Alpha and MAME, Sega CD, Sega 32X, N64, PSX, PC-ENGINE (including the CD-rom games) and even Atari 2600…

    from my controllers I can do the following:
    rewind the game, save/load states, slow motion and even a really weak fast-forwarding..

    I will end up writing some guides I’m sure but if you really need this stuff before Christmas or whatever I will do it for you, you have to pay for shipping to me and back to you though



    I believe when they refer to Xbox1 support they are talking about the original Xbox controllers not Xbox One (worst naming decision for a console, I think). As far as I’ve read the instructions needed to initialize the Xbox One controller are quite different than the original Xbox and Xbox 360 controllers. I could be wrong on this, but when I read over that information that’s how I took it in.

    As far as wired vs wireless on the Xbox One controller as of right now there are no wireless receivers for it and you have to use a USB cable to play with it. I’ve gotten my other controllers working fine, and used some guides to tinker around with emulator settings and such. I think at the current point in time the best thing for me to attempt is using a newer build and adding Emulation Station and all the other stuff myself, or just wait until a newer image is produced. I was just hoping there’d be some easier instruction on how to do this without building it myself. Obviously not many people are using the Xbox One controllers on PCs yet so I understand there’s no real big push to get an updated image for a very small minority.




    Yes you’re right there! I agree , stupid name for the new Xbox! Xbox One controller support was added in Kernel 3.17, current Raspbian uses 3.12 so could be a long time before the Pi gets support. It might be possible to update the Kernel but that’s beyond my knowledge, perhaps ask on the forums?

    If you have found the solution to your problem please mark the topic as resolved.



    Howdy y’all,

    Only just came across this project today and am already flashing up a spare SD that I’ve got with the v2.5.0beta image. I’m using the RasPi2, currently crunching data on Raspbian with BOINC, but wanted to note that the kernel at time of typing is 3.18.5.

    This is using the 31/01/2015 build. You can get the latest version here.

    Anyway, I’ll give the RetroPi v2.5.0beta image a go later today with the wired controllers I have (Xbox One a.k.a. XbOne) and will let everyone know how this goes!



    So initial report is that it seems promising! When the system boots up it automatically detects the XbOne controller and I run through the basic left-right-up-down setup and can navigate through the menu options.

    I haven’t transferred across any ROMS yet, but will do so soon. I tried the shareware games that were already packaged with the build and both Doom and Quake seemed unresponsive to controller input, so a problem there.

    I haven’t run through the configuration mentioned here, as I figured this is only for the 360 controller (as the article name suggests), but will jump into the system config soon to have a look at some things.

    I’ll note that I don’t have “wired XbOne” controllers per se; these are just the normal wireless ones that I’m using with the USB cables, so when shutting the RetroPi system down, these automatically sense a loss of connection and search for the Xbox One wirelessly. This isn’t so much of a “problem” when turning off the Retro, but can be an issue when rebooting it, as I noticed some funky modprobe errors when doing this, as the system (presumably) notices that there are problems sending input the the controller (naturally as it has a Xbox One and a RetroPi trying to direct it).

    I’ll note that the system build info shows it’s using kernel 3.18.5, so this is probably the same Debian build as Raspbian, just cut down and tailored for RetroPi.

    More troubleshooting soon!



    Hey there Diskonekted,

    i was wondering how you managed to connect the Xbox One controller to the pi?
    When i connect the controller to the Pi’s usb port with a micro USB, the controller’s light does not come on? so with no power i cannot enter key bindings in the emulation station menu.

    Any help would be appreciated.




    I configured my xbox one controller with the retroarch-joyconfig command:

    retroarch-joyconfig for RetroPie 2.3 not responding to inputs

    Does anybody know how to get two controllers running in the n64 (mupen64plus) emulator?

    n64 works fine with the 360 controller. SNES works fine with both controllers (xbox 360 and xbox one). xbox one controller in the n64 is not recognized.



    Hey there Bigdrogba,

    I just had the controller connected before powering on the Pi2 and it worked from there. I should note that I’m using the Play & Charge kit that came with the controllers, but from what I can tell this is more than the 360 Play & Charge kits that only supplied power as the XbOne ones pass control information down the USB as well.

    Whilst mine is an “official Microsoft” one, I don’t see anything special from the exterior apart from a charge light which turns off when the battery is fully charged. I will try this again with just a standard micro-USB cable and let you know the outcome.

    As Gonzo28 mentioned, you can confiigure the controller via the retroarch-joyconfig command. There is a straight-forward way to do this on the Wiki here.

    I haven’t uploaded any ROMS or BIOS files to the Pi yet and only got so far as setting up Quake; and then just spent an hour or so playing that!

    I’ll be busy for the next couple of days, but will try to do some more testing in the coming week.



    Have any of you guys using the Xbox one controller had issues making the D-Pad to MAMAE?
    I was using mine yesterday (after giving up on the PS3 controller over wireless) and found in MAME I couldn’t map it in the TAB config menu.

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at