Xbox Controller LEFT BOTTOM configure troubles

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Xbox Controller LEFT BOTTOM configure troubles

This topic contains 4 replies, has 4 voices, and was last updated by  gonzothegreat 2 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #104214

    blackwyche
    Participant

    Hi all,

    I have serious issues to configure my xbox controller.
    When I try to register left trigger of my xbox controller, configuration tool jumps to next (RIGHT BOTTOM) and shows “hold xs to skip” like some button was pressed.
    Somebody knows this issue?
    Where are xbox config files for each controller in Retropie 3?
    Thanks in advance.

    #104235

    haris1977
    Participant

    Same problem here (with a compatible xbox controller).

    Solution? I just do not register left and right bottom triggers…

    #104244

    blackwyche
    Participant

    Same problem here (with a compatible xbox controller).

    Solution? I just do not register left and right bottom triggers…

    This was my solution too.
    When I configure RetroArch Joysticks with utility in RetroPie menu, triggers seemed registered correctly. I still not checked if they work on RetroArch.

    Thanks.

    #104295

    kommissar
    Participant

    I got this bug too but there is a trick. (in my case : Retropie v3.00 Final, fresh install) 😀

    When you register your xbox 360 pad (the 1st time), you set the inputs and BAM! the bug appears on LB. Just skip the button, then before validate (press OK), go back on the LB definition (and others skipped buttons) and redefine the remaining button(s) (in my case, the bug has disapeared). Then validate (press OK).

    I hope it can help.

    #105072

    gonzothegreat
    Participant

    ok, there is a fix for this..

    so start yer Pi as normal,

    then when the EmulationStation config screen pops up, assign the buttons as well as you can.

    next you need to set your retroarch config via the ES RetroPie menu. once that is done launch the RetroPie SetUp script.

    now you need to select #3 Setup / Configuration (to be used post install) then scroll right down to the bottom if the list, select #331 Install XBox contr. 360 driver

    now reboot.

    now ES will ask you to assign the buttons again, and now the trigger & shoulder buttons should register

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/