XBox controller config problems

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of writeson writeson 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #83660
    Profile photo of writeson
    writeson
    Participant

    Hi all,

    I’m running the RetroPie 2.3 project from downloaded binaries, which works well, accept for one thing. I’ve got XBox 360 wireless controllers hooked up to the Raspberry Pi, which looks good, I can see all the buttons when I run jstest. My problem is that in game the save/restore buttons are mapped to the “B” and “Y” buttons and nothing I do the /opt/retropie/configs/all/retroarch.cfg file seems to change that (or anything for that matter!).

    Here’s the button configuration part of my configuration file:

    input_player1_joypad_index = “0”
    input_player1_b_btn = “1”
    input_player1_y_btn = “3”
    input_player1_select_btn = “10”
    input_player1_start_btn = “9”
    input_player1_up_btn = “h0up”
    input_player1_down_btn = “h0down”
    input_player1_left_btn = “h0left”
    input_player1_right_btn = “h0right”
    input_player1_a_btn = “0”
    input_player1_x_btn = “2”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “6”
    input_player1_r2_btn = “7”
    input_player1_l3_btn = “11”
    input_player1_r3_btn = “12”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3”

    input_player1_joypad_index = “1”
    input_player1_b_btn = “1”
    input_player1_y_btn = “3”
    input_player1_select_btn = “10”
    input_player1_start_btn = “9”
    input_player1_up_btn = “h0up”
    input_player1_down_btn = “h0down”
    input_player1_left_btn = “h0left”
    input_player1_right_btn = “h0right”
    input_player1_a_btn = “0”
    input_player1_x_btn = “2”
    input_player1_l_btn = “4”
    input_player1_r_btn = “5”
    input_player1_l2_btn = “6”
    input_player1_r2_btn = “7”
    input_player1_l3_btn = “11”
    input_player1_r3_btn = “12”
    input_player1_l_x_plus_axis = “+0”
    input_player1_l_x_minus_axis = “-0”
    input_player1_l_y_plus_axis = “+1”
    input_player1_l_y_minus_axis = “-1”
    input_player1_r_x_plus_axis = “+2”
    input_player1_r_x_minus_axis = “-2”
    input_player1_r_y_plus_axis = “+3”
    input_player1_r_y_minus_axis = “-3″

    input_enable_hotkey_btn=”10″
    input_exit_emulator_btn=”8″
    input_save_state_btn=”6″
    input_load_state_btn=”7”

    If anyone has any ideas, hints, pointers, obvious stuff I’ve missed, please let me know, I’m trying to get this done by Christmas!

    Thanks in advance,
    Doug

    #83664
    Profile photo of sandking
    sandking
    Participant

    Starting from obvious – you are sure that these settings work (ie changing button setup here changes how it works)? I got save/load set up in SNES (snes9x) folder cfg file and it works fine.

    #83676
    Profile photo of writeson
    writeson
    Participant

    Hi sand king,

    Actually, I’m not sure at all. No edits to /opt/retropie/configs/all/retroarch.cfg seem to do anything. I thought this file was the basis of all controller configuration (buttons are recognized in all emulators), and there is no controller configuration in the emulator specific retroarch.cfg files.

    Doug

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar