XBOX 360 Wirless

This topic contains 3 replies, has 2 voices, and was last updated by  phoenix 2 years, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #97858


    I have up to 4 controllers working (happy). I only run into 1 issue. I can’t seem to configure the exit to menu form the retroarch config.

    After doing some research and a flash to start from scratch, I noticed that I don’t need the xbox driver to get my controllers to work. I assume the latest versions come with it pre compiled?

    I am going through the manual joypad setup and then properly copying the settings into my retroarch, it still doesn’t seem to pick up the change in keys I assign it.

    In addition, and I believe this is the case with everyone, my controllers don’t sync like they do with an xbox either (all 4 user lights blink continuously, not denoting player 1 or 2). The config seems to pick up multiple controllers and randomly assign a player 1, 2, 3 and 4.

    Thoughts on what I might be missing here? I really just want to be able to exit a game to the OS ….



    Start here:

    and search this forum for xbox 360 and also blacklist you will find how to get rid of the lights and get the controller to work properly.




    I finally went through and did step 3 of the xbox conroller set up and that appears to fix my led assignment issue.

    I still cannot for the life of me get to the exit emulator. I use input_exit_emulator_btn = "9" hoping to link it to the left/right thumb push.

    After doing the step 3 setup, the retropie still asks me to configure my controllers upon initial boot. (I’m setting up all my configs via an SSH). Is this somehow over riding my custom configs I am designing?

    Any more ideas?



    hmm. I’m not any smarter. I installed the driver, and actually did option one after I read a post (on here) about how it was the easiest. I did configure the controller on initial boot. For N64 games, you have to put in an “exit emulator” button into the mupen config file, but for retroarch, “back”+”start” should work fine (it does for me).

    Try this: see what Retropie names your controller (jstest /dev/input/js0) and then check the Retroarch config for it in opt/retropie/emulators/retroarch/config

    editing that file may solve your issue.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss