Xbox 360 Wireless problems (sorry)

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Xbox 360 Wireless problems (sorry)

This topic contains 0 replies, has 1 voice, and was last updated by Profile photo of superseahawk superseahawk 2 years, 6 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #84055
    Profile photo of superseahawk
    superseahawk
    Participant

    I want to start off by saying I would not be posting this if I had not already put countless hours into researching solutions for this. I know there are a ton of controller posts going on here but I am just really hoping someone can tell me I am doing something stupid and find a solution for this. I have a crude knowledge of linux functions and commands but am eager to learn (the pi and accessories were a very anticipated gift). Most of this I have picked up from other post here or elsewhere so feel free to correct me.

    I am trying to connect my Wireless Xbox 360 controller using the dongle and I have gotten it to certain levels of functionality. To start, here are the configs and stuff I have so far:

    my rc.local has this extra code:

    sudo xboxdrv --trigger-as-button --wid 0 --led 2 --deadzone 4000 --silent --detach-kernel-driver &
    sleep 1

    I then got the player one green light in the top left on the controller and I could fully navigate the EmulationStation menu. Now here is where I ran into my first(relevant lol) problem. When I try to configure the controller in EmulationStation it registers as Gamepad 4. jstest stills says its in the first slot (0).

    After much research I found I was able to change the default player 1 controller to the fourth controller slot:

    input_player1_joypad_index = 3

    and with the help of some manually configured buttons(please help if these are wrong)

    input_player1_b_btn = "1"
    input_player1_y_btn = "3"
    input_player1_select_btn = "8"
    input_player1_start_btn = "9"
    input_player1_up_axis = "-5"
    input_player1_down_axis = "+5"
    input_player1_left_axis = "-4"
    input_player1_right_axis = "+4"
    input_player1_a_btn = "0"
    input_player1_x_btn = "2"
    input_player1_l_btn = "4"
    input_player1_r_btn = "5"
    input_player1_l2_btn = "6"
    input_player1_r2_btn = "7"
    input_player1_l3_btn = "11"
    input_player1_r3_btn = "12"
    input_player1_l_x_plus_axis = "+0"
    input_player1_l_x_minus_axis = "-0"
    input_player1_l_y_plus_axis = "+1"
    input_player1_l_y_minus_axis = "-1"
    input_player1_r_x_plus_axis = "+2"
    input_player1_r_x_minus_axis = "-2"
    input_player1_r_y_plus_axis = "+3"
    input_player1_r_y_minus_axis = "-3"

    Now I am still able to control the menu and when I load up my test ROM (NES Super Mario Bros and Duck Hunt Combo) I can press start in the menu to select Mario Bros and even jump!

    I have tried the retroarch-joyconfig and the config does not respond to any button presses even though the light shows its connected and jstest gives values.

    In summary, my joysticks are not responding in my emulator and nothing is responding in joyconfig.

    I am just completely lost. I am losing my mind trying to find this and I really just need help thanks in advance.

Viewing 1 post (of 1 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar