Xbox 360 d-pad not responding in emulators

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Xbox 360 d-pad not responding in emulators

This topic contains 1 reply, has 1 voice, and was last updated by Profile photo of wocketpatch wocketpatch 2 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #83699
    Profile photo of wocketpatch
    wocketpatch
    Participant

    I’ve manually configured my wireless 360 controller in
    /opt/retropie/configs/all/retroarch.cfg (I got the layout from jstest)
    and everything seems to be more or less working in most emulators except the up-down-left-right pad. Nothing happens. If I assign the movement functions to other buttons they work fine using
    input_player1_up_btn
    but according to jstest, the d-pad is registering as axis 4 and 5, not as buttons. I also tried
    input_player1_up_axis
    instead of btn, but that doesn’t seem to do anything either. The d-pad does work perfectly fine navigating the menus in emulationstation.

    Interestingly, when I did the initial setup for my keyboard controls in the controller setup within emulationstation, I notice the keys I selected are listed in the retroarch.cfg but I don’t see the settings for my xbox controller in there anywhere even though I did set up both the keyboard and the xbox controller for emulationstation through the same utility.

    Anyone have any idea how to get the d-pad to register? It doesn’t respond in all emulators as far as I can tell.

    Thanks!

    #83823
    Profile photo of wocketpatch
    wocketpatch
    Participant

    Well I figured it out, evidently the D-pad is considered “hats”. There is no indication of this in jstest, but all the same this worked for the wireless xbox 360 usb controller’s d-pad buttons:

    input_player1_left_btn = “h0left”
    input_player1_right_btn = “h0right”
    input_player1_up_btn = “h0up”
    input_player1_down_btn = “h0down”

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar