Xbox 360 controller set up v2.3

This topic contains 8 replies, has 2 voices, and was last updated by Profile photo of shywolf28 shywolf28 2 years, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #69832
    Profile photo of nine4v
    nine4v
    Participant

    Hi, this is doing my flipping nut in.

    Just cant get the xbox controller configured for use in the actual emulators.

    I’ve tried and watched so many tutorials now and it still wont work.

    Please help before I launch my Pi through the window.

    #70288
    Profile photo of shywolf28
    shywolf28
    Participant

    what exactly did you need help with?

    #71352

    zitres1911

    Hi,
    Same problem here. The RetroPie Emulationstation-menu works fine with the xbox360-controller, but none of the emulators.
    First i used

    sudo apt-get install xboxdrv to instal the driver – worked fine

    sudo xboxdrv -D i 0 --next-controller -i 1 --next-controller -i 2 --next-controller -i 3 --deadzone 4000 --dbus disabled
    nothing happend, just a short error

    sudo xboxdrv --trigger-as-button --id 0 --led 2 --deadzone 4000 --silent &
    nothing happend

    sudo xboxdrv --detach-kernel-driver
    terminal said it worked and show me every input from the controller, but the emulators still wont work with the controller.

    I dont know how to get into the manuel config

    Maybe this could help: https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    I use a xbox360-controller for windows and a RaspberryPi B+ with RetroPie2.3

    #71391
    Profile photo of shywolf28
    shywolf28
    Participant

    if your talking about setting up a wireless xbox 360 cotroller, do this—i setup mine this way and it works both on emulationstation and emulators..just go into terminal and type…

    Sudo chmod +rw /opt/retropie/configs/all
    Cd /opt/retropie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig –o /opt/retropie/configs/all/p1.cfg –p 1 –j 0
    Follow directions

    Sudo reboot

    hope that helps..let me know

    #72716

    zitres1911

    I started back from zero and tried to fix it, but it doenst work. In Emulationstation no problems in the emulators just the keyboard works but not the controller.
    I’ve tried to edit the /etc/rc.local but the controller still dont work.
    By the way, i have a wired on, so i replaced the –wid with a –id

    @shywolf28: i will try your code tomorrow.

    #72815
    Profile photo of shywolf28
    shywolf28
    Participant

    Do this, navigate to /opt/retropie/configs/all/ and replace the retroarch.cfg with the one that i have attached. It has my xbox 360 controller for the emulators..see if that helps..let me know

    #72816
    Profile photo of shywolf28
    shywolf28
    Participant

    lol didnt let me attach it…see if it does it this way

    Attachments:
    1. retroarch.zip
    #73357

    zitres1911

    Thank you so much!!! It works!

    #73542
    Profile photo of shywolf28
    shywolf28
    Participant

    glad i could help

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar