Xbox 360 controller set up v2.3

This topic contains 8 replies, has 2 voices, and was last updated by  shywolf28 3 years, 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #69832


    Hi, this is doing my flipping nut in.

    Just cant get the xbox controller configured for use in the actual emulators.

    I’ve tried and watched so many tutorials now and it still wont work.

    Please help before I launch my Pi through the window.



    what exactly did you need help with?



    Same problem here. The RetroPie Emulationstation-menu works fine with the xbox360-controller, but none of the emulators.
    First i used

    sudo apt-get install xboxdrv to instal the driver – worked fine

    sudo xboxdrv -D i 0 --next-controller -i 1 --next-controller -i 2 --next-controller -i 3 --deadzone 4000 --dbus disabled
    nothing happend, just a short error

    sudo xboxdrv --trigger-as-button --id 0 --led 2 --deadzone 4000 --silent &
    nothing happend

    sudo xboxdrv --detach-kernel-driver
    terminal said it worked and show me every input from the controller, but the emulators still wont work with the controller.

    I dont know how to get into the manuel config

    Maybe this could help:

    I use a xbox360-controller for windows and a RaspberryPi B+ with RetroPie2.3



    if your talking about setting up a wireless xbox 360 cotroller, do this—i setup mine this way and it works both on emulationstation and emulators..just go into terminal and type…

    Sudo chmod +rw /opt/retropie/configs/all
    Cd /opt/retropie/emulators/RetroArch/installdir/bin
    ./retroarch-joyconfig –o /opt/retropie/configs/all/p1.cfg –p 1 –j 0
    Follow directions

    Sudo reboot

    hope that helps..let me know



    I started back from zero and tried to fix it, but it doenst work. In Emulationstation no problems in the emulators just the keyboard works but not the controller.
    I’ve tried to edit the /etc/rc.local but the controller still dont work.
    By the way, i have a wired on, so i replaced the –wid with a –id

    @shywolf28: i will try your code tomorrow.



    Do this, navigate to /opt/retropie/configs/all/ and replace the retroarch.cfg with the one that i have attached. It has my xbox 360 controller for the emulators..see if that helps..let me know



    lol didnt let me attach it…see if it does it this way



    Thank you so much!!! It works!



    glad i could help

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss