X-Arcade Tankstick Trackball – advmame Golden Tee

Home Forums RetroPie Project Everything else related to the RetroPie Project X-Arcade Tankstick Trackball – advmame Golden Tee

Tagged: 

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of calumetjohn calumetjohn 2 years, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #93761
    Profile photo of calumetjohn
    calumetjohn
    Participant

    Hello,

    I was working on a project for friend and realized how much fun it was so I decided to build my own. I picked up an x-arcade tankstick with the trackball. For the life of me I am not able to get the trackball working decent in Golden Tee on ADVMAME. It shows a mouse scrolling across the screen.

    The motion is all choppy and not fluid. if I spin the trackball up fast it does nothing or or stops right before the golfer strikes the ball.

    Wondering if anyone else has been able to get the trackball working consistently with RetroPie 2.6 / ADVMAME / XAarcade Tankstick?

    Both joysticks and buttons work great!

    #93767
    Profile photo of drvenkman
    drvenkman
    Participant

    My Tankstick trackball works great in AdvMAME so long as no other mouse is plugged into the Pi. I haven’t played Golden Tee but I use it in the Atari classics Centipede, Millipede and Missile Command without any problems, as well as with Tempest (I don’t have a true spinner). Check to make sure you’ve got the analog control sensitivity in MAME set high enough. You will probably have to experiment to get the feel right.

    And if that doesn’t do it, check the Tankstick with a regular PC or Mac. The trackball will show up as a USB mouse and should work just like one. If it doesn’t work with a regular computer, something may be up with your trackball mechanically or electrically.

    #93773
    Profile photo of calumetjohn
    calumetjohn
    Participant

    I think it has to do with the sensitivity.

    The trackball does work, its just really temperamental. one time I have to roll it fast and the other slow and it is always the same result.

    I’ll send you a PM.

    #93903
    Profile photo of calumetjohn
    calumetjohn
    Participant

    I setup Maximus-Arcade on a windows machine and the trackball works perfect, just not in advmame on retropie. would you be willing to share your controller configuration within Golden tee if it works for you? I know you said you do not play it. just wondering if you could test it out.

    Thanks!

    #94138
    Profile photo of calumetjohn
    calumetjohn
    Participant

    Got it working. was an issue with retropie 2.6. I upgrade to 3.0 beta 2 and it is fixed. probably something to do with the udated version of advmame.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar