wireless xbox controller settings.

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie wireless xbox controller settings.

This topic contains 6 replies, has 4 voices, and was last updated by  red266 2 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #92530


    hello noob user here..

    Emulation station picks it up, some of the emulators have yellow writing at the bottom so I know it sees it…

    I have a rpi2 1gb version with a new 2.6 retropie install. I tried to enable to 360 driver I have a usb wireless dongle as well. Everything seems to be connected and working but the mappings to the emulators seem to be off, for example, on my nes all I can do is jump, no movement, and its the same thing on the segagenesis as well, I only have one button, no movement. 🙁

    I followed these steps;

    Wired Xbox 3060 controller for different Emulators config

    The dongle appears to be picking up both controllers. I just can use them, I am wondering if there is another way to map buttons?? Confused. please help!



    The problem in short is, that the autoconfiguration file for the Xbox 360 controller is just not complete IF you use the userspace driver (the one you might have installerd called xboxdrv). It will say the same in the yellow message you talked about.

    If you use the standard kernel driver (xpad) the lights on your controllers will keep flashing but the autoconfiguration is much more complete and correct.

    Could you try not loading the xboxdrv in rc.local by putting a “#” in front of the corresponding line and so commenting it out?



    i have a Problem with the xbox wireless controller too.
    it works in the main Menu but when i start a NES Game like SMB the key mappings are confuse… Y = start, RT= go right, SELECT = go left
    how can i map them correctly ?



    Whats weird is the n64 seems to be working great… Where is the file that actually controls these buttons so that I ma try and can compare the 2?

    How do you know if your emulation station is running from the all config or individually for each emulator??

    Having trouble editing the rc.local I am getting overwrite permissions errors. ugh.

    cannot overwrite file

    Permission denied.
    Error code: 3
    Error message from server: Permission denied

    Will look at this later today I have to goto work.

    here is the line from the local as well I am trying to add with the #

    #xboxdrv –daemon –id 0 –led 2 –deadzone 4000 –silent –trigger-as-button –next-controller –id 1 –led 3 –deadzone 4000 –silent –trigger-as-button –dbus disabled –detach-kernel-driver &
    exit 0



    Could you try not loading the xboxdrv in rc.local by putting a “#” in front of the corresponding line and so commenting it out?

    It will not let me input a #.. it changes the character to a L …. I dont understand this stuff… everytime someone tell me to do something it wont do it.

    I tried from the shell and using raspian to put a #



    The file I mentioned needs root permissions to be changed.

    If you are changing it from a shell (e.g. with nano) you would need to invoke it with sudo:

    cd /etc/
    sudo nano rc.local
    <move cursor to line>
    <add #>


    Ok I am having decent luck with these considering before this I the closest I have ever got to a command screen was ctrl, alt, del. And I have my wireless Xbox controllers connected and work great flawlessly on one player. When I go to two player the second player controller connects fine but doesn’t have anycontrol in the emulator.
    Once again if someone can help me out and stupefy it from step one some ways to fix this issue I would greatly appreciate it.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss