Wired Xbox 360 Controller Problem

This topic contains 3 replies, has 2 voices, and was last updated by  cyberfantome 3 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #6215


    I have a Raspberry Pi Model B with a 32GB Class 10 SD Card. Connect to my TV via HDMI, and have a standard USB wired keyboard and of course a power supply connect to it.

    1. I download RetroPie image via Torrent.
    2. Format SD card using SD formatter.
    3. Burn image to card using WinDisk32.
    4. Pi boots up into EmulationStation. I press F4 to exit.
    5. Run raspi-config to expand file system.
    6. Reboot
    7. Update raspi-config.
    8. Reboot
    9. Run apt-get update and apt-get upgrade
    10. Reboot
    11. Run retropie_setup.sh and update it since the Xbox Controller option isn’t there.
    12. Reboot.
    13. Run retropie_setup.sh again and run option to install xbox wired controller. Says it’s installed and will start with reboot.
    14. Exit script.
    15. Connect xbox wired controller
    16. Reboot
    17. Configure emulation station using my controller. Works in EmulationStation perfectly.
    18. Cannot use controller to play Cave game or Duke Nukem. Or any ROMS for any system I copy over.
    19. Run setup in EmulationStation for RetroArch, no difference.
    20. Exit EmulationStation
    21. Run retropie_setup.sh
    22. Run the register controller with RetroArch option.
    23. Reboot
    24. Now controller doesn’t work in EmulationStation at all.

    I fought this all weekend. What am I doing wrong?



    Hi, this thread may help you: http://blog.petrockblock.com/forums/topic/installation-problem/#post-5225

    If you have found the solution to your problem please mark the topic as resolved.



    So I flashed the image, fired it up, didn’t setup the controls for ES just pressed F4 to exit. Expanded file system, ran sudo apt-get update and sudo apt-get upgrade then tried your steps. My controller worked to setup ES’s controls but all LED’s kept flashing. I guess something in the update horked it. Thought I’d share if anyone else is running into the same issue. So anyways I copied over your .cfg file to Cave Story and the controls were FUBAR which may be a result of the update again I guess. Also I could not use my KB at all to exit out of the game. Trying again without doing an update.



    Got it to work!
    1. At first boot I exited from EmulationStation.
    2. Ran sudo raspi-config to expand file system, enable SSH, set language to US English and my timezone.
    3. Reboot
    4. Exited ES again.
    5. sudo apt-get update
    6. sudo apt-get install xboxdrv
    7. Edited local.ev with your line of code.
    8. Rebooted
    9. Xbox P1 light stayed on by the time ES booted.
    10. Did ES controller config.
    11. Went to controller setup screen within ES and configured controller.
    12. Tested NES and SNES games, works!!!!

    Thank you very much for your guide!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss