Wired Xbox 3060 controller for different Emulators config

Home Forums RetroPie Project Everything else related to the RetroPie Project Wired Xbox 3060 controller for different Emulators config

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of waddupbeazt waddupbeazt 2 years, 11 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #15598
    Profile photo of waddupbeazt
    waddupbeazt
    Participant

    Hi,

    I have an issue setting up my wired xbox 360 controller to work.

    It works in the menus without problems.
    The Xbox 360 driver is installed and checked with lsusb.
    I have tried editing the controller to use input-up-btn = “h0up” etc.
    Have tried to go through the setup in console.

    When trying out some games only the ABXY buttons work and sometimes start and select.

    I have also tried to reinstall everything.

    Important notes; I am somewhat new to linux commands and raspberry pi.
    I have followed several guides to perform this controller installation but it does not work.

    My goal is to have it working on N64, SNES and GBA emulators. Can this be done with 1 single config file?

    Thanks in advance!

    #15615
    Profile photo of nemo93
    nemo93
    Participant

    hi waddupbeazt,

    I can help you only for SNES as of now as I didn’t play much with n64 and GBA. Enclosed to this post you’ll find a retroarch config file to be used for SNES. The mapping is accurate as far as I can tell and to exit Retroarch you have to press Select and Start.

    you have to copy this file to this location:

    /opt/retropie/configs/snes/
    

    hope this helps.
    cheers,

    #15656
    Profile photo of waddupbeazt
    waddupbeazt
    Participant

    Hi Nemo93,

    Thanks for your help!

    Ok, so when I switch between emulators I manually have to activate / de-activate RetroArch?

    And another problem, RPi won’t allow me to handle files in the /opt folder due to access restriction. Are there any ways around this? I’m using the standard logon pi/raspberry

    #15669
    Profile photo of nemo93
    nemo93
    Participant

    hi waddupbeazt,

    not sure I understood your question about retroarch 🙁 You don’t have activate/deactivate NOTHING as far as I know. Just put the file I shared into the path I mentioned and that should do the trick. I consider you’re using retroarch as the SNES emulator though. If you’re not using retroarch then there is nothing I can do for you as I’m speaking.

    regarding the permission issue please take a look at this other post:
    http://blog.petrockblock.com/forums/topic/how-to-use-mame4all/#post-12230

    hope this helps.
    cheers,

    #15856
    Profile photo of vivid
    vivid
    Participant

    When I got my 360 controller working I found out xboxdrv was actually interfering with the configs in the games so I decided to uninstall it.

    I just used the retroarch joystick setup in RetroPie-Setup/RetroPie_Setup.sh then chose option 3 in the first menu and then I believe the option to set the joystick is 8 (I don’t have my Pi on so I don’t know exactly what the option is called) and then I went into the retroarch.cfg file and I was able to set save state,load state, emulator menu, and emulator reset buttons.

    The retroarch.cfg file is located in the directory: /opt/retropie/configs/all/

    The commands to set the enable hotkey and exit emulator hotkey in the retroarch.cfg are: (you need the enable hotkey because that’s what you press along with the other buttons that do other actions like load state or save state)
    input_enable_hotkey_btn = “8″
    input_exit_emulator_btn = “9″

    The commands to set the save state and load state in the retroarch.cfg are:
    input_save_state_btn = “4″
    input_load_state_btn = “5″

    The numbers are what buttons are pressed on the controller when you set it up in the retroarch joystick setup.

    Hopefully this helps a little, let me know if I need to be more clear.

    #16272
    Profile photo of waddupbeazt
    waddupbeazt
    Participant

    Ok, I did as nemo93 told be and used his config in the given location.

    When i Start SNES my config uses left trigger (upper left) to jump.
    A to go down, B to go up and neither select or start (or exit the game in any way works).

    Is there any other config files I have to change?

    i changed the one in /opt/retropie/configs/SNES/ to what Nemo93 sent me.

    Please help me with this! If I just can get one controller to work with GBA, SNES and N64 I will be super super happy.

    I have only made the standard installation and updates. No changes to any files or emulators what so ever except the config of SNES.

    #16278
    Profile photo of waddupbeazt
    waddupbeazt
    Participant

    Ok I have managed to configure the GBA controls.

    Tried to use same “1”, “2” etc in SNES but that made things worse 🙁

    #16279
    Profile photo of waddupbeazt
    waddupbeazt
    Participant

    Ok, no meaning to bump myself but better get the information inside.

    I giv up the N64 thing due to http://blog.petrockblock.com/forums/topic/n64-problems/

    Can’t even start a N64 game.

    ANyway, If someone please can help me with the remaining SNES configs that would be awesome

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar