Will PokeMMO run?

This topic contains 4 replies, has 2 voices, and was last updated by  deathzero 2 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #108993

    deathzero
    Participant

    Hi all, sorry if I’ve missed somebody posting about this before. Tried to search both forum and google for help on this.
    Running a Rasp Pi 2, with latest Retropie image from the torrent.
    I’ve got RetroPie and EmuStation running well, managed to install all my roms and got the controllers all setup. Saw places where a few people said they’d gotten PokeMMO running on RetroPie so I thought I’d give it a go.

    Should I be trying to run the .exe through rpix86, or can I run the .sh without?

    Been getting Permission Denied errors for the tries I’ve had so far.

    #108996

    herbfargus
    Member

    Alright so here is what I have so far:

    https://pokemmo.eu/downloads/

    Register an account online

    mkdir pokemmo
    cd pokemmo

    Download:

    wget https://pokemmo.eu/download_file/?id=1&mirror=1

    unzip PokeMMO-Client.zip

    sudo apt-get update
    sudo apt-get upgrade

    sudo apt-get install openjdk-7-jdk

    sudo chmod +x PokeMMO.sh

    Copy Pokemon FireRed into the roms folder (you’re on your own in providing the ROM)

    Run the game:

    ./PokeMMO.sh

    You’ll run into the error described in the following post

    https://boards.openpandora.org/topic/16502-game-pokemmo-almost-works/

    If you are able to find some way to fudge java into sorting out the liblwjgl.so then you may also need x to run it (i.e. a desktop of sorts like lxde which retropie does not come with)… I’m going to see if minecraft ships with the same library and maybe replace it with that and see if it does anything. but so far I’m stumped.

    see also: http://forum.lwjgl.org/index.php?topic=5494.0
    and http://askubuntu.com/questions/571279/minecraft-crashing-linux-download

    installing x:

    sudo apt-get install lxde

    delete contents of etc/profile.d/10-emulationstation.sh

    startx to open up into the lxde desktop

    You can download the binaries for blocky as thats the only lblwjgl arm build I’ve found and you can download the tar here:

    wget https://github.com/spsn/blocky/raw/master/blocky-run-pi-armhf.tgz

    sudo tar xvf blocky-run-pi-armhf.tgz

    then you’ll overwrite all the files that are named the same from the blocky binary over to the pokemmo folder.

    The furthest I’ve gotten is an unsatisfied link error and a failed to set display mode error.

    see also: http://talk.maemo.org/showthread.php?t=87192

    Since pokemmo is closed source its hard to troubleshoot issues without needing to piece it together from a lot of sources. It’s unlikely it will work without a lot of hacks and even if it were to work I can’t speak for how well it would run. It’s unfortunate but perhaps in the future they may be more open to making their work available to the community. Until then seems we’re out of luck.

    #109011

    deathzero
    Participant

    Shucks. Thanks for looking at it.

    No possibility of running the windows version through rpix86 then either then? Was hoping that might be a possibility since i’d seen somebody mention using that to run it when Retropie was still in the v2’s.

    #109012

    herbfargus
    Member

    Idk its possible, but may not run very well. Feel free to try it out. I’ll look into it at some point in the future when I’ve got some free time, but since they haven’t provided their source code our options are fairly limited. Its unfortunate.

    #109015

    deathzero
    Participant

    Either way, the effort and information is greatly appreciated. I’ve got a regular pc that’ll run it. Was just hoping to put it on there as well since it’s kinda retro. May keep messing with it. If I manage to get it running I’ll post. Thanks again!

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/