Wifi won't connect?

Home Forums RetroPie Project New to RetroPie? Start Here! Wifi won't connect?

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of caaok caaok 1 year, 12 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #100944
    Profile photo of caaok
    caaok
    Participant

    New user here. Following setup:
    RPi 2
    Retropie 3.0b4 installed as an SD disk image
    USB devices: Asus Usb-N10 wifi dongle
    USB keyboad (currently doubling as controller)

    Basically I’m attempting to set up Wifi using the menu option (leading to Wicd-curses). My USB dongle must be at least partially functional as it detects multiple nearby Wifi networks including my own. I’ve tried both static IP and DHCP, but after configuring it refuses to work. It goes through:

    Putting the interface up
    (Some other stuff super quickly)
    Validating authorization
    Obtaining IP address…

    And then just jumps back to “Not connected” and “Scanning for Networks” with no further error or message given. The networks then appear again and the process repeats.

    The network in question is a WPA2-PSK with AES encryption. The passcode is correct. The option I’ve chosen for network type is “WPA 1/2 (Passphrase).

    Any thoughts?

    #100969
    Profile photo of goobatroopa
    goobatroopa
    Participant

    Is your WiFi ssid set as hidden?
    For some reason mine will never connect if it’s set as hidden on my router. When it’s not, it connects perfectly.

    #100973
    Profile photo of caaok
    caaok
    Participant

    Nope, nothing like that. It’s a pretty standard Wifi setup, no hidden SSID, no MAC filtering, nothing.

    #100977
    Profile photo of herbfargus
    herbfargus
    Member

    Sometimes wicd doesn’t play nice with some WiFi dongles for whatever reason, and wifi may need to be configured manually using option two or three from this page: https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-Up-Wifi

    You can also look over option one and see if perhaps you missed a step in configuring wicd

    #101091
    Profile photo of caaok
    caaok
    Participant

    Thanks, that worked. I couldn’t figure out how to get into the terminal at first (without wifi for SSH) but eventually I found it and Method 2 worked fine.

    Either press F4 or change the default boot mode in the retropie-setup script for anyone else wondering.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar