Wifi Dongle Setup RetroPie 148f:7601 Ralink Technology

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Wifi Dongle Setup RetroPie 148f:7601 Ralink Technology

This topic contains 2 replies, has 3 voices, and was last updated by  polluxpt 3 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #84516

    LoneWolf
    Participant

    Hi All

    I recently setup a RetroPie running on img 2.3. I spend about a week alone trying to setup the wifi, it was not easy! I purchased the RALink Wifi Dongle of eBay however this is not one that runs on RetroPie out of the box and did require a lot of tweaking to get it to work. I searched many sites and resources but after a LOT of trial and error I managed to get it working. I figured I would share how I got it to work so no one else needs to go through what I went through.

    First run the following commands:

    sudo apt-get install wpasupplicant

    sudo apt-get install firmware-ralink

    The run:

    lsusb

    You should see the device listed like below:

    Bus 001 Device 007: ID 148f:7601 Ralink Technology, Corp.

    Then run the following set of commands, allowing each one to complete before moving onto the next one:

    wget https://dl.dropboxusercontent.com/u/67643651/mt7601_3.12.35_730.tar.gz

    sudo tar xf mt7601_3.12.35_730.tar.gz -C /

    sudo depmod 3.12.35+

    cat /lib/modules/3.12.35+/modules.dep | grep mt7601Usta

    sudo reboot

    Check if everything is OK:

    sudo lsmod | grep mt7601Usta

    You should see something like below:

    mt7601Usta 601487 1

    Then run:

    iwconfig

    Then use the Wi-Fi rename of ra0 on wlan0 and that the file:

    sudo nano /etc/udev/rules.d/70-persistent-net.rules

    Create and add to:

    ACTION=="add", SUBSYSTEM=="net", ATTR{type}=="1", KERNEL=="ra*", NAME = "wlan0"

    After a sudo reboot it is successfully renamed wlan0:

    Then the file /etc/network/interfaces upgraded with the following information to access with a fixed IP address can:

    sudo nano /etc/network/interfaces

    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    
    auto wlan0
    allow-hotplug wlan0
    iface wlan0 inet static
    address 7.7.7.50 
    netmask 255.255.255.0
    gateway 7.7.7.1
    wpa-ap-scan 1
    wpa-scan-ssid 1
    wpa-ssid "YOUR-WIFI-NAME"
    wpa-psk "YOUR-WIFI-PASSWORD"
    

    After a sudo reboot you can connect to the Raspberry Pi without wires.

    I hope that helps 🙂

    Software is like sex, it's better when it's free.

    #85383

    kuzzmi
    Participant

    Hi!

    Dunno why, doesn’t work on clean install and rpi-update to 3.12.36+.
    Can you, please, rebuild it for a newer kernel?

    #108856

    polluxpt
    Participant

    Hello.
    Does this method still applies to the new version of Retropie for RPi2?
    Thanks

    I was unable to get it to work with the tutorial above. It gave me errors.
    My device bought from DX only works in Windows (but I needed to install drivers…).
    I give up on this.
    This device it’s not worthy of such work to get wifi.
    I have a TP-Link one that runs smoothly.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

We use Cookies and similar technology to collect and analyse information about the users of this website. We use this information to enhance the content, advertising and other services available on the site. Please click ‘Accept cookies’ to consent to the use of this technology by petrockblock. You can manage your preferences at any time by visiting our Cookies Policy page.