Wi-fi on Pi3

This topic contains 26 replies, has 8 voices, and was last updated by Profile photo of petrockblog petrockblog 1 year, 2 months ago.

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #122286
    Profile photo of tjans
    tjans
    Participant

    Hey folks, brand spanking new to RPi. I just picked up the Pi3 and I’m having trouble getting it to see my SSID when configuring the built-in Wi-Fi. I choose the wi-fi configuration option from the main screen and it brings me to an old-style blue-screen environment (looks like the old MS-DOS text editor). I have two options, one is configuring an SSID, the other is hidden SSID.

    The only one that shows up is my neighbor’s (there are a ton more of my neighbor’s SSID’s that get discovered on my windows box, but only one in Retropie). I tried doing the hidden SSID option, but it won’t connect. I also tried misspelling my SSID to see if it was finding it, and it gives me an error message when I do so. Spelling it correctly gives me a different message about not being able to connect.

    Is there something I have to do to get my Wi-Fi router to show up? Why is only my neighbor’s endpoint showing up?

    Pi Model: Version 3, model B
    RetroPie Version Used: Latest for Pi3, 3.6 I think
    Built From: SD image download from petrockblog
    USB Devices connected: SNES controller via retrolink adapter
    Error messages received: “cannot connect to network”

    If this is something where you need to see my config files, I can tether this thing and try to SSH into it, though I’m more of a windows guy, so my command-line-fu probably ends with simple sudo commands. I’ll need some help with that. I’m not sure if that matters though, as I haven’t changed any of the configs.

    Am I missing something, or is the Pi3 too new to work with the built-in Wi-Fi right now?

    #122292
    Profile photo of dankcushions
    dankcushions
    Participant

    i would probably start with doing
    apt-get update
    and then
    apt-get upgrade

    the pi3 wifi drivers/configuration was a bit rubbish on the initial release that was used in retropie 3.6.

    #122309
    Profile photo of tjans
    tjans
    Participant

    Doing so now. It’s taking a while!

    #122347
    Profile photo of auswear
    auswear
    Participant

    Just remember you’ll only be able to connect to the 2.4Ghz band on the Pi 3, so if you’re router is 5Ghz it won’t display

    #122353
    Profile photo of tjans
    tjans
    Participant

    Ok, so after two attempts at apt-get update and another two at upgrade and several hours of waiting, the process completed successfully.

    I restarted my pi and my router and the ssid showed up. I tried connecting but still says its unable to connect. My other devices and computers are connecting fine but not the pi.

    You are correct, only the 2.4 shows up, not the 5ghZ

    #122359
    Profile photo of zigurana
    zigurana
    Participant

    I had the situation where my router would report the Pi to be connected via Wifi (fixed ip), but the pi would not report an IP address at all. The routers logging would show many ACK commands, basically trying to keep the connection alive, but failing.

    For me it helped to switch off wifi power-management:
    sudo iwconfig wlan0 power off

    I’ve added the same to my rc.locale:

    sleep 10
    sudo iwconfig wlan0 power off

    just before the exit 0

    #122374
    Profile photo of meneerjansen
    meneerjansen
    Participant

    Why is only my neighbor’s endpoint showing up?

    Maybe because his wireless signal is stronger. The blue MS-DOS like wizard should work, and considering that it lists SSID’s proves that is does. I wouldn’t mess around on the command line if I were you.

    Try to move your Pi around and seee if you router shows up. BTW, if your router’s SSID is hidden then you’ve set that. Un-set it.

    Good luck 🙂

    #122435
    Profile photo of dabone
    dabone
    Participant

    The pi3 has trouble with the higher wifi channels, mine would see my router on channel 11, but was transfering at under 12kbs a sec.

    Changing the wifi channel to an open lower channel worked for me.

    (To see what channels are in use, the easiest way I’ve found is use the free wifi-analyzer app on an android device. It shows you all the wifi signals it sees in a nice display so you can see where the channels are congested and move yours to an open one.)

    Later,
    dabone

    #122438
    Profile photo of tjans
    tjans
    Participant

    I don’t have it hidden, but since my AP wasn’t showing up, I tried the “hidden” option to see if I could force it to connect. I finally got my SSID to show up, but it still won’t connect to it. I’m not sure what to do at this point, though I’ll try the channel thing and try moving it around. That said, my Pi is about 10 feet from my AP so I’d imagine that’s not the issue. I’ll try anything though as not having wi-fi makes it difficult to put ROMs on it…

    #122449
    Profile photo of finhead
    finhead
    Participant

    I had the same issue with my Rpi3, the update with Zigurana’s suggestion worked for me.
    It’s faster and easier to just use a USB drive to tranfer ROMS BTW. Here are the steps just in case you haven’t tried it.

    (ensure that your USB is formatted to FAT32)

    first create a folder called retropie on your USB stick

    plug it into the pi and wait for it to finish blinking

    pull the USB out and plug it into a computer

    add the roms to their respective folders (in the retropie/roms folder)

    plug it back into the raspberry pi

    wait for it to finish blinking

    refresh emulationstation by pressing F4, or choosing quit from the start menu

    #122450
    Profile photo of tjans
    tjans
    Participant

    finhead, thanks for the reply. I wonder why my update didn’t work then. I’ll have to keep playing with it. I tried the USB method to seed my ROMs and it worked, but I don’t agree at least for me that it’s faster with the USB. I’m part of a yearly rom hacking project and I’m constantly updating the ROM from my computer and to be able to just hit \\my.pi.ip.address\roms and dump it in the system is the quickest way for me to get updated ROMs on my pi to test out on the TV. I just prefer the finer control. Besides, having Wi-Fi working would be nice to have working for other reasons, and also I’m a geek and I don’t like my stuff in a half-working state 😉 I’m sure you can understand that!

    #122451
    Profile photo of tjans
    tjans
    Participant

    What does the rc.locale thing do? Is that so that when I reboot it keeps that setting? I’m guessing that power setting is temporary if I run it from the command line…

    #122454
    Profile photo of meneerjansen
    meneerjansen
    Participant

    What does the rc.locale thing do? Is that so that when I reboot it keeps that setting? I’m guessing that power setting is temporary if I run it from the command line…

    I wouldn’t fiddle w/ that. It sets your locales for currency, language, time and date format, etc. That too is better set via the wizard in RetroPie.

    If I were you I’d place my Pi next to my router, set the channel not to 11 (as advised by someone else) and run the blue MS-DOS like wizard. To test if it all works. Then go further from that. Good luck 🙂

    #122455
    Profile photo of tjans
    tjans
    Participant

    Alrighty, I’ll try that and report back this evening. Thanks…

    #122456
    Profile photo of zigurana
    zigurana
    Participant

    I wouldn’t fiddle w/ that. It sets your locales for currency, language, time and date format, etc. That too is better set via the wizard in RetroPie.

    I’d say, fiddle all you want, that’s what the Pi is for IMO. The entry in rc.local is indeed to make it stick. You should try it from the command line first, to see if this solves your issue.

    #122457
    Profile photo of tjans
    tjans
    Participant

    I planned on trying both. Thanks gents, will report back…

    #122460
    Profile photo of meneerjansen
    meneerjansen
    Participant

    I wouldn’t fiddle w/ that. It sets your locales for currency, language, time and date format, etc. That too is better set via the wizard in RetroPie.

    I’d say, fiddle all you want, that’s what the Pi is for IMO. The entry in rc.local is indeed to make it stick. You should try it from the command line first, to see if this solves your issue.

    Off course. The Pi’s for fiddling. However, I always try to solve one problem at the time. The locale has nothing tot do w/ WiFi AFAIK.

    #122480
    Profile photo of tjans
    tjans
    Participant

    So, a little progress, I first tried the

    sudo iwconfig wlan0 power off

    And I got it to connect, but I can’t access it via \\retropie or SSH in via the IP address, so something still isn’t right. I’ll tweak my router tonight to see if I can get an open channel. Stay tuned and thanks thus far for the help!

    #122498
    Profile photo of meneerjansen
    meneerjansen
    Participant

    That good news! And interesting to know for other Pi3 users that one had better set the WiFi chip’s power management off for optimal results.

    In my experience you preferably connect via SSH to a Linux machine by using its IP address. Using its hostname (i.e. ‘retropie’) doesn’t work as well. If your Linux machine (i.e. the Pi) is connected to a network then determine its IP address w/:

    ifconfig
    Then, in Windows, use Putty to connect to the Pi. When one uses Linux and a terminal do:

    ssh pi@192.168.0.xxx
    where 192.168.0.xxx is the Pi’s IP address. If all is well you will be asked for the Pi’s password which is “raspberry”. Dunno exactly haw that works in Windows/Putty.

    Good luck!

    #122507
    Profile photo of tjans
    tjans
    Participant

    Well, it’s back to not connecting again. I’m not sure what the deal is but perhaps the Wi-Fi is just spotty on the pi3 with Retropie and I’ll have to wait for more updates. Bummer, but I’ll just have to tether for now.

    P.S. I’m on channel 6…

    #122514
    Profile photo of meneerjansen
    meneerjansen
    Participant

    Well, it’s back to not connecting again. I’m not sure what the deal is but perhaps the Wi-Fi is just spotty on the pi3 with Retropie and I’ll have to wait for more updates. Bummer, but I’ll just have to tether for now.

    P.S. I’m on channel 6…

    I don’t know how the experiences from other users are, but I find the Pi is underpowered, no matter what power adapter I use. When I use a WiFi dongle it disconnects all the time. The connectiosn via WiFi is quirky. I was hoping this was different for the Pi3 with its on-board WiFi chip.

    If I were you I’d consult a Raspb. Pi forum or try the best power adapter (some adapters say they are 2.1 Ampere, but hey appear not to be) you can find, and connect almost nothing to your Pi’s USB ports.

    Or do the middle ages thing…: connect an UTP cable…

    #122516
    Profile photo of finhead
    finhead
    Participant

    Well, it’s back to not connecting again. I’m not sure what the deal is but perhaps the Wi-Fi is just spotty on the pi3 with Retropie and I’ll have to wait for more updates. Bummer, but I’ll just have to tether for now.

    P.S. I’m on channel 6…

    No shouldn’t be spotty, once updated it should be 100% working.
    I have been testing AttractMode with Robospin theme (think hyperspin) frontend ontop of Retropie for the last 4 days on to see if it would crash or glitch and I can login with Putty or WinSCP at any time not once has it failed.

    Are you sure you got it to update and upgrade properly?

    #122517
    Profile photo of tjans
    tjans
    Participant

    Everything seemed to jive after a few attempts. It failed to get stuff first time through each step but a second step fixed it. Not sure what the deal is.

    #122521
    Profile photo of finhead
    finhead
    Participant

    Using REtropie 3.6 and doing the updates straight from the pi? That’s what worked for me, just hit F4 and sudo apt-get update and same for upgrade. I managed to get that done in the first minute of booting (hitting F4 and the update command) so the wifi didn’t have a change to drop.

    #122524
    Profile photo of tjans
    tjans
    Participant

    I’m trying your suggestion now, finhead. I didn’t know I could drop to console with F4. It seems to be going a lot faster now…

    I am however seeing some errors like dpkg: error while cleaning up, unable to restore backup version of … read only file system and some other errors…

    #122529
    Profile photo of tjans
    tjans
    Participant

    I tried to do the apt-get stuff again and something happend corrupting my SD card, so I reimaged it and started over. It’s currently doing the apt-get update right now, so it’ll be an hour or so, i think before its done…i’ll see if this helps…

    #122530
    Profile photo of petrockblog
    petrockblog
    Keymaster

    retropie site / forum has moved – this forum is being made read only – please see https://retropie.org.uk/

Viewing 27 posts - 1 through 27 (of 27 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar