Which Arcade emulator should I focus my time on?

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! Which Arcade emulator should I focus my time on?

This topic contains 15 replies, has 3 voices, and was last updated by Profile photo of Floob Floob 2 years, 1 month ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #98166
    Profile photo of azuretyger
    azuretyger
    Participant

    I am asking this because I have been working on setting up MAME4ALL and it has been fairly time consuming to get it configured and collect a good romset. So before I invest more time in it I want to get an idea of the pros and cons of each arcade emulator.

    My goal is basically to have a good, very playable, and video/sound true set of arcade games that were popular in the U.S. from the late 70s to the early 90s. I am not interested in multiple versions, clones, or international releases. If I end up with more than 500 total games that is probably more than I want. I really just want to play the hits. I also want to resort to the use of a keyboard in game to game play as little as possible.

    From what I understand, the choices for arcade emulation in the latest image are: MAME4All, MAMEADV, FBA, and NeoGeo. I would appreciate any advice experienced users would like to share on the pros and cons of the emulators with my end goal in mind. I don’t have tons of free time so I want to make it count.

    Thanks so much for your time!

    #98180
    Profile photo of Floob
    Floob
    Member

    Well, the ones with a libretro core can offer you the standard settings such as shaders and other graphical tweaks.

    But it really is horses for courses. I install 4 different ones just to compare and contrast – saying that if you want new roms you kind of have to go with fba-libretro at the moment.
    Based on your description I would have thought either of the mame4alls should do the trick for you.

    General version info here:

    MAME versions and romsets on RetroPie

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98225
    Profile photo of windale
    windale
    Participant

    So why does everyone seem to use Mame4All ? I’m using RetroPie 3.0 and tried Mame4All and all I get is crackling sound on nearly all games even the most basic ones. I don’t know if it is something to do with a bug in SDL (which i’ve read about). I’ve tried AdvanceMAME and the sound is fine but I get a lot of screen tearing.

    #98229
    Profile photo of Floob
    Floob
    Member

    Mame4all uses the 0.375b romsets (which is about 15 years old), and as it doesnt have to emulate newer games it often runs very well speed wise.
    So its a great one to run on the non Pi2 models.

    Those romsets are also pretty easy to find compared to some of the others, so it seems to encourage people to stick with it.

    Not sure about your audio issue. Are you using a clean install image of RetroPie 3? Have you tried different HDMI and/or TV displays?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98230
    Profile photo of windale
    windale
    Participant

    Mame4All was the first thing I tried when I got my Pi 2 and was very dissapointed with the bad sound. I’ve tried the same games on AdvanceMAME and the sound is good but I get screen tearing (no VSync ?). I’m using HDMI 1.4.

    I saw a YouTube video somewhere that said SDL in RetroPie 3 was bugged and you had to reset the system to make the sound crackle go away, that doesn’t work for me. Like I said, AdvanceMAME using the same games (obviously different ROM versions) don’t have bad sound.

    #98232
    Profile photo of Floob
    Floob
    Member

    Is that the libretro core as well as the standalone mame4all?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98233
    Profile photo of windale
    windale
    Participant

    The sound doesn’t crackle on lr-imame4all but the compatibility is terrible, some games had no music and wrong aspect ratio (bad dudes, squashed screen), some didn’t work and some I couldn’t start because the buttons didn’t work.The games I tested work on AdvanceMAME and Mame4All (with crackling sound). It looks like I’ll have to stick with AdvanceMAME 1.2.

    #98236
    Profile photo of Floob
    Floob
    Member

    I’m not sure what to suggest with mame4all, I run it without any sound issues.
    As I have the same Pi and RetroPie image as you (unless you have changed settings) I can only think its related to the HDMI cable or TV?
    (I’m assuming you are using verified 0.37b5 romsets)

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98241
    Profile photo of windale
    windale
    Participant

    I got the HDMI cable with my Pi package from the PiHut. I have a complete verified 0.37b5 romset that i’ve had for years from my GP2X days. I also have the latest Rollback roms so I can rebuild any version Romset (used for AdvanceMAME). Mame4All is the only emulator that I get crackling sound with, all the rest work fine. Oh well.

    #98244
    Profile photo of Floob
    Floob
    Member

    Ok, maybe you’ll need to stick to other emulators like advance of fba then.

    Perhaps it would be worth trying it against a 2.6 setup, to rule out any changes in the build that are affecting your setup.
    That said, if you are happy running advancemame, no real point in trying to get others working.

    For reference (I know you have it running though, so more for others benefit) here is a mame4all setup running:
    http://dai.ly/x2hunh4

    Here is Bad Dudes on mame4all on mine (RetroPie 3 beta 2), not sure if the ratio is correct, but it would be quite playable if I wasnt so bad.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98248
    Profile photo of windale
    windale
    Participant

    Would the crackling sound have anything to do with the refresh rate of my TV ? I’m on 50Hz most of the time (i’ve set it to 60Hz for US Console roms). Maybe the reason I don’t get crackling sound on AdvanceMAME because there’s no VSync (I get a lot of screen tearing). Just out of interest, is your TV running Mame4All at 50Hz or 60Hz ? Or doesn’t it matter ?

    I might try a RetroPie 2.6 setup tomorrow just out of curiosity. Thanks for replying.

    #98252
    Profile photo of Floob
    Floob
    Member

    Thats a good point, it may well be related to the 50Hz/60Hz, or certainly something in the video signal anyway.

    My TV used here is a Sony KDL-26EX553:
    http://pdf.crse.com/manuals/4411984131.pdf

    I can only presume it auto switches to the appropriate mode, but I’m not sure how to tell if its showing me the display in 50Hz or 60Hz.

    You could probably set an override using these settings
    http://elinux.org/RPiconfig

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98254
    Profile photo of windale
    windale
    Participant

    I’ll check it out tomorrow as I’m not at home at the moment. Thanks.

    #98256
    Profile photo of azuretyger
    azuretyger
    Participant

    For myself, I have always loved Tournament Cyberball 2072 and even have an original cabinet in my garage. Using the same .375b ROM on MAME32 on my PC or MAME4iOS in my iPad I get a very accurate game with good speed, sound, and visual. On MAME4All it is pretty good, but the aspect ratio gets stretched in widescreen and I get artifacts in the video and occasional stutters in gameplay.

    #98295
    Profile photo of windale
    windale
    Participant

    I just thought i’d let you know, I set my TV to 60Hz when using Mame4All and now the crackling sound has gone.

    #98299
    Profile photo of Floob
    Floob
    Member

    Thats great! Thanks for checking it out, I’m sure that will help others with the same issue.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar