Where to put gba bios file in retropie

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Where to put gba bios file in retropie

This topic contains 19 replies, has 10 voices, and was last updated by  caseyjames 2 years, 10 months ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
  • #4103


    I know it goes into the home/pi/RetroPie/emulators/gpsp/raspberrypi/ directory but how do you get it into that directory. I’m a noob so please help.



    Are you using cyberduck? You can drag it in from there.



    No, I use winscp. I put it in the roms folder and it still doesn’t work, I just can’t find the gpsp directory to put it in.



    I would suggest dumping the bios into the GBA rom directory via FTP/SAMBA, then SSH into the machine (or connect a keyboard and quit out of EmulationStation), and move from the GBA rom directory to the one you mentioned.

    Of the top of my head this should do it I think:

    cd into the GBA ROM directory
    mv gba_bios.bin /home/pi/RetroPie/emulators/gpsp/raspberrypi/ 

    you shouldn’t need root to use the command but just in case just add ‘sudo’ in front of the mv command.

    You won’t be able to find the correct directory on another machine (via FTP or SAMBA) as it isn’t shared, the only way is to manually copy it via the RaspberryPi.

    Hope this helps!!



    Thanks. finally got it working.



    Ok I am new to this and I have got most of the systems running fin but I have issues with neo geo I have a bios but do I just leave it zipped and put it with the games then their is the is the gba which needs me to add the bios to a folder I cant get to due to the filezilla not working on retropie I dont kow how to now I did create folder called gpSP like the started to show me in a video but then the video showed me to get and install threw a dropbox linkan d it didnt’ work I have the file sitting in the GBA rom folder and cant’t get it to work.can some one help me out. please.



    I tried what smartroad posted and i got “no such file or directory”

    my bios file is in the gba rom directory, but there is no evidence of an “emulators” directory in /home/pi/RetroPie/

    I have used the RetroPie image and used WinSCP to move my roms and the bios file



    If you have the “new” retropie image (2.0 and higher) the retropie folder moved to /opt/retropie/. So you have to move the gba.bios to /opt/retropie/emulators/gpsp/raspberrypi/



    found it! I thought I was doing something really wrong when I couldn’t find any of the directories in /pi/RetroPie/

    Thanks Mutex!



    I have a problem adding the GBA bios file as my permission was denied



    you need to do it from terminal with sudo command.


    $ sudo cp /home/pi/RetroPie/ROMS/GBA/gbs_bios.bin /opt/retropie/emulators/gpsp/raspberrypi/

    All on one line.



    Winscp made my life easy I had to drag it from the left window instead of straight from desktop this is assuming you are using Windows of course…

    Raspberry Pi B 512mb
    Generic 64gb SD
    Overclock Turbo

    Raspberry Pi B+ 512mb
    Generic 128gb MicroSD
    Overclock Turbo

    Raspberry Pi2 B 1gb
    Samsung Evo 16gb MicroSD
    Overclock Pi2



    Im quite interested in solving this problem. I have the most recent build of retropie, and I do not know where to put the bios file for the GBA. I have it named correctly, but I am still getting a bios error as if it isnt where it is supposed to be.



    My bad, I figured it out from previous posts. It was that you have to go in manually, cant use the ssh.



    Hey there, I am new to the GBA thing. Can someone tell me where this bios file needs to go, and where do I get the file (is it already there or do I need to download it somewhere else? I am running retropie 2.3.



    As this was the first hit on google, hopefully noone gets upset that I’m necro’ing this thread.

    To answer a few questions on here (that may/may not have been answered already above):

    The GBA Bios is proprietary, so it’s of the user’s own accord to find it (just like ROMs). If you happen to have access to a bios already, with the newer versions of RetroPie (2.0+) you can find the location to place the bios at:


    Note, if you’re using Samba to connect to the Pi (which would be how you likely got your ROMs onto it), you won’t have access to this location unless you modify the smb.conf file at /etc/samba/smb.conf. An easier ‘one-time’ method, as described above, is to place the bios in the roms folder, ssh into the Pi, and cp it to the location above. However, here’s what you can add to the smb.conf file to provide yourself access to other parts of the Pi through Samba (this would also be done by ssh’ing into the Pi, and is useful if you plan on doing other modifications):

    comment = root
    path = /
    writeable = yes
    guest ok = yes
    create mask = 0777
    directory mask = 0777
    force user = pi

    Now you should see a ‘root’ folder pop up along with the roms folder. Note that this will provide you read access, but not write access, as all of the files and folders outside of /home/pi are owned by root. To give yourself write access, you can use the ‘chown’ (short for change owner) command:

    sudo chown -R pi /opt/retropie/

    This will give you write access, and let you drag + drop the bios into the respective folder. I would suggest you change the owner back to root when you are done (just change ‘pi’ in the command above, to ‘root’), for security purposes.

    EDIT: I forgot to mention to not run this on /etc/ . If you do, you’ll change the ownership of the /etc/sudoers file, which will prevent you from running sudo. This will place you in a rather annoying catch-22 (which you’ll either need to reboot into recovery mode for, have a root account password created prior, or running pkexec on /etc/sudoers to change ownership back)

    EDIT2: Before you recursively chown your /opt/retropie directory, you may want to take note of the ownership of the directories within (ls -l). For example, /opt/retropie/configs/ should probably be owned by the pi user (or atleast have write access) as this is where your controller configs reside, and to write new ones (through the RetroArch menu, for example), write access will of course be needed.



    in the image 2.4.2
    the sub directory raspberrypi\
    seems to be missing. has the bios location changed?



    chito, I had the same issues running 2.4.2 but I was able to find the root directory of gpsp going one directory at a time. Here are my detailed instructions. The “quotes” should not be included in the code, but otherwise that is the text I entered.

    The new file directory is here: opt/retropie/emulators/gpsp/

    how to get gba games to work on retropie (using 2.4.2)

    press f4 to exit emulation station

    type “cd /” to go to top root folder
    “cd opt”, you can see the files/folders in each directory by typing “ls”, if desired.
    “cd retropie”
    “cd emulators”
    “cd gpsp”
    this is the root folder of gpsp in 2.4.2 (opt/retropie/emulators/gpsp/). If you type “ls”, you can see the program gpsp is in this folder. The error message said to save gba_bios.bin here.
    To download gba_bios.bin, first download the zip file by typing
    “wget http://www.roms4droid.com/files/bios/gba_bios.zip
    to unzip type
    “unzip gba_bios”
    This unzips your file and you now have gba_bios.bin saved in the same folder as the emulator gpsp.
    Type “emulationstation” to start emulation station and choose GBA (assuming you have already transferred over your roms)

    I want to emphasize the steps below will work on any version of retropie:
    To download gba_bios.bin, change directory until you are in the same directory as the program gpsp (opt/retropie/emulators/gpsp/ for 2.4.2, /opt/retropie/emulators/gpsp/raspberrypi/ for 2.0 to 2.3, home/pi/RetroPie/emulators/gpsp/raspberrypi/ for earlier versions.)

    Download the zip file by typing
    “wget http://www.roms4droid.com/files/bios/gba_bios.zip
    to unzip type
    “unzip gba_bios”
    This unzips your file and you now have gba_bios.bin saved in the same folder as the emulator gpsp.



    Thanks heaps. I found my answer eventually. Im pretty sure it was in this tread. but i cant find the post that show me how. anyway thanks heaps.



    Hey I got an Idea I know works.One u get your bios .Take your sdcard put it in a linux machine then all you have to do is put it in the floder it needs.No commands required.Just drag and drop

Viewing 20 posts - 1 through 20 (of 20 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss