Whats your OverClock settings? :)

This topic contains 102 replies, has 59 voices, and was last updated by Profile photo of raymate raymate 1 year, 3 months ago.

Viewing 35 posts - 1 through 35 (of 103 total)
  • Author
    Posts
  • #2077
    Profile photo of karloss
    karloss
    Participant

    Hey, just wondering what people have as their overclock settings, with my settings I have near perfect playback of all systems, and PSX plays perfect.

    arm_freq=1000
    gpu_mem=384
    avoid_safe_mode=1
    core_freq=500
    sdram_freq=500
    over_voltage=4
    force_turbo=0

    #2145
    Profile photo of petrockblog
    petrockblog
    Keymaster

    For the sake of “completeness”: The SD-card image comes with the over clock settings “medium”:

    “900MHz ARM, 333MHz core, 450MHz SDRAM, 2 overvolt”

    #2156
    Profile photo of Adam Wright
    Adam Wright
    Participant

    Hey, just wondering what people have as their overclock settings, with my settings I have near perfect playback of all systems, and PSX plays perfect.

    arm_freq=1000<br>
    gpu_mem=384<br>
    avoid_safe_mode=1<br>
    core_freq=500<br>
    sdram_freq=500<br>
    over_voltage=4<br>
    force_turbo=0

    Have you noticed any crashing with these settings?

    I tried to put my pi on the maximum overclock settings using the raspi-config tool and as soon as I rebooted and went to emulationstation it crashed.

    #2170
    Profile photo of karloss
    karloss
    Participant

    Hey mate, with these settings I have no crashes, I believe the overvolt makes the difference..

    #2253
    Profile photo of fungus
    fungus
    Participant

    thank you for the info karloss, i used this setting and my raspi goes better than anytime. i repost ur settings in other forum i hope u dont matter. this is the link ( sorry my english is horrible)

    #2664
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hey, just wondering what people have as their overclock settings, with my settings I have near perfect playback of all systems, and PSX plays perfect.

    arm_freq=1000<br>
    gpu_mem=384<br>
    avoid_safe_mode=1<br>
    core_freq=500<br>
    sdram_freq=500<br>
    over_voltage=4<br>
    force_turbo=0

    Thanks for sharing your settings, Playstation is pretty playable on latest image with these settings, just a bit more tweaking and it will be there. Which emu are you using by the way? Have you gone any higher with the overclock?

    If you have found the solution to your problem please mark the topic as resolved.

    #2713
    Profile photo of jplaj
    jplaj
    Participant

    I’m on 800, and I’d like to bump it up a little more to fix problems with PSX, but I’m not sure about it. The term “overvolting” seems a little intimidating. Could someone explain what that means?

    Also, one website said class 10 cards have corruption issues with overclocking. Has anyone had issues with this?

    #2717
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    I’m on 800, and I’d like to bump it up a little more to fix problems with PSX, but I’m not sure about it. The term “overvolting” seems a little intimidating. Could someone explain what that means?

    Also, one website said class 10 cards have corruption issues with overclocking. Has anyone had issues with this?

    I had problems with my Transcend class 10 card corrupting so now run off USB. Not all cards are the same though, some work better than others.

    you can overclock your Pi without voiding your warranty (make sure you have a decent power supply):
    sudo raspi-config
    option 7

    And select one of the overclock settings:
    oc

    I have had no problems with the settings in the original post above, temperature never goes above 60C. Check your temperature with:
    cat /sys/class/thermal/thermal_zone0/temp
    (divide by 1000)

    If you have found the solution to your problem please mark the topic as resolved.

    #3208
    Profile photo of ordenrahl
    ordenrahl
    Participant

    Hey, just wondering what people have as their overclock settings, with my settings I have near perfect playback of all systems, and PSX plays perfect.

    arm_freq=1000<br>
    gpu_mem=384<br>
    avoid_safe_mode=1<br>
    core_freq=500<br>
    sdram_freq=500<br>
    over_voltage=4<br>
    force_turbo=0

    That looks great, a couple extra settings altered here than I can find in the Raspi Config.

    But WHERE do I make these changes? what is the file name and location that I need to edit. Thanks!!

    #3209
    Profile photo of ordenrahl
    ordenrahl
    Participant

    Sorry, Meant to say:

    That looks great, a couple extra settings altered here that I CAN’T find in the Raspi-Config.

    Thanks.

    #3732
    Profile photo of dmoojunk
    dmoojunk
    Participant

    These settings are great, emulation station would crash on load with out of the box turbo settings enabled. This plays all snes/genesis perfectly. Many thanks!

    #3881
    Profile photo of supersirlink
    supersirlink
    Participant

    Sorry, Meant to say:

    That looks great, a couple extra settings altered here that I CAN’T find in the Raspi-Config.

    Thanks.

    These settings go in the config.txt located in /boot

    #3896
    Profile photo of RetroMarine
    RetroMarine
    Participant

    I tried this and it won’t let me edit config.txt…it says I don’t have the permissions in cyberduck. Wtf

    #3901
    Profile photo of motorhead
    motorhead
    Participant

    You must be root for this.

    First you need to define a root password, try this:

    sudo passwd root

    If you are using a USB keyboard and the TV directly use:

    su

    Then write root password and you can do anything.

    If you are using SSH or FTP then try to connect using user root not pi: root@192.168.1.X

    #3927
    Profile photo of supersirlink
    supersirlink
    Participant

    Don’t use root, just SSH on and do sudo nano /boot/config.txt

    #4047
    Profile photo of moorens
    moorens
    Participant

    900MHz ARM, 333MHz core, 450MHz SDRAM, 2 overvolt

    I am using a class 10 San Disk. Anything over this setting and I often get SD corruption. Backup that image.

    #4049
    Profile photo of Coolname
    Coolname
    Participant

    I’ve had these since I found them online (can’t remember where) and I’ve had no crashes caused by them. Of course, I am still fiddling around to get the whole project working perfectly, but when I stop to play, these work wonders and actually allow me to play some decent PS1 games with a very little lag (like Spiderman, which is pretty open and all 3D) and the lag I had on MAME (noticeable when playing Final Fight) is gone.

    arm_freq=930

    core_freq = 500
    sdram_freq=500
    over_voltage=6
    gpu_mem=250

    Still learnin', but ideas and motivation be flowin'!

    #4095
    Profile photo of whiskey
    whiskey
    Participant

    I am playing with the OC settings on my pi, and wondered what power supply are you all using? Right now my pi is powered from the USB port on my TV, which is probably not supplying enough power for OCing, and somewhere around my house I have a spare 5v 1amp USB charger plug from an old phone I can use, but I haven’t tried that yet. I’m assuming the “over_voltage” parameter is increasing the amperage the pi is consuming?

    #4098
    Profile photo of RetroMarine
    RetroMarine
    Participant

    I’ve tried all the preset OC settings on raspi-config as well as the settings mentioned in this thread, and I can’t get any of the Crash Bandicoot games on PSX to run smoothly. Am I missing something?

    #4580
    Profile photo of mattmartinolc
    mattmartinolc
    Participant

    My Pi is connected to a 5.1v 2.1amp power supply. I put on heatsinks and a fan that is wired to a separate universal adapter. With this I can run the following overclock without crashes

    arm_freq=1130
    core_freq=560
    h264_freq=360
    isp_freq=0
    v3d_freq=360
    sdram_freq=675
    over_voltage_sdram=6
    over_voltage=8
    temp_limit=80
    avoid_pwm_pll=1

    Temperature never exceeds 40celcius but usually hovers around 36celcius.

    #4925
    Profile photo of retrofredde
    retrofredde
    Participant

    Mine runs at 1020 mhz right now, with the core at 520 and sdram at 580, over voltage 5, gpu ram 384, with heat sinks and it stays at 59.9 degrees celsius after stresstesting it. Too close 😛
    I tried to go higher but it froze so I pushed it down a notch so that’s why I have so uneven figures.

    I still can’t play ps1 games at full speed though. Most 2D games I’ve tried like Suikoden and Strikers 1945 runs at 60fps but 3D games usually runs at 40-50fps depending on how much is going on, Raiden 2 goes down to 45 fps at times too. I still have some screen resolution configurations to try out though so hopefully I can get it a little bit better.

    #5029
    Profile photo of karloss
    karloss
    Participant

    change your gpu ram to 128, i read somewhere that neither the psx/n64 can run with more than that, and running with higher than 128 cause swap file slow down..

    #5625
    Profile photo of oneeyedphoenix
    oneeyedphoenix
    Participant

    “gpu_mem=128” confirmed superior to “gpu_mem=384” for psx emulation on my 1.91 setup (at least on FF7), with the rest of the setting similar to those of the OP. It improved emulation from about 95% smooth to 98% smooth (loading new animations still lag a little, but repeating them lag a bit less).

    #6056
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    Just asking:
    I am using my RetroPie Pi to emulate Atari, NES, SNES, SMS, and Megadrive, mainly. Would you still recommend overvolting the Pi, or just stay on non-overvolted overclock settings? I’m on Medium right now but if it is not absolutely necessary I guess I will go down to Modest (i.e. no overvolting) to improve lifetime of the Pi.
    I suppose I should go higher for NeoGeo or MSX emulation, right?
    Thanks for helping!

    To defeat them is a must and bringing peace to the land is my duty

    #6059
    Profile photo of jplaj
    jplaj
    Participant

    There shouldn’t be any need to overclock for any of those systems. They’ll run perfectly on the basic setting.

    I’ve only had performance issues with PSX, and overclocking doesn’t seem to help that, so I’d say there’s no need.

    #6077
    Profile photo of vcolombo
    vcolombo
    Participant

    I’d be interested in more details about your configuration and how you’ve gotten those emulators to run at full speed without any overclocking. I’ve been trying to play Super Metroid and cannot get that to run full speed unless I overclock to Turbo (1000 Mhz), but when I do that my Pi is unstable and will inevitably crash. The highest overclock setting that works for me is the 950 Mhz, but that still leaves Super Metroid lagging.

    Thanks,

    Vince

    #6100
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    I don’t use any special configurations for the basic emulators. My overclocking settings are on Modest (no overvolting). Have you tried other SNES games to see if they work? I believe Super Metroid is a 24Bit game. I can tell you that I haven’t been able to play any Sega 32X games; they all stutter and are unplayable. So maybe that is the problem with that specific game.
    NES, SNES, Megadrive, SMS are all working perfectly for me. ZX Spectrum, Atari2600, AmstradCPC are working too. MSX goes well for most games, but some might get very slow. FBA for NeoGeo games works well for some games (like Snow Bros and Cadillacs and Dinosaurs), while some cannot be executed (something that has to do with emulation itself; e.g. Metal Slug or KoF).

    To defeat them is a must and bringing peace to the land is my duty

    #6528
    Profile photo of kitchuk
    kitchuk
    Participant

    I don’t use any special configurations for the basic emulators. My overclocking settings are on Modest (no overvolting). Have you tried other SNES games to see if they work? I believe Super Metroid is a 24Bit game. I can tell you that I haven’t been able to play any Sega 32X games; they all stutter and are unplayable. So maybe that is the problem with that specific game.<br>
    NES, SNES, Megadrive, SMS are all working perfectly for me. ZX Spectrum, Atari2600, AmstradCPC are working too. MSX goes well for most games, but some might get very slow. FBA for NeoGeo games works well for some games (like Snow Bros and Cadillacs and Dinosaurs), while some cannot be executed (something that has to do with emulation itself; e.g. Metal Slug or KoF).

    I have a over clock of 900/333/500 with 4 overvolt and I can run Metal Slug and KOF Flawlessly at 60fps. Are you using PiFBA instead of the RetroArch core. PiFBA has much better performance.

    #6530
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    I have a over clock of 900/333/500 with 4 overvolt and I can run Metal Slug and KOF Flawlessly at 60fps. Are you using PiFBA instead of the RetroArch core. PiFBA has much better performance.

    Indeed I am using PiFBA outside of the RetroArch core (fba2x command, right?). The problem is not performance, because these games never actually get to load. They go by that first screen where the files get loaded (the yellow bars), and nothing happens after that. I would say it doesn’t have to do with overclocking, but who knows.
    We’ve been discussing about this in a thread specifically related to NeoGeo, if you could visit said thread you might be really helpful to me and the other people. Thanks!

    To defeat them is a must and bringing peace to the land is my duty

    #6706
    Profile photo of sunjammer
    sunjammer
    Participant

    @hacha-dorada:
    Try lowering your memory split. I had same issues as you. After lowering gpu_mem from 384 to 256 (or even 128) (on a Raspberry with 512 MB RAM) now almost every neogeo game runs with pifba (source installed).
    Please take a look at http://www.raspberrypi.org/forums/viewtopic.php?f=78&t=50587 for more help.

    #6781
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    @sunjammer:

    I already have my memory split set at 128, on my Model B. I installed PiFBA from the sources through the script. Maybe I should compile from diferent sources? Get ROMs from a different source?
    I have two kind of failing ROMs. Some just go on to a blank screen and then go back to ES. The rest go through the yellow loading bars and then fail.

    To defeat them is a must and bringing peace to the land is my duty

    #6800
    Profile photo of kitchuk
    kitchuk
    Participant

    Do you have the neogeo.zip in the same directory as your roms?

    #6801
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    Do you have the neogeo.zip in the same directory as your roms?

    Indeed. I have all the bios files in the ROM folder. Maybe the files are corrupted/incorrect?
    I’d appreciate if someone could provide me a working link with the bios files and a Metal Slug ROM so I can check if there is a problem with the files.

    The admins should probably move this last series of posts regarding Neo Geo to a different thread.

    Thanks all for helping out with this.

    To defeat them is a must and bringing peace to the land is my duty

    #6853
    Profile photo of hacha-dorada
    hacha-dorada
    Participant

    So most NeoGeo games are finally working with a new neogeo.zip file provided by one generous user. I got the old one from a ROM pack, probably it wasn’t the right one.
    Thanks to all!!

    To defeat them is a must and bringing peace to the land is my duty

    #8820
    Profile photo of Cael
    Cael
    Participant

    Hey, just wondering what people have as their overclock settings, with my settings I have near perfect playback of all systems, and PSX plays perfect.

    arm_freq=1000
    gpu_mem=384
    avoid_safe_mode=1
    core_freq=500
    sdram_freq=500
    over_voltage=4
    force_turbo=0

    i used pretty much the same except i couldnt go any higher than 950ARM w/o a boot-panic.

Viewing 35 posts - 1 through 35 (of 103 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar