What controllers are you using?

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie What controllers are you using?

This topic contains 185 replies, has 124 voices, and was last updated by Profile photo of meneerjansen meneerjansen 1 year, 3 months ago.

Viewing 35 posts - 71 through 105 (of 186 total)
  • Author
    Posts
  • #14792
    Profile photo of eyanez
    Eduardo Yáñez

    Just setup today a X-Arcade Dualstick (not Tankstick) with USB adaptor, but needed to hack a little bit the source code of Xarcade2Jstick (very easy hack).

    #15388

    Haris

    I use a wireless ps3 controller

    Although it works ok there are 2 probs:

    1- sometimes it wont connect.Lights wont stop flahing too:(

    2- i can configure it with all emulators except for MAME 🙁 i tried some tricks but in no avail. If anyone has done it please let me know

    #15697
    Profile photo of deaftolight
    deaftolight
    Participant

    Are you able to get the PS3 controller to always remember your pairing? Mine does sometimes, but sometimes it doesn’t. Sometimes it won’t register as a js#, and I have to reboot. I wonder if it has anything to do with when you turn it on… I’m thinking if I turn it on too early, before the Raspberry Pi is done booting, it won’t get recognized. I have yet to test this more, because at the moment I just cross my fingers everytime I start it up.

    Also, the lights don’t stop flashing and it doesn’t auto shut off, which is annoying because if you forget to turn it off (which requires holding the PS button for like 15 whole seconds), the battery dies quickly.

    #15775

    Haris

    Some times it connects , sometimes not and have to reboot.

    But i think i have found a trick for that. I push the PS button only when EmulationStation splash screen starts.

    Only drawback is that you have to remap es buttons everytime you start it

    Havent found a solution for constant flashing though, it is smth with the bt drivers i believe

    #16316
    Profile photo of atimmins
    atimmins
    Participant

    Has anyone else tried those adapters to plug in an original nes controller to a usb slot? I have these ones (http://www.amazon.com/RetroBit-Adapter-Controller-Nintendo-Entertainment-System/dp/B004L5KHKS) and they doesn’t seem to register some of the d-pad buttons. They worked fine on my windows 7 computer.

    Is there any hope of this ever working? If I bought the nes controllers already converted to USB would I have better luck?

    Also, is it possible to assign snes controllers to players 1 and 2 and nes controllers to players 3 and 4 so I can use the appropriate controller for the system? Can you use different types of controllers together?

    #18232
    Profile photo of
    Anonymous

    I use a F310 logitech (xbox?) and I am lost.
    I can browse into the UI, start a game, but subsequently lost all controls once it starts.
    where do I need to start?

    #18640
    Profile photo of atimmins
    atimmins
    Participant

    I use a F310 logitech (xbox?) and I am lost.
    I can browse into the UI, start a game, but subsequently lost all controls once it starts.
    where do I need to start?

    Sounds like you set up the controller for emulation station, but not for the actual emulators. There are some step by step guides on the forum you can follow.

    #18658
    Profile photo of
    Anonymous

    <div class=”d4p-bbt-quote-title”>regis57 wrote:</div>
    I use a F310 logitech (xbox?) and I am lost.
    I can browse into the UI, start a game, but subsequently lost all controls once it starts.
    where do I need to start?

    Sounds like you set up the controller for emulation station, but not for the actual emulators. There are some step by step guides on the forum you can follow.

    Hi, thanks for your optimism. This is as it works out of the box for me.
    To make it works inside emulator I need guidance on how to proceed and did not succeed at finding something similar on your forum 🙁 please point out a topic I can start with.
    Thank you
    Regis

    #19800
    Profile photo of avatar2200
    Avatar2200

    I use the iBuffalo USB controllers (snes style). I tried many other “nes/snes” style controllers (retrolink etc.) and they all had a very bad quality. Sometimes the buttons didn’t response, I was really disappointed. The iBuffalo have an absolutely awesome quality, they’re definitely worth the price. Near to the original ones by nintendo. As a bonus, they have programmable autofire (turbo) keys.

    Here some pics of them, combined with my raspberry 🙂

    https://imageshack.com/a/lAeF

    If you want to, i can provide my controller config for the iBuffalos.

    #20080

    bolch

    Using a Dreamcast arcade stick… however I’ve removed the controller board from that and replaced it with a Raspberry Pi for an all in one solution. The controls are plugged into the GPIO ports and I’m running Adafruit’s retrogame.c to map the GPIO to keyboard presses.

    Inside
    https://www.dropbox.com/s/gpi4g8v7mtm77jw/2014-07-26%2014.09.30.jpg

    Outside
    https://www.dropbox.com/s/uw2nflz2u1waxl8/2014-07-26%2014.11.59.jpg

    #20134

    ZeBlob

    I use the Tomee USB SNES Controller, it’s a good controller. The feelings are pretty good. Maybe the DPad is a little bit “mushy”, else all is good !

    #25008
    Profile photo of rickd99
    rickd99
    Participant

    Some tips for those of of you having problems setting up the wired Logitech F310: I followed the steps exactly as outlined in the following thread after starting from a fresh install of RetroPie v 2.3:

    http://dfarq.homeip.net/2014/07/the-logitech-f310-on-retropie/

    After following this procedure I went into the MAME emulation and was able to set up most controller buttons by hitting the Tab key on my keyboard but I was unable to use the D-pad functions at all. I noted in another thread that someone mentioned that to get the D-pad working you needed to turn on the mode button. Sure enough when I did this I was able to set up the D-pad buttons to my liking. With mode turned on all buttons seem to be active except for the left and right joy sticks and the left and right trigger buttons. Also note that you should have the switch on the bottom of the controller set to X (the D setting does not seem to work with the above procedure).

    I can vouch for this procedure working for MAME emulation but I have not tried any of the other emulators. Hope this info helps…

    #26467
    Profile photo of merlin2049er
    merlin2049er
    Participant

    I’m using an xbox usb controller. I need to reconfigure it. How is that done?
    I’m using the latest retropie image.

    #26970

    Mike

    to whoever was asking about the usb PS2 controller adapter that you plug 2 PS2 controllers into, I HIGHLY recommend going that route. PS2 controllers are great, assign the digital pads as your input and press the analog button on the controller to switch to analog stick input.

    I think you can plug and unplug the controllers while in use, I’m not sure though, I usually just keep them both plugged in.

    here’s how I set them up for retropie in the retroarch.cfg file with save and load state goodness, hold in select and press R1 for save, select and L1 for Load state, and select and start to exit emulator.

    input_player1_joypad_index = “0”
    input_player1_b_btn = “2”
    input_player1_y_btn = “3”
    input_player1_select_btn = “8”
    input_player1_start_btn = “9”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0”
    input_player1_a_btn = “1”
    input_player1_x_btn = “0”
    input_player1_l_btn = “6”
    input_player1_r_btn = “7”
    input_player1_l2_btn = “4”
    input_player1_r2_btn = “5”

    input_player2_joypad_index = “1”
    input_player2_b_btn = “2”
    input_player2_y_btn = “3”
    input_player2_select_btn = “8”
    input_player2_start_btn = “9”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “1”
    input_player2_x_btn = “0”
    input_player2_l_btn = “6”
    input_player2_r_btn = “7”
    input_player2_l2_btn = “4”
    input_player2_r2_btn = “5”

    input_enable_hotkey_btn = “8”
    input_exit_emulator_btn = “9”
    input_save_state_btn = “7”
    input_load_state_btn = “6”

    #29457
    Profile photo of hadibus
    hadibus
    Participant

    I’m using a blue wireless rock candy ps3 controller

    Blue wireless rock candy ps3 controller

    It comes with a wireless dongle and is recognized as a regular controller (I mean it doesn’t require ps3 controller driver installation). I just plugged it in and ran the retroarch configuration. It works great.

    #31076

    rms13

    any tips on setting up multiple Retrolink pads? I did the initial config with a Retrolink SNES usb pad and it works great. I bought a Genesis 6 button Retrolink. I tried to run the config again but I notice there are no options for the x, y, z buttons. The Genesis pad works but only 2 buttons.

    #32027
    Profile photo of theroamer
    theroamer
    Participant

    I’m using a ps3 controller. Works great plugged in via usb. Works in mame over bluetooth but I have yet to get nes/snes to recognize it over bt.

    #37910

    GreenHoodyGuy

    I have two usb snes controllers but when i try to set them up the down button also gets mapped to the b button and the left button gets mapped to the y button. Does anyone have any idea as to how i can fix this?
    Much appreciated!

    #37985
    Profile photo of akerius
    n00bStuck

    Im using an arcade setup with xinmo. However I can’t get the up and left (or right, can’t remember) to work. Any help is much appreciated.

    #39102

    Advait

    has anybody used teensy in emulation station AND emulators?
    if yes then teach us master!!!!!(whoever u r)

    #45007
    Profile photo of natedgreat3
    natedgreat3
    Participant

    Using 2 of these controllers:
    http://www.amazon.com/gp/product/B00FFL7WRS

    Can get one to work, but not the other (in default RetroArch, in PiSNES they do work). Have tried both registering a retroarch controller and setting them up via retroarch.cfg. Any idea what could be wrong?

    #46544
    Profile photo of RippinAndTyrion
    RippinAndTyrion
    Participant

    I use Logitech Precision gamepad and Logitech Cordless Rumblepad 2. Both are really comfortable and work really well with RetroPie. Not sure if you can still get them new.

    #49279

    shrapnel09

    Hey all, just got the pi a few weeks ago for the retropie project. I’m a bit of an enthusiast in trying trying to get my personal ‘retro experience’ project up and going.

    For controllers my end goal is do have this: . Most of the controllers will be originals I already own but I would have USB adapters, just not sure how well they would work with the Pi.

    I’m still new and not even sure how to map individual controller buttons to individual emulators, so I have a way to go yet, any assistance would be awesome! Thank you! 🙂

    #49284

    shrapnel09

    Huh, cant seem to find a way to preview or edit but I’ll try to show my controller setup again:

    #51285
    Profile photo of abenamou
    abenamou
    Participant

    I was using the Neo Geo X controllers (USB) on a previous RetroPie build with no issues (pre 2.x), however I can’t seem to get Emulationstation 2 or the NES emulator to recognize it on 2.3.

    Any ideas?

    #51716
    Profile photo of hbg1968
    hbg1968
    Participant

    I am using a Soniq PS3 Controller (Bluetooth capable) via a USB hub. I have managed to get it working on PS1, but as yet still nothing on Mame. It says it detects when starting Mame (under a different driver name).

    Attachments:
    #55129
    Profile photo of andthecookies
    andthecookies
    Participant

    I am using a USB adpater in tandem with a Sega Saturn controller.

    I highly recommend the Saturn pad. It has the best control pad I know to exist, and having 6 face buttons is marvelous.

    The adapter I have also supports N64, PS1 and PS2, which I have confirmed all work with the Pi.

    #56686
    Profile photo of apedroid
    apedroid
    Participant

    I use the iBuffalo USB controllers (snes style). I tried many other “nes/snes” style controllers (retrolink etc.) and they all had a very bad quality. Sometimes the buttons didn’t response, I was really disappointed. The iBuffalo have an absolutely awesome quality, they’re definitely worth the price. Near to the original ones by nintendo.

    I totally agree. I first got a pair of RetroLink NES controller believing they would be better than all the cheap “noname” NES controllers. Really disappointed. They look good, I give them that, but the D-pad is bad and on one of them the A button gets stuck down every now and then.

    So I bought one iBuffalo SNES controller and one iBuffalo Famicom controller (Famicom = Japanese NES). Both are way better than the Retrolink ones but the D-pad is much better on their SNES controller. I would prefer the Famicom for NES games due to the correct button placement for NES but the D-pad is so much better on the SNES controller so that’s the one I end up using. Probably getting another one for two player games.

    #66008
    Profile photo of jameshartzog
    jameshartzog
    Participant

    I am having a problem with using my keyboard. I have tried 2 different ways to install Retropie on my Raspberry pi. Both have the same results. I downloaded a retropie image and restored that to my SD card and put into my raspberry pi. When it boots up, it starts ES, and comes up that no Gamepads detected, hold a button to configure. I press any key on my keyboard and ES shows on screen that that input is from my keyboard. I can go down the list setting keys for U, D, L, R, A, B, Select, etc, but then when that is done, the OK button becomes highlighted, but nothing I press will continue forward. If I press F4, it will exit ES. When I start ES again, it tries to do the same thing again. I have also changed my SD card to a fresh install of Wheezy and proceeded to us the Retropie_setup script and when it is finished, I get the same results with keyboard setup. What am I doing wrong? I did try to find that answer myself, but either my searches are missing something or this is a “me only” problem. Help!

    #68207

    Edward Mangion

    Hey,the USB NES controller you got of amazon, have you opened it up?
    I know, random question, but in need of a picture of the PCB for a project.
    If you could reply with one I’d be rather greatful!
    Many thanks, Edward.

    #77022
    Profile photo of
    Anonymous

    Hi Everyone, I do not have a Raspberry Pi yet (I am just taking stock of what’s needed ATM), I was considering controllers and saw this thread.

    In an ideal world I’d use a single controller for all console emulations, but finding the right one that will work for all seems tricky.

    I am not precious about having snes, n64 or megadrive styled controllers specific to each emulation, just after generic controllers that work ideally for as many console emulations as possible.

    Feedback and experiences appreciated!

    #77338
    Profile photo of avatar2200
    Avatar2200

    I ordered those a few days ago (wired):

    http://www.amazon.de/snakebyte-PC-Controller-DirectInput-kabelgebunden/dp/B00ALTUECO/

    They work pretty well with my Pi, only L1 + R1 are a little bit too easy to press. Had the iBuffalo snes style before, but if you want to play all the games with 1 sort of controllers (psx especially) you will need those additional buttons.

    #77372
    Profile photo of jjd99d
    jjd99d
    Participant

    I use a custom built. 😉

    #80828
    Profile photo of
    Anonymous

    Avatar2200: Problem is this doesn’t have enough buttons for N64… Or am I missing something??

    #81408
    Profile photo of doublej
    doublej
    Participant

    Hello
    I bought a SNes remote and I can program all the controls and everything works fine except I can not get the hot keys to work properly, can anyone help me with this or give me the coding I need to use? Thank you

    Here’s what I have…
    http://www.amazon.com/gp/product/B002JAU20W/ref=oh_aui_detailpage_o01_s00?ie=UTF8&psc=1

Viewing 35 posts - 71 through 105 (of 186 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar