Weird USB controller problem, stops working

Home Forums RetroPie Project Everything else related to the RetroPie Project Weird USB controller problem, stops working

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of rambopie rambopie 3 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6102
    Profile photo of rambopie
    rambopie
    Participant

    Hello!

    I have the weirdest problem. I use a SNES replica USB controller and it always works on boot (both in ES and in all the emulators I use).

    Now sometimes, the controller suddenly stops working while playing a game. So far it has happened three times, two times while playing GBA games and one time when I was playing MAME. If I use the keyboard Esc and go back to ES the controller still works in ES!? Then, if I launch a game (doesn’t matter which emulator) the controller is dead from the start. Back to ES and the controller works again…?

    Sometimes I can have a ¨100 minute playing session with no problems at all. Sometimes it happens after 20-30 minutes.

    I honestly don’t know what to believe.

    Pi is powered with a 5V 1A micro-USB charger and I have connected a powered 7-port USB hub on which I have my two SNES controllers (and keyboard when necessary) connected. Pi is overclocked with Medium settings (900 MHz ARM).

    I could seriously use some advice here 🙁

    #6104
    Profile photo of RetroMarine
    RetroMarine
    Participant

    I noticed that if you are using all the space on your sd card it will automatically delete some configuration files or XML files. Use df -h to see how much space you have and if you’re using 100%, try freeing up a gig, reconfigure your snes controller, them try again.

    Sent from my iPhone using Tapatalk

    #6127
    Profile photo of rambopie
    rambopie
    Participant

    I noticed that if you are using all the space on your sd card it will automatically delete some configuration files or XML files. Use df -h to see how much space you have and if you’re using 100%, try freeing up a gig, reconfigure your snes controller, them try again.

    Sent from my iPhone using Tapatalk

    Thanks for replying. I did what you suggested but space is not a problem as I have a 16gb 10 class SD card (33% used at the moment according to df -h)

    Yesterday I played for over 3 hours before the gamepad lost it’s function. Used the keyboard to exit the emulator and lo and behold, the gamepad works again.

    This is driving me crazy, guess I’ll need to keep a keyboard nearby at all times.

    Btw, what is the key to exit a retroarch emulator? I tried Esc, F1 and F4 but they did not respond, at least not while playing NES. Controller exit binds works, when the controller is working that is.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar