Weird problem with Vectrex

This topic contains 4 replies, has 3 voices, and was last updated by Profile photo of ashmck73 ashmck73 1 year, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #111127
    Profile photo of ashmck73
    ashmck73
    Participant

    I just noticed something weird with trying to run Vectrex games on my RetroPie installation (3.2.1).

    I have 27 Vectrex .vec game files in the rom folder for Vectrex and they are different sizes so they are definately different games. When I try and run them though through the frontend, even though they are listed as different games – it always seems to load Mine Storm. Doesn’t matter which one I select – it always loads Mine Storm.

    I just read somewhere else that Mine Storm was the inbuilt game that came with the Vectrex – so it just seems to be defaulting to that – and not loading anything else.As I said, the game files are fine as I use them on my Hyperspin setup with no issues.

    Anyone else had a similar issue ?

    #111130
    Profile photo of ashmck73
    ashmck73
    Participant

    Well – a weird problem with a weird solution. I thought I’d try copying over another rom file from my working Hyperspin install and try it. The Vectrex games there are zipped so it came across as a zip file. And it worked – loaded fine. Extracted it into the .vec file and wouldn’t work again – hello Mine Storm again.

    So either something is wrong with my unzipper (though now I have tried both WinZip and WinRAR but same issue using both) or the Vectrex Emulator is having problems reading a vec file. Doesn’t make sense as that same vec file is in the zip archive and works if you leave it zipped.

    Oh well – as I said weird problem and solution – least I have a working Vectrex install now.

    #111187
    Profile photo of InsecureSpike
    InsecureSpike
    Participant

    just thought i’d check mine for you, RetroPie installation (3.2.1).
    any game for me loads with no issue, i only tried the .vec files

    #111259
    Profile photo of redfarmer
    redfarmer
    Participant

    I don’t have much to add but just wanted to mention that i owned a Vectrex many years ago and Minestorm was indeed built into the machine. I remember when starting my console without a cartridge it defaulted to Minestorm so i guess the emulator kind of does the same thing, it can’t load/find the ROM and assumes you have no cartridge. Maybe you should try downloading a new set of ROM’s.

    #111384
    Profile photo of ashmck73
    ashmck73
    Participant

    There doesn’t appear to be anything wrong with the roms – they work if I zip them – they just don’t work as .VEC files. As I said this is weird because when you use them as ZIP files they are unzipped into .vec files and they work.

    These are also the .vec files I use on 3 different HyperSpin installs with no problems.

    I don’t understand why they work when zipped and not work when used as .vec files but for me I have a solution so I’m happy with that.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar