Weird emulator issue

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of proxycell proxycell 2 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #81661
    Profile photo of bsalapek
    bsalapek
    Participant

    I recently setup my Raspberry Pi B+ with RetroPie 2.3 from the image file. With little effort the SNES, NES, GBA, Genesis and Master System emulators were working great.

    I loaded ROMs for TurboGrafx 16, 32x, GB, GBC and none of them worked. Many went right to a black or blue screen and I’d have to quit. For those that showed text, it usually had an error on par with “Cannot load file (filename).cfg” or “cannot load file %m” for TurboGrafx 16.

    I shrugged it off since most of what I wanted ran fine. Tonight after playing SNES, my son accidentally launched a 32x rom and it worked. After rebooting, the same ROM did NOT work. We ran another SNES game for awhile and then tried 32x. It works great. In fact, all of a sudden, all of the previously broken emulators work great. Something about running SNES enables them to run.

    Tl;dr? Many emulators only work once the SNES emulator has been run.

    Does this have any rhyme of reason to anyone? It’s a mild inconvenience but I’d still like to get it fixed if I can.

    Thank you everyone!

    #81765
    Profile photo of bsalapek
    bsalapek
    Participant

    Bump, anyone?

    #82425
    Profile photo of bsalapek
    bsalapek
    Participant

    To “resolve” this issue, here is my solution…

    I am running on a HD TV. The non working emulators were crashing because they were trying to run at 1080p. Changing the config file to force VGA mode solved the issues.

    #82435
    Profile photo of proxycell
    proxycell
    Participant

    oh wow, i’m glad to see that you figured it out. i would have never thought that it was the output switching around

    which hdmi mode are you running on now? i was doing 1 (vga) but i have switched to 4 for 720

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar