Web browser on retropi/raspbian?

Home Forums RetroPie Project New to RetroPie? Start Here! Web browser on retropi/raspbian?

This topic contains 5 replies, has 4 voices, and was last updated by Profile photo of johnnyb4 johnnyb4 1 year, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #102645
    Profile photo of godseye
    godseye
    Participant

    Hello,

    I´m running retropie och my Pi, and everything seems to be working great, except the fact that I´m missing a web browser. I don’t know if there is one included in the pre-compiled image (2.6). I tried to download midori but it wouldnt run (“cannot open display”)

    I would be greatful if someone could point me in a direction to a lightweigh browser that works on raspbian/retropie =)

    #102648
    Profile photo of godseye
    godseye
    Participant

    Ok, I got some more information for you guys. Seems like all these browseras are dependent of X. But when I try to sudo startx, the screen goes black with a tiny white bash square, showing the user root. No input is possible, and I tried waiting a long time but nothing happens.

    #102656
    Profile photo of petrockblog
    petrockblog
    Keymaster

    startx will just start the X server / environment and by default just start xterm, not the browser (You also shouldn’t be running it as root). RetroPie doesn’t come with a full X desktop environment to keep the size down.

    if you have installed midori, you can start it by installing a window manager and making a small script

    
    sudo apt-get install matchbox-window-manager
    

    then create a script in your homedir called browser.sh containing

    
    #!/bin/bash
    matchbox-window-manager &
    midori
    

    make sure it has executable permissions (chmod u+x browser.sh)

    then you can do

    
    xinit ~/browser.sh
    

    to launch X and run the script which loads the window manager and browser.

    #102660
    Profile photo of herbfargus
    herbfargus
    Member

    Alternatively if you want the whole desktop thing back you can do sudo apt-get install lxde

    #102673
    Profile photo of godseye
    godseye
    Participant

    Work wonders! Thanx for the advice guys!

    #107669
    Profile photo of johnnyb4
    johnnyb4
    Participant

    I am having trouble with startx. I am running retropie v3.1 on berryboot on my rpi2. I tried installing lxde with sudo apt-get install lxde, and immediately following installation I ran sudo raspi-configuration so that emulationstation would load on startup. When I exit out to terminal after emulation station loads up and try startx the screen goes black and nothing happens and I have to restart my pi. I tried apt-get update then upgrade then reinstalling lxde but still having the same problem. Never had this issue with 3.0

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar