Virtual Game pad in version 3.4

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie Virtual Game pad in version 3.4

This topic contains 12 replies, has 2 voices, and was last updated by  jaspreet97 1 year, 9 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #115582

    jaspreet97
    Participant

    Newbie here to retropie Was trying to get virtual gamepad from experimental setups.
    The installation completes fully and then when I try to reach the IP through phone or laptop The remote doesn’t show up and chrome says the page is not available.
    Please let me know of any logs that you might need
    My guess is that the package doesn’t work on Jessie at all

    #115598

    herbfargus
    Member

    I’ve tested it on Jessie and it worked for me. You sure that your phone is connected to the same network as your pi?

    #115606

    jaspreet97
    Participant

    I’ve tested it on Jessie and it worked for me. You sure that your phone is connected to the same network as your pi?

    Yes
    I can ssh into pi with the same phone . I did not apt get update upgrade on the pi though Does that have a effect?

    #115629

    herbfargus
    Member

    I just installed it again from a fresh image and it works fine, so its possible something may have happened during your install or some other issue with your network possibly.

    #115632

    jaspreet97
    Participant

    I just installed it again from a fresh image and it works fine, so its possible something may have happened during your install or some other issue with your network possibly.

    Thanks for the effort I tried it fresh again and still the same issue. I have a netgear router Maybe its blocking?
    What port does node.js work on?
    Maybe adding the port after IP can help??

    #115634

    herbfargus
    Member

    its port 80 but I think it can be changed in the config.json maybe.

    https://github.com/miroof/node-virtual-gamepads/blob/e40fe4968bf77cf77dd00384cf32b88eac68ae32/config.json

    But if its on the same network I don’t see how that would block the port that way, but I am not familiar enough with network protocols to know how that stuff all works.

    #115635

    jaspreet97
    Participant

    i tried adding port 80 but that didnt help . i am trying with a different router now.

    i screenshotted all the steps of installtion if that might help
    https://drive.google.com/file/d/0B65B-0VIQNG-aTRGVWJYdWYxM00/view?usp=sharing
    you can see in the last SS that its working fine

    #115636

    herbfargus
    Member

    Yeah it looks like it installed fine, so it probably is a network issue of sorts but I wouldn’t have any idea on where to begin troubleshooting

    #115666

    jaspreet97
    Participant

    I started fresh again and got this error this time.

    Am about to give up on VirtualPad and invest in a wireless gamepad I have a few wired ones but due to location of my rpi Can’t use them.

    Attachments:
    #115681

    herbfargus
    Member

    I installed mine directly with a USB keyboard rather than over ssh, I don’t know if that makes a difference. Really it’s more a novelty than a practicality and I’d definitely recommend hardware over it if you have it.

    #116556

    jaspreet97
    Participant

    Hey i got it to work with another router but now i have another problem.

    I have to configure the virtual gamepad everytime i restart or boot retropie.
    Can i make configuration permanent?

    #116558

    herbfargus
    Member

    I had a similar issue the first time I installed it

    No more gamepad ? Why not use the phone ?

    Can’t for the life of me remember how I resolved it, it may have just been a fluke. are you making it an app on your homescreen? https://github.com/retropie/RetroPie-Setup/wiki/Virtual-Gamepad#use-it-as-a-smartphone-application-chrome-for-android (Note that you have to configure it in the browser first before you make the app or else emulationstation wont configure properly)

    Its possible the device ID is dynamic and changes anytime the network changes (i.e. on a reboot) especially likely if run from a browser rather than a homescreen app.

    #116567

    jaspreet97
    Participant

    i think I found a fix.
    in \opt\retropie\configs\all\emulationstation\es_input.cfg
    I changed the inputconfig type line to this
    <inputConfig type=”joystick” deviceName=”Virtual gamepad&#02; ” deviceGUID=”03000000030000000300000002000000″>
    i found it from es_temporaryinput file.

    That helped and the settings are sticking now
    Thank you for all the help Herbfargus. Your videos on youtube have been helpful too

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/