Video splashscreen no sound

Home Forums RetroPie Project Splash screens Video splashscreen no sound

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of devil78 devil78 1 year, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #104756
    Profile photo of mexeroser
    mexeroser
    Participant

    Hey guys,
    with the new 3.0 version i managed to implement a video splashscreen to my RetroPie.
    Everything is working fine except the sound. I do not seem to get any sort of sound, no matter how loud my speakers are. I am using the 3.5 mm audio jack with usb speakers, which are working fine for all the ingame music, but not for the boot video :/ (I have already set the 3.5mm audio jack to the default sound device in the Audio settings). Any ideas? Thanks 🙂

    #104964
    Profile photo of jm73
    jm73
    Participant

    maybe re encode it to another format sometimes 1 format will not have sound when encoded for some strange reason

    #105546
    Profile photo of devil78
    devil78
    Participant

    try this:

    omxplayer -o local file.video

    Picab Multi Emulator - Rasperry pi 2 - Retropie - Arcade Cabinet

    #105565
    Profile photo of mexeroser
    mexeroser
    Participant

    Ok a little update: I tried encoding the video into a couple of formats but none of them had any sound playing. When i try the omxplayer -o local file.video command to play the video from the command line, i do actually get to hear the sound very clearly. So how do i tell the rpi to do the same when booting up?

    #105573
    Profile photo of devil78
    devil78
    Participant

    I would like to understand one thing … Can you hear the sounds while playing ?if so you just have to set omxplayer to redirect the output relay to audio output mini jack . To do that you have to add , in the configuration file of the splash screen , the option -o local after the command omxplayer. The configuration file is located in /etc/asplashscreen. You can try to modify it with nano. sudo nano -w /etc/asplashscreen

    Picab Multi Emulator - Rasperry pi 2 - Retropie - Arcade Cabinet

    #105578
    Profile photo of mexeroser
    mexeroser
    Participant

    Umm yeah playing it with the command you told me I totally hear the sound!!! 😀
    I wanted to try out configuring the file but i cannot seem to find anything in /etc that is called asplashscreen :p

    EDIT: just found it in /home/pi/retropie-setup/scriptmodules … Just testing it now 🙂

    Edit2: okay i tried that out, but that has still not worked, maybe the config file in the /scriptmodules directory is outdated and a new one is supposed to be at the location you told me, which i cannot find?

    #105585
    Profile photo of petrockblog
    petrockblog
    Keymaster

    the script that gets run on bootup is /etc/init.d/asplashscreen not /etc/asplashscreen as was mentioned.

    #105588
    Profile photo of mexeroser
    mexeroser
    Participant

    Thank you very much, everythings working now! =)

    #105598
    Profile photo of devil78
    devil78
    Participant

    oops, I used the phone to answer it and , therefore , I did not realize that the path was not the correct one . Buzz Thanks for the tip .

    Picab Multi Emulator - Rasperry pi 2 - Retropie - Arcade Cabinet

Viewing 9 posts - 1 through 9 (of 9 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar