Video Settings after Emulator Launch

Home Forums RetroPie Project New to RetroPie? Start Here! Video Settings after Emulator Launch

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of dcesarz dcesarz 2 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #98484
    Profile photo of dcesarz
    dcesarz
    Participant

    Hi. I am somewhat new to Retropie. I have the basic emulators working, but I am having a light issue with the screen sizing and resolution after launching the NES or SNES emulators. Specifically, after launch, every NES ROM has black bars on the sides of the screen. The EmulationStation itself is fine, utilizing the full screen. I tried changing the some of the settings within retroarch.cfg with no luck. I have a converter that converts hdmi to vga from the pi to my monitor. The monitor is not widescreen, it is a standard square shaped monitor. ANyone have any suggestions? I noticed there are multiple locations of the retroarch.cfg file. With any suggestion, please be specific as I am still learning my way around retropie. I attached pictures below. When launching any ROM for NES, you will see that that games is “squeezed” into a smaller window with black bars on either side.

    Thanks for any help.

    ScreenShot1496

    Attachments:
    #98566
    Profile photo of Floob
    Floob
    Member

    What resolutions does your monitor support?
    You can set the main Pi resolution here:
    http://elinux.org/RPiconfig#Video

    This is done in the /boot/config.txt

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98575
    Profile photo of dcesarz
    dcesarz
    Participant

    It supports 1024 by 768 and I have the appropriate settings in config.txt for hdmi group and mode to match that. Again..it’s only an issue after the emulator for nes launches. The screen resolution is perfect in emulation station. Is there a way to change just the settings for video withIn the emulator?

    #98585
    Profile photo of Floob
    Floob
    Member

    Yes, press “x” as the game starts to set the resolution of the game/emulator.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #98594
    Profile photo of dcesarz
    dcesarz
    Participant

    worked. Thanks!!

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar