need an expert: video scaling problems at 5x integer

Welcome Page Forums RetroPie Project Video Output on RetroPie need an expert: video scaling problems at 5x integer

This topic contains 2 replies, has 1 voice, and was last updated by  patrickm 2 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #97678

    patrickm
    Participant

    I’m wondering why I can’t seem to get perfect pixel scaling at 5x scale.

    I’ve set my video_fullscreen x/y to 1536×1200 for my nestopia config, because I want to take full advantage of my display area and not waste a bunch of display area on black bars and overscan. I have windowed fullscreen off and fullscreen on. Integer scale is on and my custom viewport is 1536×1200. In theory, setting a custom fullscreen x/y would allow one to keep integer scaling with a custom viewport that is larger than the display resolution.

    However, when Retroarch is launched, I lose my fullscreen x/y settings, and they are reset to 0. I’ve double checked my config and I know it’s set to 1536×1200, but both say “0” in Retroarch.

    Any idea why this is and how to fix it?

    #97698

    patrickm
    Participant

    Bump; would really like to get this addressed. SNES, NES, Genesis, Doom, N64 would all be awesome at 5x integer scale, if I could get it to work without scaling artifacts.

    #97715

    patrickm
    Participant

    I solved this; turns out the problem was not with integer scale but with my scanline overlay.

    I made a new overlay with slightly thinner scanlines that works at 5x integer scale, see “scanline overlays.”

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/