Video filters scanlines/ntsc

This topic contains 43 replies, has 10 voices, and was last updated by  Rich 2 years, 9 months ago.

Viewing 35 posts - 1 through 35 (of 44 total)
  • Author
    Posts
  • #3593
    Profile photo of roman
    roman
    Participant

    Everything looks great when I use a crt tv. However, I don’t really like the pixelated look when I use an LCD tv.

    I was wondering if there’s a way to add scanlines or some sort of ntsc filter to emulationstation.

    #3620
    Profile photo of aksen
    aksen
    Participant

    I spent most of yesterday trying to figure this out. I am only running NES/SNES, through RetroArch. My raspi is overclocked to the “high” preset with some cute little heatsinks.

    I have been trying to get gpu-based shaders to work, I haven’t tried the bsnes cpu-based filters yet.

    This is what I’ve learned so far:
    You need to enable video shaders in home/pi/RetroPie/configs/all/retroarch.cfg:

    # Path to shader. Shader can be either Cg, CGP (Cg preset) or XML/GLSL format if support is enabled.
    video_shader = "/home/pi/emulators/RetroArch/installdir/bin/shaders/CRT.shader"
    
    # Load video_shader on startup.
    # Other shaders can still be loaded later in runtime.
    video_shader_enable = true

    I downloaded shader packs recommended in the RetroArch readme, and placed them in RetroArch/installdir/bin/shaders.

    *.shader files do nothing,
    *.cg filters give me a blank screen.

    I tried to convert using RetroArch/installdir/bin/cg2glsl.py, but it wont work on the raspberry pi (can’t install the nvidia-cg-tools dependency, because it is x86 only).

    Not really sure what to do next, so I have stopped for now.

    Does anyone have a link to shaders that might work with RetroArch/raspberry pi?

    #3622
    Profile photo of supersirlink
    supersirlink
    Participant

    I had similar results… If you browse and apply one through the RGUI, I just get a black screen as well…

    #3623
    Profile photo of aksen
    aksen
    Participant

    I had similar results… If you browse and apply one through the RGUI, I just get a black screen as well…

    So it’s not just me, that’s good.

    I’d really like to give this a shot, at least for NES or other lightweight emulation!

    I’m hoping we are just using the wrong files – often I am finding dead links or 2-year-old information on the subject. Maybe someone out there has the right files available for download, or at least info on what exactly is supported by Raspian + RetroArch.

    And thanks to everyone in this community I was up and running within two days of getting my Pi. I’m having a lot of fun tweaking it, and this one cosmetic issue is the only thing I’ve had actual trouble with.

    #3717
    Profile photo of roman
    roman
    Participant

    I had the same results as well. I just came across with this retroarch pack that includes a quite a few shaders.

    http://themaister.net/retroarch.html

    Might be worth a try.

    #3720
    Profile photo of iphitus
    iphitus
    Participant

    I managed to get the common-shaders “working” on the raspberry pi. You can convert the shaders to GLSL on a x86 based system – the conversion doesn’t compile them to x86 binaries. I used my debian laptop and the python script from the retroarch git repository – but I’m sure any distro would suffice.

    While the shaders work, performance suffers with all but the most trivial shaders – they really highlight how many of these emulators (picodrive/pocketsnes) are just barely working on the pi.

    I found the crt/crt.glsl,crt-highgamma.glsl,crt-normalgamma.glsl seemed to provide a passable CRT type display without hindering performance too badly. Otherwise using an interlace + smoothing shader like hqx/eagle kind of worked too.

    Hope that helps.

    edit: for any shader, drop scale to 1x – it runs poorly if you leave it on “don’t care” or a higher value. Currently running Sonic 3 smoothly in picodrive with crt-highgamma.glsl and RPi OC’ed to 1ghz.

    #4174
    Profile photo of gizmo98
    gizmo98
    Participant

    Phosphor shader runs smooth and looks good.

    I have attached a collection of converted shaders.

    #4326
    Profile photo of roman
    roman
    Participant

    That’s it! Those shaders work perfectly.

    Thank you so much gizmo98, you’re the man!

    #4522
    Profile photo of
    Anonymous

    This worked great gizmo98! One hiccup I had, at first after following the steps in your readme I got a permissions error with runcommand.sh. This fixed it:

    chmod u+x home/pi/RetroPie/supplementary/runcommand.sh

    #4621
    Profile photo of gizmo98
    gizmo98
    Participant

    Thank you very much. I did not had that issue because i modified my original runcommand.sh.

    The shaders and a updated runcommand.sh were added three days ago to the master repository:
    https://github.com/retropie/RetroPie-Setup/commit/4a5ab350bf36aa6fe33a9000a4954836059a6e31

    New run command options:
    1: set video mode to VGA ONLY IF tvservice is in HDMI mode, and run command
    2: keep existing video mode and run command
    3: set video mode to VGA and run command
    4: set video mode to 720p ONLY IF tvservice is in HDMI mode and run command

    New shader path:
    /RetroPie/supplementary/RetroArchShader

    #4874
    Profile photo of primeform
    primeform
    Participant

    Man i cannot figure this out. keep getting errors about runcommand. Want to get this to work badly.

    #4908
    Profile photo of gizmo98
    gizmo98
    Participant

    Just update RetroPie-Setup, RetroArch and runcommand.sh and everything should be fine.

    1. Exit Emulationstatistation
    2. Command line:
    # cd RetroPie-Setup
    # git pull (or “sudo git pull”)
    # sudo ./retropie_setup.sh
    3. Select “Source Based Installation”
    4. Select at least RetroArch, Emulationstation and runcommand.sh (Don’t select all. MAME compiles a long long time)
    5. Click ok and wait.

    #4917
    Profile photo of primeform
    primeform
    Participant

    Im running a compiled image called Ultraslim that has Emulationstation and retroarch. Im not seeing anything about retro-pie so not sure how to upgrade this.

    http://www.raspberrypi.org/forum/viewtopic.php?f=78&t=59590

    Sorry I am really new to linux and raspberry pi. Can I download an update and copy those files to the directories?

    #4918
    Profile photo of gizmo98
    gizmo98
    Participant

    Ultraslim has another directory structure.
    1. Copy runcommand.sh to /home/pi/.emulationstation.
    2. # chmod u+x /home/pi/.emulationstation/runcommand.sh
    3. Edit /home/pi/.emulationstation/es_system.cfg
    4. Change runcommand.sh 1 to 6 (my zip file) or 4 (current RetroPie runcommand.sh)

    #4921
    Profile photo of primeform
    primeform
    Participant

    Ultraslim has another directory structure.<br>
    1. Copy runcommand.sh to /home/pi/.emulationstation.<br>
    2. # chmod u+x /home/pi/.emulationstation/runcommand.sh<br>
    3. Edit /home/pi/.emulationstation/es_system.cfg<br>
    4. Change runcommand.sh 1 to 6 (my zip file) or 4 (current RetroPie runcommand.sh)

    This is exactly what i did. as soon as i copy the new runcommand.sh i start geting errors that it cant find runcommand.sh. The numbers after the runcommand.sh in es_system.conf might be the problem. What number do I want? ALso what about the starttype=?

    Unfortuneatly I started the retropie install like you said so Im waiting on that to finish. I wonder if that will mess anything up with ultraslim?

    #4926
    Profile photo of primeform
    primeform
    Participant

    well crap, installing the retropie setup fubard my ultraslim. now when it boots into emulationstation it goes to a black screen with a white dot in the middle. cant get out of it sigh.

    #4936
    Profile photo of gizmo98
    gizmo98
    Participant

    Sorry! I thought you are using retropie.

    Try to exit emulationstation with F4 and do a retropie full installation.

    #4942
    Profile photo of primeform
    primeform
    Participant

    no worries. I was able to find the file that was pointing to retropie instead of retroarch. But now it seems the 2 config files are interconnected. I deleted the entire retropie directory it installed but for some reason it is still trying to pull retropie shaders. I edited the retroarch config in /etc, /emulators/retroarch, /emulators/configs/all, AND /emulators/retroarch/configs/snes/ but its still saying it couldnt load /retropie/shader.

    I have NO IDEA where it is still pulling the retropie shader info. How many fricking config files does this thing need!

    #4996
    Profile photo of gizmo98
    gizmo98
    Participant

    Please check out the attached shader presets. The shader dir = RetroPie/emulators/RetroArch/shader.

    All *phosphor*.glslp are brighter now. New and interesting shaders presets:
    snes_scanline.glslp
    snes_hq2xwaterpaintscanline.glslp (crisp, 720p, 1GHz Overclocking needed)
    snes_hq2xwaterpaint.glslp (crisp, 1GHz Overclocking needed)

    Please set video_smooth = false.

    Attachments:
    1. new_shaders.zip
    #4999
    Profile photo of peanut
    peanut
    Participant

    I’ve inserted/replaced above shader but now nothing happens (No shaders anymore)

    (also video_smooth = false)

    btw any way of getting these shaders to work for mame4all aswell?

    #5005
    Profile photo of gizmo98
    gizmo98
    Participant

    I updated the whole package. Check out the attached file.

    You can use shaders only with libretro cores like imame4all-libretro and fba-libretro.

    #5116
    Profile photo of bw38
    bw38
    Participant

    I’ve followed the instructions to the letter as far as configuring the retroarch.cfg file and copying over the shaders, but I can’t see a bit of difference in the way any of the emulators look. How can I tell if an emulator is running? Also, is it possible to target specific shaders to specific emulators? Thanks for any help in advance.

    #5117
    Profile photo of bw38
    bw38
    Participant

    Just to clarify my previous post, I meant to say “if a shader is running”, not an emulator. Sorry!

    #5124
    Profile photo of gizmo98
    gizmo98
    Participant

    If you exit emulation station and there is a messages like “no shader found, use stock shader” there is something wrong. There are two possible reasons. Your retroarch.cfg is false or the shader directory is at the false position.

    You can target specific shaders to specific libretro cores. The zip file contains the path “RetroPie/config”. There are examples for different targets.

    #5153
    Profile photo of bw38
    bw38
    Participant

    Thanks for the assistance. For some reason, there is no mention of any shaders being used when I exit emulation station. I also can’t seem to bring up the in emulator menu when pressing F1, even though I activated the toggle in the cfg file. Very frustrating.

    #5161
    Profile photo of primeform
    primeform
    Participant

    any reason these shaders wouldnt work with ultra slim?

    #5177
    Profile photo of gizmo98
    gizmo98
    Participant

    If you use RetroPie, update RetroPie and do a source based installation.

    # cd RetroPie-Setup
    # git pull
    # sudo ./retropie_setup.sh
    # select “Source Based Installation”
    #5178
    Profile photo of gizmo98
    gizmo98
    Participant

    Ultraslim uses RetroArch. So the file from Post 5005 should work.

    #5180
    Profile photo of primeform
    primeform
    Participant

    going to give it one more shot updating ultra slim. If the doesnt work im going to have to do a drastic rebuild with retropie and add the applications individually.

    #5181
    Profile photo of primeform
    primeform
    Participant

    “runcommand.sh 1“ = VGA

    whats with all the greek looking letters after 1?

    #5186
    Profile photo of gizmo98
    gizmo98
    Participant

    It should be “runcommand.sh 1″ = VGA 🙂

    #5197
    Profile photo of primeform
    primeform
    Participant

    Ok now im getting the error: Failed to power on HDMI mode with explicit settings (CEA mode 4)

    #5201
    Profile photo of primeform
    primeform
    Participant

    fixed the hdmi problem but it always gives me retroarch error and loads stock shaders

    #5203
    Profile photo of primeform
    primeform
    Participant

    Retroarch error: failed to parse GLSL shader.
    Retroarch error: failed to init shader, falling back to stock.

    #5204
    Profile photo of primeform
    primeform
    Participant

    Success! dont know why its so picky but i ended up changing the permissions of every folder and file. Then I cleared all settings related to shaders out of the main retroarch.cfg and put them into the /*emulatorcore/retroarch.cfg and presto.

Viewing 35 posts - 1 through 35 (of 44 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar