Video configuration

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of petrockblog petrockblog 4 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1612
    Profile photo of dedhart
    dedhart
    Participant

    Right now I have my pi connected with an hdmi cable. It seems the video output is slightly larger than my tv screen so the top and bottom of the video get cut off. Most games it is not noticable, but it does seem noticable in some game boy games. I would also like to know if I can configure retroarch to play games in hd.

    #1613
    Profile photo of Raygan Kelly
    Raygan Kelly
    Participant

    I have been looking into this same issue. I use my Pi with a SD CRT TV over composite, and I am getting a little bit of overscan on both sides. I tried adjusting the overscan setting in the /boot/config.txt file, but that causes emulationstation to fail to start for some reason. I get the RetroPie startup screen, and then nothing.

    I’d love to hear if there’s a way to adjust the overscan or scaling within RetroArch itself.

    #1619
    Profile photo of Raygan Kelly
    Raygan Kelly
    Participant

    I’ve sorted out my issues, and perhaps my experience will help you as well.

    You need to edit your /boot/config.txt file to adjust the overscan.

    First, make sure that disable_overscan=1 is commented out (has a # sign in front of it.) You want overscan to be enabled.

    Second, uncomment (remove the # sign from) the overscan adjustments. They look like overscan_left=16, overscan_right=16, etc…

    You can adjust these to whatever amount you need to overscan by. With my composite TV, I just needed small changes. 8 at the left and right and 4 at the top and bottom. Your settings may vary. Try the default of 16 to start with.

    If that works, then you’re golden. But for me, on a CRT composite video screen, I had a couple of other things I had to do.

    I needed to add the line “overscan_scale=1” to the file. This is an experimental feature in the newer firmware that makes sure that everything, not just the console and X server, obey the overscan setting. Without this, My pi would boot to the console and look properly scaled, but wouldn’t display anything at all for EmulationStation or RetroArch. Source here.

    Also, PetRockBlog recently added a feature for changing the HDMI resolution when starting Retro-Arch based systems. This seems to interfere with video working properly on composite screens. To disable it, you need to edit the ~/.emulationstation/es_systems.cfg file. Change the line:

    COMMAND=$rootdir/supplementary/runcommand/runcommand.sh 1 “retroarch -…

    to:

    COMMAND=$rootdir/supplementary/runcommand/runcommand.sh 2 “retroarch -…

    Source here.

    Now my little RetroPie is looking and working great with the old $3 TV I picked up at Goodwill. Playing these old classics on a CRT TV is really the way to go; they just look right!

    #1620
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Thanks a lot for sharing that here!

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar