Using Xbox 360 Wireless controller with Retropie 3.0- problem!

Home Forums RetroPie Project Everything else related to the RetroPie Project Using Xbox 360 Wireless controller with Retropie 3.0- problem!

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of petrockblog petrockblog 1 year, 7 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #109369
    Profile photo of helpmypie
    helpmypie
    Participant

    Hi guys,

    I’m trying to connect two wireless Xbox 360 Controllers to Retropie 3.0. I’ve been following Floob’s tutorial on it and followed every step. I even got up to the point where I configured each input button. But I’m stuck in this part of his Youtube instruction video, where he says:

    – Enter Retropie setup
    – Select 317 – Register RetroArch controller

    The problem is that this task no longer exists under RetroPie 3.0. Here’s what I get

    317 – Configure the ‘runcommand’ – Launch script.

    And unfortunately this task has nothing to do with registering the controllers.

    Floob’s video mostly follows [this GitHub wiki entry](https://github.com/RetroPie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller), but parts of it no longer match up with the Wiki since the updates.

    What the heck do I do, at this point? My controller can navigate the Emulation Station screens, but when I launch a game none of the buttons are responding! Proobably because the controller isn’t registered, Also, only one of my two Xbox controllers are working. The other one syncs with the receiver, but doesn’t even have the limited usability that my ‘Player 1’ controller does.

    EDIT: I found the new task# under Retropie 3.0, it’s 314 – ‘Configure input devices for RetroArch’. But the prompts aren’t responding to my Xbox controller at all. So, I can navigate menus, but can’t configure the controller in the Setup dialogue.

    I also tried the wiki’s config command: “./retroarch-joyconfig -o /opt/retropie/configs/all/p2.cfg -p 2 -j 1”. But it’s not doing anything, for me.

    What am I doing wrong?

    #109372
    Profile photo of adid4s
    adid4s
    Participant

    Install xboxdrv, under retropie setup, there’s an option i can’t remember what its called something about “to be used post install” enter that and towards the bottom, install xbox drv, do that then reboot, it’ll ask you to reconfigure once it loads up again, that should be all you need

    #109374
    Profile photo of helpmypie
    helpmypie
    Participant

    I’ve already done that, and even went through Emulation Station’s key binding prompt. But my Xbox 360 controller still doesn’t work. It can only navigate the Emulation Station screens, but doesn’t work within any emulation games at all.

    #109377
    Profile photo of adid4s
    adid4s
    Participant

    That’s weird what version of retropie do you have?

    #109379
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Did you update from an earlier version ?

    What are the contents of /opt/retropie/configs/all/retroarch-joypads

    and what is in your /opt/retropie/cofigs/all/retroarch.cfg

    what happens if you drop to a terminal and run

    
    /opt/retropie/supplementary/emulationstation/scripts/inputconfiguration.sh
    
    #109394
    Profile photo of helpmypie
    helpmypie
    Participant

    No, I didn’t install from an earlier version. It’s all from a fresh RetroPie installation. In response to your questions:

    What are the contents of /opt/retropie/configs/all/retroarch-joypads
    Screenshot!

    and what is in your /opt/retropie/cofigs/all/retroarch.cfg
    Nothing. It’s blank. I feel like this isn’t normal. I tried to configure the controllers through setup, but my wireless controller doesn’t respond to any of the prompts.

    what happens if you drop to a terminal and run /opt/retropie/supplementary/emulationstation/scripts/inputconfiguration.sh

    [snip – removed unneeded contents of file]

    #109399
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Second item – /opt/retropie/configs/all/retroarch.cfg – I made a small typo – cofigs instead of configs – please check that one.

    You didn’t run the 3rd command – you pasted the contents.

    to run it, paste the commandline I gave directly into a terminal, dont try and show the contents.

Viewing 7 posts - 1 through 7 (of 7 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar