Using overscan in RetroPie to fit video to your display

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Using overscan in RetroPie to fit video to your display

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of herbfargus herbfargus 2 years, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #83161
    Profile photo of Floob
    Floob
    Member

    Thought I’d put a post up about overscan when using RetroPie, hopefully it will help some of you. Feel free to point out any issues!

    Overscan
    Overscan is historicaly an issue for CRT TV’s as they weren’t consistant in what area of a video signal would be displayed. This means that a portion of the picture is often outside of the viewable area. It isnt so much of an issue for modern digital (720p/1080p) TV’s as its a lot more specific.

    Far more information can be found here:
    http://en.wikipedia.org/wiki/Overscan

    When using the Raspberry Pi, Emulation Station or playing games you may find that a small portion of the display is ‘chopped off’, often at the top and bottom of the screen. This is often independent of the emulator and more a Raspberry Pi video setting.

    Raspberry Pi Settings – config.txt
    You can see a lot of options to configure the video settings, including overscan in the /boot/config.txt file.
    There is a lot (all?) of the information here: http://elinux.org/RPiconfig#Video

    The key areas are:

    hdmi_group=1 (usually 1, for TV)
    hdmi_mode=4 (720p)
    overscan_left=16 (Amount of pixels to skip - this is what you want to change to move the viewing area)
    overscan_right=16 (Amounat of pixels to skip - this is what you want to change to move the viewing area)
    overscan_top=16 (Amount of pixels to skip - this is what you want to change to move the viewing area)
    overscan_bottom=16 (Amount of pixels to skip - this is what you want to change to move the viewing area)
    overscan_scale=1 (Not usually needed for the terminal console view, but forces overscan when video modes are kicking in, like EmulationStation)
    disable_overscan=0 (set to 0 to enable overscan)

    Make sure that any values you want to use aren’t commented out with a hash ‘#’

    You will see group CEA and DMT mentioned, broadly speaking they refer to using TV (CEA), or using a computer monitor (DMT)

    This is a useful command to see what your TV will support: /opt/vc/bin/tvservice -m CEA
    You can see your current mode with: /opt/vc/bin/tvservice -s

    Here is a comment about the video modes here:
    http://blog.petrockblock.com/forums/topic/retropie-2-x-list-of-issues/#post-15864

    Emulation Station
    When you use RetroPie, you start a game using the Emulation Station interface. The configuration file that will start the emualtor and roms is stored in the es_systems.cfg file. This is usually found in /etc/emulationstation/ .

    An example is here:
    https://github.com/solygen/dotfiles-RetroPie/blob/master/.emulationstation/es_systems.cfg

    You can see that before runnig the rom, there is a command like "COMMAND=/home/pi/RetroPie/supplementary/runcommand/runcommand.sh 1"
    This means that the video mode will be ‘1’ – you can match these up by looking at http://elinux.org/RPiconfig#Video

    (I changed the fba emulator from using 1 (small VGA window) to 4 – standard 720p.)

    The common setting for these is ‘4’ which is:
    hdmi_mode=4 720p 60 Hz

    The runcommand script itself can be seen here:
    https://github.com/retropie/RetroPie-Setup/blob/master/supplementary/runcommand.sh

    So you could even update your own and tweak video modes there.

    MAME
    I also found that there is another setting for Mame that is useful. I hadnt changed any overscan settings in config.txt, as my games looked fine except for Mame which is run with mame4all-pi. Here is the config file for that: https://code.google.com/p/mame4all-pi/
    I simply changed the value of
    display_border
    from “0” to “24” and it worked really well!

    This is found in the mame.cfg file which is in /opt/retropie/emulators/mame4all-pi

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #83852
    Profile photo of Floob
    Floob
    Member

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #86100
    Profile photo of herbfargus
    herbfargus
    Member

    For anyone that has issues with black borders, in my case in /boot/config.txt all I did was uncomment

    disable_overscan=1

    It worked like a dream, then with the 2.4.2 added video options as floob generously showed us on youtube (https://m.youtube.com/watch?v=3f9ldh2H7js) and changing my TV settings to “stretch” I’ve been able to get just about every game full screen.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar