USB transfert doesn't work on the new release Retropie

Home Forums RetroPie Project New to RetroPie? Start Here! USB transfert doesn't work on the new release Retropie

This topic contains 12 replies, has 2 voices, and was last updated by Profile photo of turk182 turk182 1 year, 7 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #110015
    Profile photo of turk182
    turk182
    Participant

    Hi,

    Since the 3.1 version my roms didn’t transfer into my raspberry.
    So I did a fresh new installation with the last retropie version.
    I connect My brand new USB with the Retropie folder in it and after 5 reboot retropie didn’t created the emulator folders inside mine.

    Is this function unavailable in the new version ? Or I’m doing something wrong ?

    Thank you for your help

    #110023
    Profile photo of petrockblog
    petrockblog
    Keymaster

    you give little detail. EG Folder structure etc ? Did you check the instructions on the wiki ? https://github.com/RetroPie/RetroPie-Setup/wiki/How-to-get-ROMs-on-the-SD-card (noting – Starting with RetroPie 3.0 you first need to create a folder called retropie on your USB stick and then follow the above steps.)

    #110026
    Profile photo of turk182
    turk182
    Participant

    I did it 100 times and never had issue but still last version the folder structure doesn’t be created automatically

    I create the folder Retropie on my USB and after reboot it should create all the emulator folder inside as they say in the link you give me (The first time you plug the USB stick into the the RPi, a ROM directory structure is generated on the USB stick) and it alway work for me but now nothing is created and the USB service is on I check it.

    It happens since version 3.1

    #110036
    Profile photo of petrockblog
    petrockblog
    Keymaster

    Did you create the folder with a capital “R” ? it should be all lowercase.

    #110040
    Profile photo of turk182
    turk182
    Participant

    I tried all possibility with and without capital R

    #110109
    Profile photo of turk182
    turk182
    Participant

    Any idea ?

    #110111
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I know it works, so it must be an issue on your set up. Double check your usb stick has a single partition formatted as fat32 or ext4 with a folder in the root called “retropie” and plug it in to the pi. then from a terminal do “cat /var/log/syslog” – when it’s working it should have some lines like

    
    Nov 17 11:55:25 retropie usbmount[2282]: executing command: run-parts /etc/usbmount/mount.d
    Nov 17 11:55:26 retropie usbmount-01_retropie_copyroms-[2327]: Attempting to create directory structure for ROMS in '/media/usb0/retropie/roms' ...
    Nov 17 11:55:29 retropie usbmount-01_retropie_copyroms-[2327]: Syncing roms ...
    Nov 17 11:55:29 retropie usbmount-01_retropie_copyroms-[2327]: Syncing configs ..
    
    #110112
    Profile photo of turk182
    turk182
    Participant

    Ok, I will check the partition. Its a brand new one, maybe it have a hide partition.

    But, i’m sure that I don’t make any mistake as the process .. I did it many times and it always work fine. The issue it since the 3.1 version.

    I will let you know.

    Thanks for your help.

    Stephane

    #110232
    Profile photo of turk182
    turk182
    Participant

    My USB is NTFS … this is the reason ? Retropie doesn’t recognize the NTFS ?

    #110233
    Profile photo of petrockblog
    petrockblog
    Keymaster

    That probably won’t work out of the box. It might if you install ntfs-3g, but that is likely the problem.

    #110234
    Profile photo of turk182
    turk182
    Participant

    ok thank you for the information. I would be great to add this feature on next release if it’s not too much work :p

    For the moment I will transfert my roms with network 🙂

    Thank you again for your help.

    Stephane

    #110246
    Profile photo of petrockblog
    petrockblog
    Keymaster

    I’ll consider adding it as an option, but for now if you must use NTFS, you can enable it by doing the following

    
    sudo apt-get install ntfs-3g
    sudo sed -i "s/hfsplus/hfsplus ntfs fuseblk/g" /etc/usbmount/usbmount.conf
    
    #110260
    Profile photo of turk182
    turk182
    Participant

    Thx for the tips I will try that!

Viewing 13 posts - 1 through 13 (of 13 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar