USB SNES controller not working in MAME, but works in every other emulator

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie USB SNES controller not working in MAME, but works in every other emulator

This topic contains 1 reply, has 2 voices, and was last updated by  dankcushions 2 years, 1 month ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #111180

    sanchees3
    Participant

    So I recently bought a USB SNES controller off Amazon and it works great (Gtron SNES USB gamepad) ! It works perfectly well in every other emulator EXCEPT MAME. Weird thing is that the retroarch commands still work (such as Sel+X ; start+sel does not work on the gamepad, only keyboard) but no matter how many times I’ve remapped the controller in the RetroArch GUI settings and saved it (saved as libretro.cfg), and EmulationStaion menu mapping and it still does not work in MAME. I am using lr-imame4all as the emulator since my roms only work on this and not mame4all emulator option so remapping the controls with the mame4all tab settings will not be possible. If anyone can please help me it would be greatly appreciated !

    the mame configs are below ( found in /opt/retropie/configs/mame-mame4all )

    http://s000.tinyupload.com/?file_id=10591152337684684884

    I am using a:
    -Raspberry Pi Model B+
    -RetroPie v3.2.1
    -Rii wireless keyboard
    -Gtron SNES USB gamepad
    -CanaKit wifi dongle

    #111196

    dankcushions
    Participant

    when you remap the controls in the GUI it should start working? is it that your ‘insert coin’ button (usually select) isn’t working, so you can’t actually get control of the games in the first place?

    anyway, if you do need to remap to get it working, the default save-as config file name (libretro.cfg) is not the one it uses. it should be named retroarch.cfg

    so, you can either go into /opt/retropie/configs/mame-mame4all/ and rename libretro.cfg to retroarch.cfg,

    or, you can go into /opt/retropie/configs/all/retroarch.cfg and change the ‘save config on exit’ (forget what it’s called) option to ‘true’, and then remap again (don’t need to save – just exit the emulator and it will save in your existing mame-mame4all/retroarch.cfg)

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss