usb mounting slowly

This topic contains 5 replies, has 2 voices, and was last updated by  InsecureSpike 2 years, 9 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #95208


    hi all,

    i just upgraded my hd to a 2tb disc, copied everything over from the 1tb, all is good.

    except that the drive no longer mounts at boot, i have to quit ES, type in the commend “sudo mount -a” to mount the drive. restart ES and everything is back. from blkid, i get the following:

    /dev/sda1: LABEL=”2TB” UUID=”18ba8ee8-7a31-4efe-8625-bd64e13790fe” TYPE=”ext4″

    i have edited the /etc/fstab file with the following line:

    UUID=”18ba8ee8-7a31-4efe-8625-bd64e13790fe” /mnt ext4 defaults 0 0

    that line obviously works since “sudo mount -a” mounts the drive. did I miss a step?




    ok, what method did you use to move yer file system to the hdd? I take it was the same method you used on your 1tb hdd, and that worked ok?
    also are you using a powered USB hub?



    well i have tried it two different ways, first up i used midnight commander to copy all my folders from the 1tb to the 2tb disc.

    second method (after a format of the 2tb drivce), i plugged both into my mac and copied all folders from the root of the 1TB to the root of the 2tb drive.

    in both instances, the 2tb behaves the same. on a side note, when i first did it, the drive would mount but there would be an extra foolder in the directory tree. so instead of the mount point being /media it was /media/usb

    but that screwed up my rom patths. so fixing my rom paths and a rebbot, the mount point was BACK to /media. so now my new rom paths didn;’t work. swithch them back and the mount point was back to /media/usb. weird to say the least.

    so, i started with a reformat and now am at a point where the drive will not automount. i must quit ES, use sudo mount -a and restart ES, then everything is back.

    i have tried adding rootdelay=5 but that did nothing.

    any thoughts? and many thanks!




    i came across this and it worked a charm:

    add the line:

    sudo mount -a

    to this file:


    i appreciate the feedback!



    awesome! your welcome!

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss