USB flash drive issue MAME

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! USB flash drive issue MAME

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of dankcushions dankcushions 1 year, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #106502
    Profile photo of kraken0667
    kraken0667
    Participant

    Hello

    Im running Retropie, and for easy ROM access I use a USB flash drive as path/directory to all my games.

    I recently bought a USB sound card / audio adapter from Adafruit to get decent sound, and everything works great, except for MAME games. The MAME ROMs are detected in Retropie menu, but they won’t launch. When I try, I just get back to menu. All other emulators Ive tried work. When I unplug the USB sound card and reboot, MAME ROMs load perfect again. So, I guess MAME in particular does not like the sound card. Can this be fixed somehow? I still want to have ROMs loaded from an external USB flash drive.

    #106542
    Profile photo of kraken0667
    kraken0667
    Participant

    Bump!

    Update: I moved my MAME ROMs to the SD instead and loaded from there, same issue. So this has nothing to do with loading ROMs from USB. It just seem the USB sound card / audio adapter interfere with mame4all somehow.

    So, when I try to launch a MAME ROM with USB sound card connected, I just get thrown back to emulationstation menu(No error messages, no missing file message etc)

    When I launch a MAME ROM with the USB sound card disconnected, it load perfectly without issues.

    Any help would be much appreciated!

    #106558
    Profile photo of dankcushions
    dankcushions
    Participant

    have you tried the other mame4all emulator? there are two:
    mame4all-pi
    lr-imame4all

    they both use the same romset so you should be able to swap the default to whatever one you’re not using. might be worth a shot! 🙂

    failing that, you should be able to see any error messages in /tmp/runcommand.log after a crash – this might give a clue as to the problem.

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar