Usb Drive not reading

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of trimmtrabb trimmtrabb 3 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6808
    Profile photo of stoopypoo
    stoopypoo
    Participant

    Hi all,

    I’m in the process of setting up my retropie system. After running through several hurdles I though I was on the home stretch. However, after getting it up and runnin I noticed that the only emulators showing up are Apple 2, cave story, duke nuken, doom and x86. Is this just because I dont’ have roms in it yet?

    I’m trying to get roms from my usb stick, I have tried plugging a usb stick and a usb HDD (unpowered but connected to a powered hub) and neither seem to be picked up. Retropie is not creating a roms directory or anything at all on the drives when they are inserted.
    I’ve tried formatting the usb stick again as fat 32 just to be sure. Still nothing. I don’t really want to try formatting is Ext4 as I want to move roms from my windows computer to my pi using this.

    The sd card image would not work at all for me so I have had to install in through the script.
    I am a complete noob at this and seem to be struggling at every hurdle, so any help would be appreciated.

    Thanks!

    #6813
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    Hi, yes roms need to be placed in the rom folders for the emulators to show up.

    You have two options:

    Enable the auto-copy feature via the setup script which will transfer roms from the usb drive to the relevant rom folders on your sd card:
    https://github.com/retropie/RetroPie-Setup/wiki/How-to-get-ROMs-on-the-SD-card

    Or modify es_systems.cfg to load roms from the usb drive:

    How to load ROMs from a USB drive on RetroPie 3

    Hope this helps

    If you have found the solution to your problem please mark the topic as resolved.

    #6815
    Profile photo of stoopypoo
    stoopypoo
    Participant

    Thanks for the reply.

    I have tried the auto transfer. It’s a problem with the raspi actually reading the drive. Every tutorial I read says just plug it in and retropie will create a folder for you to drop the roms in. It doesn’t, I have tried pointing the es system file to where I thought the drive was put it still does not pick up anything.
    I think my problem is that the drives will not mount properly, although I read that retropie auto mounts all drives and creates folders for each emulator.
    Is there a reason why mine is not doing this?

    #6819
    Profile photo of trimmtrabb
    trimmtrabb
    Participant

    hmm it should auto mount. You can manually mount it, this may help: https://www.modmypi.com/blog/how-to-mount-an-external-hard-drive-on-the-raspberry-pi-raspian

    If you have found the solution to your problem please mark the topic as resolved.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar