usb conrtoller no retroarch config

Welcome Page Forums RetroPie Project Controller Configuration in RetroPie usb conrtoller no retroarch config

This topic contains 2 replies, has 2 voices, and was last updated by  evil 2 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #111406

    evil
    Participant

    Hello,

    i have installed retropie 3.2.1
    I configured Xbox controller successfuly. After that i connected a diffrent controller. The configuration in emulationstation workt perfect and the controller works in the menu. But there was no configuration file in /opt/retropie/configs/all/retroarch-joypads for that controller. So the controller is not working with the games (retroarch).
    By the way retropie_setup has no option for configuring the controller any more.
    i think ist was 316 but its not there anymore.

    Question: How i can set up a new controller for retroarch.

    Second problem is that the usb stick i connected, no directory structure for the roms is created. I activated the service with the retropie_setup but no change.

    Version 2.6 worked so perfect, but 3.2.1 not.

    #111426

    herbfargus
    Member

    Autoconfigs were depreciated by retroarch. They should be created when configuring through emulationstation or alternatively you can configure them from the rgui

    For the usb transfer Read the documentation:

    https://github.com/RetroPie/RetroPie-Setup/wiki/First-Installation#usb

    #111435

    evil
    Participant

    thanks for usb link (i have not look into the wiki, sorry)

    autoconfig retroarch is not supported?

    cat /opt/retropie/configs/all/retroarch.cfg | egrep “autodetect|joypad_autoconfig_dir”

    input_autodetect_enable = true
    # corresponding to that joypad is present in joypad_autoconfig_dir.
    # Requires input_autodetect_enable to be enabled.
    joypad_autoconfig_dir = /opt/retropie/configs/all/retroarch-joypads/

    I think whats not support is the preconfigured joypad by retropie (from 2.6)

    what I have done is (it worked for me):

    cd /opt/retropie/configs/all/retroarch-joypads/
    sudo /opt/retropie/emulators/retroarch/bin/retroarch-joyconfig -a joypad.cfg -j0 -t 4
    CFG_NAME=$(cat joypad.cfg | grep “input_device” | cut -f 2 -d \” | tr -d ” “)
    mv joypad.cfg $CFG_NAME.cfg

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss