USB audio device

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of renrom renrom 1 year, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #104839
    Profile photo of renrom
    renrom
    Participant

    Hi,

    I want to use an USB audio device with the Pi2. After installing it, no games are started anymore. The following error i can see quickly on the screen:

    lvl0: VolumeControl::init() – Failed to find mixer elements

    In the /tmp/runcommand.log this error is showing up:
    ALSA lib pcm.c:7431:(snd_pcm_set_params) Rate doesn’t match (requested 44100Hz, get 0Hz)

    If i try to play a sound from the commandline with aplay /usr/share/sounds/alsa/Front_Left.wav it does play the sound.

    Any idea to fix this?

    #104842
    Profile photo of renrom
    renrom
    Participant

    Ok, after digging around a bit, this seem to work:

    Creating a file /etc/asound.conf with the following:

    ctl.!default {
    type hw
    card 0
    }
    pcm.usb
    {
    type hw
    card "U012529205"
    format S16_LE
    }
    
    pcm.!default {
    type asym
    playback.pcm
    {
    type plug
    slave {
    pcm "hw:0"
    format S16_LE
    }
    }
    capture.pcm
    {
    type plug
    slave.pcm "usb"
    }
    }
    

    and comment the line ‘options snd-usb-audio index=-1’ in the /etc/modprobe.d/alsa-base.conf

    Only part what still dont have sound is the splashvideo, will try figure out that one aswell. 🙂

    #104871
    Profile photo of lilbud
    lilbud
    Participant

    Use this website http://plugable.com/2014/11/06/how-to-switch-to-usb-audio-on-raspberry-pi works perfectly, and it automatically switch depending on if the adapter is plugged in on boot.

    #104886
    Profile photo of renrom
    renrom
    Participant

    i will try and test that later, although I think I also tried that. Without the /etc/asound.conf I will probably get the pcm error.

    #104918
    Profile photo of renrom
    renrom
    Participant

    Tested it, and the /etc/asound.conf is realy neccesary to make the usb sound work with ES.

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar