USB Arcadesticks & Retropie

Home Forums RetroPie Project Controller Configuration in RetroPie USB Arcadesticks & Retropie

This topic contains 21 replies, has 2 voices, and was last updated by Profile photo of bitbytepixelsprite bitbytepixelsprite 1 year, 11 months ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #101036
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    I just picked up a Qanba Q1 for Mame, and I wanted to know if anyone has had any issues with it in any of the emulators? I would imagine that it would be similar to any other USB controller, maybe I have to do some mapping.

    Any input is appreciated!

    #101066
    Profile photo of Floob
    Floob
    Member

    I’m going to look at mine soon (although mine are MadCatz Arcade SE and TE).
    I have to get the internals swapped out (although its fine in my PC if I use a VIA USB chipset).
    I’m not sure if the Qanba has the same issue. Does it work fine in your PC?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101075
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    Its still incoming, from what I understand it is plug and play largely, so I’m not too concerned. But I don’t see much talk of arcade sticks on here.

    Also, I love your videos, they have been so helpful! I mean a real life saver!

    #101247
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    So I tried my stick today, retroach configured fine. And FBA took the inputs ok, but I may have to mess with those. However Mame did not detect the stick movement,in game or when I tried to assign the movement in menu. Any thoughts?

    #101270
    Profile photo of Floob
    Floob
    Member

    Which mame are you using – was it mame4all, or the libretro version. Or advance mame?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101274
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    I am using mame4all. One thing I did notice when I ran a JS test was that the Joystick Axis went from approx 3000 to -3000 on their respective up/down left/right movements. I know that in mame for all its looking for 1/-1. Would that have anything to do with it?

    #101430
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    Does anyone have any ideas on this? I still cant get it to go, other games are ok, but Mame4All seems to be difficult.

    #101433
    Profile photo of Floob
    Floob
    Member

    Can you get the libretro version of mame4all working ok?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101439
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    Can you get the libretro version of mame4all working ok?

    Forgive me, but I thought that was what the Mame-mam4all folder was utilizing.

    #101443
    Profile photo of Floob
    Floob
    Member

    It can use either in that directory. You choose by pressing x as the game starts.

    The default is the non libretro version

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101449
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    It can use either in that directory. You choose by pressing x as the game starts.

    The default is the non libretro version

    I apologize again, I saw that when I was booting them up again. The stick does work in the libreto version. However I cant seem to back out of games when I am in that version I have to ssh and reboot. But that may just be my issue in not knowing the correct command or button, although I hit every button on the board.

    #101512
    Profile photo of Floob
    Floob
    Member

    Which version of RetroPie are you using? Is it an image like 2.6.0, or did you build it from binaries/source?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101531
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    Im using image 3.0 Beta 2

    #101572
    Profile photo of Floob
    Floob
    Member

    Can you send your controller file (post it on pastebin) – it should be here
    /opt/retropie/emulators/retroarch/configs
    Probably with a more recent date than the other files in there.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101582
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    Can you send your controller file (post it on pastebin) – it should be here
    /opt/retropie/emulators/retroarch/configs
    Probably with a more recent date than the other files in there.

    http://pastebin.com/qtmCkHL5

    #101647
    Profile photo of Floob
    Floob
    Member

    hmm, what if you try this content instead
    http://pastebin.com/raw.php?i=kmLCRvR8

    basically delete these lines
    input_r_x_plus_btn = “9”
    input_r_y_plus_btn = “9”
    input_r_y_minus_btn = “9”

    I’m assuming you havent tweaked any of your retroarch.cfg files. If you have, please post those as well.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101664
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    I havent changed anything else, I deleted those lines and the conf menu in mame4all still doesnt see my joy stick movements when assigning them to up/down/left/right.

    #101667
    Profile photo of Floob
    Floob
    Member

    Can you confirm you are using the libretto mame4all – that’s what should see the config file above. If mame4all standalone doesn’t read it I’m not sure it will unless you changed the controller board in the stick. Don’t forget there are other arcade emulators on the Pi like fba and advance name and even gngeo.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101683
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    I did double check that on the last test, FBA works perfectly for some reason, and the rest of the emulators pick it up. Could it be this part of the config? I tried to remove the h0 in the directional part to see if it made a difference but no change.

    #101689
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    One question and it may be basic, will FBA read most mame roms?

    #101713
    Profile photo of Floob
    Floob
    Member

    Thats a very broad question. There are different romsets for different emualtors:
    https://github.com/RetroPie/RetroPie-Setup/wiki/Managing-ROMs

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #101714
    Profile photo of bitbytepixelsprite
    bitbytepixelsprite
    Participant

    Thanks for that, I mean its not a insurmountable problem, I can still use my controller for regular mame. Its just so weird that this specific emulator is giving me hell.

Viewing 22 posts - 1 through 22 (of 22 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar