Updated for 2.2: Step-by-Step Guide

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Updated for 2.2: Step-by-Step Guide

This topic contains 80 replies, has 16 voices, and was last updated by Profile photo of tdawg1982 tdawg1982 2 years, 4 months ago.

Viewing 35 posts - 36 through 70 (of 81 total)
  • Author
    Posts
  • #13103
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    I’m having a slight issue with accessing the menu from within the emulators. I think people normally access it using F1 on a keyboard.

    When I press F1, nothing happens. It did work once, before I configured my Xbox360 wireless pad, but now I can’t get it working.

    I’ve looked at the retroarch.cfg file and I presume the button needs to be mapped to the menu input command, but even when I change this to F1, nothing happens. I’ve also tried mapping it to a button on my controller (ideally the home button – 15 I presume) but nothing works. Even if I map it to a known button (ie. A button) I still can’t get the menu to appear.

    Does anybody know how to access the emulator menu in a game using the Xbox360 wireless pad? If so, what does you retroarch.cfg file look like?

    Would be eternally grateful for any help as this seems to be the only problem I have to my otherwise perfect setup…

    EDIT: I have now resolved this issue. I mapped the hotkey to F2 on the keyboard, then held F2 down before pressing F1. This then accessed the GUI from within the emulator and I was then able to assign my own button map using the settings in there. I then saved this as a new config file and replaced the retroarch.cfg one (the autosave feature saves it as a different .cfg file).

    #13144
    Profile photo of tandre
    tandre
    Participant

    <div class=”d4p-bbt-quote-title”>tandre wrote:</div>
    I dont know why but pressing 0 button, i.e. triangle on ps2 controller, emulators quit.

    Have you tried to set this one to “nul” and see if it still happens?

    input_exit_emulator_btn = “9″

    It was a stupid problem of quote i.e. “”

    input_enable_hotkey_btn = “8″
    input_exit_emulator_btn = “9″
    input_save_state_btn = “4″
    input_load_state_btn = “5″

    In your post you have differente quotes, change to “”. It’s a text formatting problem ( dont know if i’ve been clear)

    Another problem, when I’m getting out of a ROM I have a black screen and nothing happen… How to return to Emulation Station again? Thanks 🙂

    #13174

    michelle

    hi there!

    thanks alot for the information so far. i’m stuck at the part where i want to configure the joypad for pisnes. i don’t have the snes9x.cfg file. do i have to create it? sorry if it’s a stupid question. this is my first time ever working with anything linux related. kinda used to dos 🙂

    thanx,

    michelle

    #13225
    Profile photo of smatticus
    smatticus
    Participant

    I had to create it so maybe? I just created a .cfg in the cyberduck window and copied and pasted from the guide. I actually want to switch some of the settings for the video because some games play worse in pisnes than pocket SNES and vice versa. I already mentioned that its possible to have both emulators appear in the ES menu by adding pisnes to the es_systems.cfg but keep the pocketsnes entry there. I feel that since there really isn’t a “one size fits all” solution then why not have both?

    #13339
    Profile photo of zsprawl
    zsprawl
    Participant

    hi there!

    thanks alot for the information so far. i’m stuck at the part where i want to configure the joypad for pisnes. i don’t have the snes9x.cfg file. do i have to create it? sorry if it’s a stupid question. this is my first time ever working with anything linux related. kinda used to dos :)

    thanx,

    michelle

    Yes you need to create it.

    #13340
    Profile photo of zsprawl
    zsprawl
    Participant

    I’m having a slight issue with accessing the menu from within the emulators. I think people normally access it using F1 on a keyboard.

    Add this to your config file:

    input_menu_toggle = "f1"
    input_enable_hotkey_btn = "8"
    input_menu_toggle_btn = "9"

    You may need to change button numbers, but the gist of this is, you can either press F1 to enter the menu OR hold select and press start.

    #13591

    Foodsabsopini

    On vous propose cette fois le chouet clavier de la terre pour parler l’arabe en toute securité et chance , il peut s’integrer avec plusieurs moteurs de recherche telle que ask et bing , il ont la possibilité chercher sur rutube avec un seul click de la souris , apprenez l’arabe avec nous avec le meilleur plaisir de la langue arabe et la calligraphie arabe elle est de bonne qualité et tres belle a voir et a aimer avec le nez clavier arabe de maroc ou d’algerie ou en israel aussi il y a les algeriens qui souhaitent copier l’arabe mais ne trouvent pas les moyens adequats de le faire a moindre cout , on sait bien que les arabes sont tres radins et ne lachent pas l’argent dans les marchandises importantes mais si c’etait la viande ou la glace la ils sont les premiers n’en parlant pas de KFC , allez n’oubliez pas la valeur de vos ancetres avec le clavier arabe de la planete mars

    BBCode you used is not allowed.

    #13807
    Profile photo of smatticus
    smatticus
    Participant

    Ok is there a crash course in the pisnes .cfg somewhere? I like that you put your own settings up for us to use but since it’s a different t set of instructions than what retroarch uses, I have no idea how I would change anything. For instance the screen for pisnes with your settings is smaller and has a large black border along the bottom of the screen. Plus you put a note about using a js0 file for controller input but what do you mean?

    #13819

    Ahmed Abosriaa

    Hi I’m trying to set a connection with my raspberry pi using RPI Support package but i have this error message and i can’t solve it …. Can anyone help ?!

    #13833
    Profile photo of zsprawl
    zsprawl
    Participant

    Ok is there a crash course in the pisnes .cfg somewhere? I like that you put your own settings up for us to use but since it’s a different t set of instructions than what retroarch uses, I have no idea how I would change anything. For instance the screen for pisnes with your settings is smaller and has a large black border along the bottom of the screen. Plus you put a note about using a js0 file for controller input but what do you mean?

    I did learn a few things reading the official site, but not a lot.

    https://code.google.com/p/pisnes/

    In the end, I went back to the native SNES emulator after overclocking. It supports some of the better/later games, and works excellent at the higher clock settings. I’d recommend picking up a few cheap $3 heat sinks off Amazon though.

    #13914
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    I have pretty much got a perfectly running setup, with the exception of one thing: EmulationStation overscan!

    Firstly, I have edited the config.txt file to reduce the overscan by adjusting the values and uncommenting the lines. This is now set up perfectly and I get a perfect fit with the boot console, the splash screen and so on.

    However, once I have booted into EmulationStation and get to choose the emulator I want, the screen does not fit properly – i.e. I can see that the menu, buttons, select etc at the bottom right of the screen are not displaying correctly and are off the screen.

    I have even tried booting with HDMI mode set to VGA, but this does not work either.

    Has anybody else encountered this problem? If so, has anybody managed to resolve this?

    It’s not impacting the performance of the setup as the games run within the screen resolution, but it is bugging me!

    #14021
    Profile photo of ranem123
    ranem123
    Participant

    Change the section for SNES by uncommenting out the line for pisnes, and commenting out the current line. It should look like this when you’re done.
    <system>
    <fullname>Super Nintendo</fullname>
    <name>snes</name>
    <path>~/RetroPie/roms/snes</path>
    <extension>.smc .sfc .fig .swc .SMC .SFC .FIG .SWC</extension>
    <command>/opt/retropie/emulators/pisnes/snes9x %ROM%</command>
    <platform>snes</platform>
    <theme>snes</theme>
    </system>

    who can give me the stock es_systems.cfg or how i can revert this switch to the stock Snes Emulator ?

    #14035

    shaun wallace

    Thank you for taking the time to write this out. I am trying something a little different. I am using a Minipac from Ultimarc which is a keyboard encoder. Is there anyway to get snes working with 2 players using this method?

    My SNES config looks like this.

    [Keyboard]
    # Get codes from /usr/include/SDL/SDL_keysym.h
    A_1=100
    B_1=101
    X_1=97
    Y_1=98
    L_1=99
    R_1=102
    START_1=49
    SELECT_1=53
    LEFT_1=276
    RIGHT_1=275
    UP_1=273
    DOWN_1=274
    A_2=113
    B_2=114
    X_2=109
    Y_2=110
    L_2=111
    R_2=115
    START_2=50
    SELECT_2=54
    LEFT_2=106
    RIGHT_2=107
    UP_2=105
    DOWN_2=108
    QUIT=27
    ACCEL=8
    [Joystick]
    # Get codes from “jstest /dev/input/js0″
    # from package “joystick”
    A_1=1
    B_1=2
    X_1=0
    Y_1=3
    L_1=4
    R_1=5
    START_1=9
    SELECT_1=8
    A_2=1
    B_2=2
    X_2=0
    Y_2=3
    L_2=4
    R_2=5
    START_2=9
    SELECT_2=8
    QUIT=99
    ACCEL=7
    QLOAD=99
    QSAVE=99
    #Joystick axis
    JA_LR=0
    JA_UD=1
    JA_LR_2=0
    JA_UD_2=1
    [Graphics]
    DisplaySmoothStretch=1
    # Display Effect: 0 none, 1 scanlines, 2 phospher
    # NOTE Phospher does not run at full speed
    DisplayEffect=0
    MaintainAspectRatio=1
    DisplayBorder=0
    AutoFrameskip=1
    Frameskip=200
    Transparency=1
    CPUCycles=100
    [Sound]
    APUEnabled=1
    # Sound rates below as index, i.e. 7=44100 (some of these produce static)
    # 0, 8192, 11025, 16000, 22050, 29300, 32000, 44100
    SoundPlaybackRate=7
    InterpolatedSound=0
    #14049
    Profile photo of atimmins
    atimmins
    Participant

    Borerlandoflorida,

    In my case I had to fix overscan in the boot config so terminal and desktop modes fit the screen. However, when I wen to emulationstation, the screen was too large and I could not see all of the menu buttons in the lower left corner. I edited the retoarch.cfg in the “all” folder. I added commands similar to the ones in the boot config to get it where I wanted it. It works fine now.

    #14100
    Profile photo of zsprawl
    zsprawl
    Participant

    who can give me the stock es_systems.cfg or how i can revert this switch to the stock Snes Emulator ?

        <system>
            <fullname>Super Nintendo</fullname>
            <name>snes</name>
            <path>~/RetroPie/roms/snes</path>
            <extension>.smc .sfc .fig .swc .SMC .SFC .FIG .SWC</extension>
            <command>/opt/retropie/supplementary/runcommand/runcommand.sh 4 "/opt/retropie/emulators/RetroArch/installdir/bin/retroarch -L /opt/retropie/emulatorcores/pocketsnes-libretro/libretro.so --config /opt/retropie/configs/all/retroarch.cfg --appendconfig /opt/retropie/configs/snes/retroarch.cfg   %ROM%"</command>
            <platform>snes</platform>
            <theme>snes</theme>
        </system>
    #14103
    Profile photo of zsprawl
    zsprawl
    Participant

    Thank you for taking the time to write this out. I am trying something a little different. I am using a Minipac from Ultimarc which is a keyboard encoder. Is there anyway to get snes working with 2 players using this method?

    Probably but I’ve never used that keyboard encoder, but I would think you can look at /opt/retropie/configs/all to see what buttons are set to what, then use that to edit your snes9x.cfg.

    Sorry I can’t help ya more.

    Good luck!

    #14209
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    Borerlandoflorida,

    In my case I had to fix overscan in the boot config so terminal and desktop modes fit the screen. However, when I wen to emulationstation, the screen was too large and I could not see all of the menu buttons in the lower left corner. I edited the retoarch.cfg in the “all” folder. I added commands similar to the ones in the boot config to get it where I wanted it. It works fine now.

    Great, thanks for that. I’ll give it a go later. Good thinking!

    #14213
    Profile photo of tandre
    tandre
    Participant

    when I’m getting out of a ROM I have a black screen and nothings happen… How to return to Emulation Station again? Thanks

    #14486
    Profile photo of deaftolight
    deaftolight
    Participant

    This is gonna sound dumb as hell, but I’m a Linux noob that’s so exhausted from searching every little detail when I have a question… I have to ask. Is there a way to see what versions of the emulators I have? I did a binaries-based installation just to try to get everything to work, with plans to either do a source-based later or upgrade if need be.

    If anyone could let me know how to
    1. See my current versions
    2. Find out what the latest versions are
    3. Update to the latest versions

    Now I’m pretty sure the answer to #3 is to go through retropie-setup and do a source-based install. If that is the case, is there a way to uncheck all and then just select a few?

    Thanks!

    #14559
    Profile photo of zsprawl
    zsprawl
    Participant

    Now I’m pretty sure the answer to #3 is to go through retropie-setup and do a source-based install. If that is the case, is there a way to uncheck all and then just select a few?

    Yep and yep.

    #14698
    Profile photo of spock
    spock
    Participant

    Is there any way of getting ES-scraper working on 2.2, or another way to scrape quicker than within the ES interface?

    #14726
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    Ok, so I have tried what you suggested by adding the following lines to the retroarch.cfg:

    overscan_left=18
    overscan_right=18
    overscan_top=-18
    overscan_bottom=-18

    But this did nothing to the overscan problem within ES.

    Can you post your settings to compare please?

    #14853
    Profile photo of smatticus
    smatticus
    Participant

    ok so for .cfg files, is there a way to have it set so i when i want to play NES,snes,gen, etc that i can plug in my snes usb controller and play that way, and then when i want to play psx gaes i can plug in my ps3/360 wired controller and play those games with those seperate controls? because i got the ps3 controller setup easily, but then i wanted to go back to the snes controller and i had to delete a bunch of buttons and run the retroarch config again, which is a hassle.

    #14897
    Profile photo of zsprawl
    zsprawl
    Participant

    ok so for .cfg files, is there a way to have it set so i when i want to play NES,snes,gen, etc that i can plug in my snes usb controller and play that way, and then when i want to play psx gaes i can plug in my ps3/360 wired controller and play those games with those seperate controls? because i got the ps3 controller setup easily, but then i wanted to go back to the snes controller and i had to delete a bunch of buttons and run the retroarch config again, which is a hassle.

    Yeah you put the different retroarch.cfg files in the different folders located at:

    /opt/retropie/configs/all/retroarch.cfg
    /opt/retropie/configs/snes/retroarch.cfg
    #14956
    Profile photo of ranem123
    ranem123
    Participant

    Guys i try to set up my second Controller but nothing works !
    I try
    sudo ./retroarch-joyconfig -p2 -j 1 >> /opt/retropie/configs/all/retroarch.cfg
    and also
    sudo ./retroarch-joyconfig -j 0 >> /opt/retropie/configs/all/retroarch.cfg

    but my controller not be recognized in games !

    this my my config
    input_player2_joypad_index = “1”
    input_player2_b_btn = “2”
    input_player2_y_btn = “3”
    input_player2_select_btn = “8”
    input_player2_start_btn = “9”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”
    input_player2_a_btn = “1”
    input_player2_x_btn = “0”
    input_player2_l_btn = “6”
    input_player2_r_btn = “7”
    input_player2_l2_btn = “4”
    input_player2_r2_btn = “5”
    input_player2_l3_btn = “10”
    input_player2_r3_btn = “11”
    input_player2_l_x_plus_btn = “h0right”
    input_player2_l_x_minus_btn = “h0left”
    input_player2_l_y_plus_btn = “h0down”
    input_player2_l_y_minus_btn = “h0up”
    input_player2_r_x_plus_axis = “+3”
    input_player2_r_x_minus_axis = “-3”
    input_player2_r_y_plus_axis = “+2”
    input_player2_r_y_minus_axis = “-2”

    #14984
    Profile photo of zsprawl
    zsprawl
    Participant

    Have you tried:

    input_player2_joypad_index = "2"

    as well?

    #15398
    Profile photo of deaftolight
    deaftolight
    Participant

    I’m getting confused on the the proper way to configure controllers. Are we still supposed to use the joyconfig pipe to configure our controllers? I don’t know because but I stumbled across a configuration option somewhere that I can’t even remember… it had me enter the buttons, and would actually allow you to time out for L2, L3, etc. if you were using an SNES controller. This configuration option was the one that would create the files like /opt/retropie/emulators/RetroArch/configs/2Axes11KeysGamepad.cfg

    It didn’t add anything into the /opt/retropie/configs/all/retroarch.cfg, though, but doing that for an SNES USB controller and a PS3 BT controller worked. So the only stuff in the retroarch.cfg is the initial keyboard inputs set up in emulationstation, and the exit and save/load state hotkeys I added here.

    So I’m unsure as to what the correct way to configure the controllers in 2.2 is… using the joyconfig pipe, or the other way that created those autoconfig files. I can’t even remember what tool I used… it may have been registering the controller in retropie_setup.sh that launched it. I can’t remember as I was just spending a lot of time that day trying to get the controllers to work.

    So I needed to swap them so player 2 was player 1 and vice versa. Adding this to retroarch.cfg fixed that:

    input_player1_joypad_index = "1"
    input_player2_joypad_index = "0"

    I don’t know if that is the way swapping controller numbers is supposed to be done.

    I’m also trying to add a hotkey for hold to speed and menu toggle, so I added these

    input_enable_hotkey_btn = "8"
    input_exit_emulator_btn = "9"
    input_save_state_btn = "4"
    input_load_state_btn = "5"
    input_hold_fastforward = "3"
    input_menu_toggle = "0"

    at the end of retroarch.cfg. The exit, save, and load ones worked, but the fast forward and menustoggle did not.

    Also, since I have 2 different controllers, I started to think that these hotkeys might conflict, since button 8 on the SNES pad is Select, and 8 on the PS3 controller is L2. Sorry for the wordy post, but with all the recent updates to 2.2, I picked the worst time to try and figure all this out. 🙂 A lot of old methods has become misinformation and not a lot of the new updates have been covered.

    #15537
    Profile photo of K-Project
    K-Project

    Hi. Is there any way to access the Retroarch GUI that was present in the last release? Though tricky at first I began to find this an essential add-on to Retropie, and I’m really missing it with this 2.2 release. I tried adding-

    input_menu_toggle = “f1”

    -to my config file but for whatever reason it doesn’t work. No response from pressing that button with a keyboard attached, presuming this would be the required setting to access the RGUI.

    Thanks. 🙂

    #15606
    Profile photo of zsprawl
    zsprawl
    Participant

    Hi. Is there any way to access the Retroarch GUI that was present in the last release? Though tricky at first I began to find this an essential add-on to Retropie, and I’m really missing it with this 2.2 release. I tried adding-

    input_menu_toggle = “f1″

    -to my config file but for whatever reason it doesn’t work. No response from pressing that button with a keyboard attached, presuming this would be the required setting to access the RGUI.

    Thanks. :)

    Are you pressing F1 while in a game? That is when you have to do it.

    #15647
    Profile photo of K-Project
    K-Project

    Hi and thanks for your response. 🙂

    Yes I am pressing the key during the game. To be honest I’ve tried it all ways but it does not respond either way. I’m also noticing other keys don’t work, such as shader selection using the n and m keys, but other inputs do such as my button 8 and 9 hotkey exit as detailed here elsewhere.

    I don’t really know what’s happening but could it be something to do with the new read-only permissions on the file in 2.2? Can the Retropie system not access it properly perhaps? Just a stab in the dark.

    #15687
    Profile photo of zsprawl
    zsprawl
    Participant

    Hi and thanks for your response. :)

    Yes I am pressing the key during the game. To be honest I’ve tried it all ways but it does not respond either way. I’m also noticing other keys don’t work, such as shader selection using the n and m keys, but other inputs do such as my button 8 and 9 hotkey exit as detailed here elsewhere.

    I don’t really know what’s happening but could it be something to do with the new read-only permissions on the file in 2.2? Can the Retropie system not access it properly perhaps? Just a stab in the dark.

    hmmm not sure. You can always do:

    chown -R pi /opt/retropie/configs

    Make sure you have the right localization for your keyboard though in raspi-config.

    #15803
    Profile photo of borlandoflorida
    borlandoflorida
    Participant

    Hi and thanks for your response. 🙂

    Yes I am pressing the key during the game. To be honest I’ve tried it all ways but it does not respond either way. I’m also noticing other keys don’t work, such as shader selection using the n and m keys, but other inputs do such as my button 8 and 9 hotkey exit as detailed here elsewhere.

    I don’t really know what’s happening but could it be something to do with the new read-only permissions on the file in 2.2? Can the Retropie system not access it properly perhaps? Just a stab in the dark.

    I had the same issue and what I did to resolve this was to change the hockey button to F2. Then I held F2 down before pressing F1 then voila! I was then able to map the buttons to my controller from the settings and then changed them to what I wanted.

    Hope this helps.

    #15974
    Profile photo of deaftolight
    deaftolight
    Participant

    Yes I am pressing the key during the game. To be honest I’ve tried it all ways but it does not respond either way. I’m also noticing other keys don’t work, such as shader selection using the n and m keys, but other inputs do such as my button 8 and 9 hotkey exit as detailed here elsewhere.

    I think you have to press your enabled hotkey and F1 on the keyboard. So if your hotkey is select on your controller, you have to hold that and then hit F1 on your keyboard.

    However, I’ve noticed that the menu doesn’t toggle (you can’t exit with F1, only enter). I have to choose Resume Content from the RGUI to get back into the game. Not really a big deal. It’s just odd, because a couple of days ago I was able to enter and exit the RGUI menu with the assigned hotkey. Anyone else notice this?

    #16045
    Profile photo of K-Project
    K-Project

    My thanks to zsprawl, borlandoflorida and deaftolight for your solutions. I’ll give them a try and post back. 🙂

    #16662

    m88

    You expressed it terrifically.

Viewing 35 posts - 36 through 70 (of 81 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar