unable to mount root FS after resizing SD root

Welcome Page Forums RetroPie Project New to RetroPie? Start Here! unable to mount root FS after resizing SD root

This topic contains 5 replies, has 2 voices, and was last updated by  sjoerdw 2 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #112420

    sjoerdw
    Participant

    Hello, i downloaded the img file and created the SD from it. Works like a charm, but only 56 mb left and it’s a 8GB card.

    I used the command: sudo raspi-config and choose option 1 to extend the fs and rebooted it. Only after the reboot it doesn’t seem to find the root partition anymore 🙁

    PANIC: VFS: Unable to mount root fs on unknown-block(179,2)

    Any tips? 🙂

    #112421

    petrockblog
    Keymaster

    Probably related this issue – https://github.com/RetroPie/RetroPie-Setup/issues/1141

    If you rewrite the image again, make those editos to /etc/fstab and then resize it should be ok.

    #112918

    sjoerdw
    Participant

    Thats not the solution, I also tried version 3.3.1 now. Still getting the error after extending the partition and a reboot

    #113005

    sjoerdw
    Participant

    before the reboot i get this error message: Re-reading the partition table failed with error 16: device or resource busy

    Anyone ?

    #113016

    petrockblog
    Keymaster

    Problem with your SD card ? Worth trying another in case it is.

    #113288

    sjoerdw
    Participant

    ordered a new one..waiting for it and will check 🙂

Viewing 6 posts - 1 through 6 (of 6 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss