UAE4ARM strange issue

This topic contains 3 replies, has 2 voices, and was last updated by  windale 2 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #109283


    Last night, I did binary update to the latest uae4arm v0.4 in RetroPie v3.0 final on my RPI 2.
    Emulator works well but have a strange issue, because Z3 fast memory is not working at all.
    When I add any amount of the Z3 Fast memory in any configuration, I get a “Defective board” message (red screen), when starting Amiga.
    After the second restart, Amiga boot on, but without any Z3 memory.
    Other types of memory (Chip, Slow and Fast) are working properly, but this isnt enough for some demanding demos, becouse of 8mb limit.
    In the previous version everything worked well, but this new one has better compatibility and I’d like to keep it.
    Can anyone confirm this beaviour and give me a clue how to solve this?



    Can someone at least confirm this behavior?
    I also did the installation from source but the problem is still there.
    Emulator works fine, except Z3 memory reported as defective.



    Is anyone willing to spend a few minutes to start the emulator and do the following?
    CPU set to 68040
    Chipset set to AGA
    Z3 RAM memory set to any value from 1 to 64 Mb

    Start and see whether it shows red “RAM Expansion Board” message with Z3 memory board as Defective.
    Just that simple confirmation, nothing else.
    Thank you in advance.



    I tried a 68030 with 16mb Z3 memory and on boot I got a red screen with ‘Expansion Board Diagnostic’ and it said ‘Board Number 2’ ‘Product 3’ was defective.

    JIT also doesn’t work properly. According to TomB (who implemented JIT into the Pandora port), JIT is only useful when using CPU speed “Fastest”, but if you do this then a lot of Games/Demos end up having crackling sound and also slower video. I couldn’t see any difference when I turned JIT off. Also when leaving a WHDLoad Game/Demo and go back to ClassicWB you can hear a fast repeating sound that lasts a few seconds.

    So to sum up, when JIT is on I get worse performance.

    Tested on Raspberry Pi 2 with RetroPie v3.2.1. I also updated UAE4Arm from ‘Source’.

    So confirmed, JIT and Z3 memory do not work properly on RetroPie RPi 2.

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently read only - please visit the new RetroPie forums at

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss