UAE4ALL + Pi 2

This topic contains 18 replies, has 12 voices, and was last updated by  Anonymous 2 years, 7 months ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #88505

    Anonymous

    Hello, I have the latest Raspberry Pi 2 + Retropie v2.6 image. I have copied across a number of known working kickstart roms + disk images that work great on my WinUAE emulator on my PC.

    When I try to use UAE4All (from the Retropie image) on my Pi 2, I get to configuration GUI just fine, I select the correct kickstart ROM, (I have placed my kick ROMs in the correct folder and named them appropriately) select a game, however when I click “Reset” to commence the loading procedure, the video output just goes black and the Pi appears to lock-up. I need to power cycle it to bring it back to life. It’s hangs right when it should commence to load the kick ROM as soon as you click “Reset”…

    For reference, I have a keyboard + Sony PS3 controller plugged in.

    Does anyone have any idea? I REALLY want to get this going as I am an Amiga diehard….

    Thanking you all in advance!
    Ross

    #88506

    Anonymous

    I should point out that the Pi hasn’t ACTUALLY locked up. I can still communicate with it over SSH without a problem, however the buttons and keys on the plugged in keyboard and PS3 controller do nothing – the screen simply stays black…

    #88624

    devo
    Participant

    I have exactly the same problem with this. I’m using the same hardware, Pi2 and PS3 controllers with the 2.6 image. I have various working kick roms which I’ve named kick13.rom, kick20.rom, kick31.rom and placed in the RetroPie BIOS folder.
    I get to the UAE4All menu page without any problems, but once I’ve placed my game images in the virtual floppy drive and press the reset button I get stuck in a black screen and have no choice but to reboot my Pi.

    I’d really appreciate it if somebody could provide more comprehensive instructions on how to get this emulator up and running. I really want to play my old Amiga games again!!

    #88639

    Floob
    Member

    I’ve had a quick go this weekend, I’ll put a video up soon.
    Have you tried selecting the A500 defaults button on the first screen?

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #88661

    devo
    Participant

    I think I have discovered what the problem is with the black screen on UAE4all. I have now managed to get the emulator to work. The problem is the PS3 controller. (I use a PS3 controller via bluetooth.)

    I booted up Retropie with only my keyboard connected, I used the keys to navigate emulation station’s menus and boot up the Amiga emulator. Suddenly all games loaded perfectly, no black screen anymore.
    If I go back and reboot Retropie with the controller connected the frozen black screen returns when I try to load an Amiga game. However, if I turn off the controller while I’m still stuck in the black screen, the game will boot the instant the controller switches off.
    Once I have loaded a game for the first time I seem to be then able to reconnect the controller again. I can then go back to the menu and boot other games without further black screen errors.

    I’ve only just discovered this and haven’t so far attempted to play any of these games, but they do now load up. The Amiga could have other PS3 controller problems which I’m not aware of yet, but hopefully this will help others who may be suffering with this same black screen error.

    #88689

    amigauser22
    Participant

    Hi guys

    I’m having the same problem. I load an image into df0, hit reset and get a blank screen.

    As suggested, I’ve tried various combinations of unplugging the wireless mouse, keyboard and logitech f710 Bluetooth devices I’m using without any luck.

    FYI I’m using amiga forever by cloanto kickstart roms as follows:
    amiga-os-130.rom renamed to kick13.rom
    amiga-os-310-a500.rom renamed to kick31.rom
    Both have been copied to the bios folder. Not sure which kick20 room to use so I haven’t copied it, could that be the problem?

    Uae4all on Android requires the kick roms be certain sizes, perhaps that is the problem?

    I choose the kickstart rom from the bios directory, it defaults to “cust” kickstart and I’ve tried leaving it there or selecting 1.3 or 3.1 depending.

    No luck.

    #88696

    Anonymous

    Thanks for your reply devo! I actually inadvertantly realised it was was the controller a short while ago!

    amigauser22, I am using the ~256kb kick13.rom and that one works perfect. I couldn’t get it to work with any of the 512kb kick13.rom images.

    Does anyone know who we need to speak to in order to get the PS3 gamepad issue fixed?

    Thanks to all for your useful replies!

    Cheers,
    Ross

    #88836

    amigauser22
    Participant

    All

    I also have had some success however it was after trying a new kick rom image. For me it didn’t seem to have anything to do with controllers like other users have found

    Cheers

    #88905

    ftjosas
    Participant

    I have the same problem with the PS3 controller. The games wont load if it is connected either via bluetooth or usb. When I disconnect the games load. However in game I am not able to anything as I have apparently not been able to configure any controls for the emulator.
    I would much appreciate if anyone can point me in the right direction to where I might learn more about the controls for this emulator and how to configure.

    Using RPI2 and version 2.6.0 of retropie

    #88978

    anotherdan
    Participant

    I get the same black screen behaviour.

    • PI2
    • 2.6.0 image
    • Amiga forever roms
    • NES-like usb joypad from retrolink

    Haven’t tested if it works without the joypad connected, but will do so this weekend…

    #89392

    amigauser22
    Participant

    All

    I resolved my black screen issue by using different kickstart roms. Suggest those who are having an issue try the aros roms included with the emulator as these seem to work fine for most games. Do this before diagnosing a hardware issue

    Cheers

    #89948

    anotherdan
    Participant

    Got it running using another rom as well, can’t get the AmigaForever or included aros rom to work…

    Been playing Sensible Soccer, Kick Off 2 and Erik this evening… I’m 10 again…

    #90055

    gingerbeardman
    Participant

    Got it running using another rom as well, can’t get the AmigaForever or included aros rom to work…

    Been playing Sensible Soccer, Kick Off 2 and Erik this evening… I’m 10 again…

    How is the performance of Sensible Soccer? That’s my reason for investing in this setup.

    I’d be using it with a “Genesis->USB” (by retro-bit) controller adapter USB cable. And some original Atari/Amiga joysticks!

    #90056

    anotherdan
    Participant

    I had a couple of lags, but otherwise it was quite OK… Can let you know after this coming weekend; where I’ll do some more tweaking and testing…

    Hopefully with the new joysticks I’m waiting for… I should have ordered that adaptor as well – might do down the line to play with wico joysticks… But for now it will be competition pro in the USB version as well as the NES for other types of games 😀

    #90822

    kaitain
    Participant

    Out of interest, with which roms did you finally get the thing to work? I had a quick attempt to play Sensi and Sidewinder over the weekend and in both cases it was just the dead black screen of doom. (I was also using a PS3 controller plugged in, though.)

    #93335

    chiangkl
    Participant

    Same issue with a wired USB controller. uae4all won’t load if it is connected with the usb controller. The games load when I disconnect the USB controller.

    I am now with uae which is practically useless if I can’t use by game controller.

    Any fix?

    #93789

    zx-9r
    Participant

    Same problem here… uae4all works just fine, until i connect my sixaxis… then it’s just a black screen when starting a rom… 🙁

    #93793

    trixster
    Participant

    SWOS 96/97 with the syncronated swos 13/14 team updates and two competition pro usb joysticks is retro gaming heaven.

    #93808

    Anonymous

    Hi

    Using

    • 3.0 Beta image
    • PS3 Controller
    • “Real” kick Roms

    Get the same black screen issue. Unplugging the PS3 controller causes the emulator to boot but cannot then use the controller within uae after reconnection (controller works within emulation station if you kill the uae processes which returns you back there)
    Steve

Viewing 19 posts - 1 through 19 (of 19 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/