Turbografx / PC Engine Button Mixup

Home Forums RetroPie Project Ideas for Further Enhancements Turbografx / PC Engine Button Mixup

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of LodanZark LodanZark 1 year, 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #108687
    Profile photo of ando
    ando
    Participant

    Hello,

    You guys might already be aware of this but the Turbografx / PC Engine face buttons are not mapped according to this link: https://github.com/RetroPie/RetroPie-Setup/wiki/PC-Engine . Instead Y is mapped to the ‘I’ button and B to the ‘II’ button, requiring some unconventional remapping of the buttons on a SNES controller in order use the buttons you want.

    Just thought I should mention this and thanks so much for all your work!!

    #108711
    Profile photo of herbfargus
    herbfargus
    Member

    Thanks, I’ll fix it when I find the time

    #108713
    Profile photo of herbfargus
    herbfargus
    Member

    Should be fixed now

    #108742
    Profile photo of ando
    ando
    Participant

    Thank you!

    #109604
    Profile photo of ando
    ando
    Participant

    Just a follow-up – I’ve updated to 3.2.1 and the button mapping hasn’t changed. Will it be updated in version 3.3? I’m in no rush but I just wanted to point this out in case it was overlooked.

    Thanks again!

    #109612
    Profile photo of herbfargus
    herbfargus
    Member

    I only changed the image to match the core mapping of the emulator not the other way around. The core button mappings are hard coded on retroarch’s end, we don’t have anything to do with how the core emulator buttons are mapped, that’s retroarch’s deal.

    #109616
    Profile photo of ando
    ando
    Participant

    Ah, gottcha. Thanks for the explanation. Now I understand.

    Keep up the good work!

    #111888
    Profile photo of LodanZark
    LodanZark
    Participant

    Well the core mapping will not get remapped: https://github.com/libretro/beetle-pce-fast-libretro/issues/22

    yet you can use the the core remap feature to fix the issue:

    Overlays/Pillarboxs and other goodies for Retropie:
    https://www.dropbox.com/sh/3a7ylhwy3an2xrl/AAD-dOH-BXGuBrl6zphmJvyYa?dl=0

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar