Trouble with Xbox 360 & Xbox One controllers

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Trouble with Xbox 360 & Xbox One controllers

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of flemo84 flemo84 2 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #91093
    Profile photo of flemo84
    flemo84
    Participant

    Morning Ladies & Gents
    I have had my RasyberryPi 2 now for about a week. And it bloody awesome.
    I mainly got it so i can Retro Game on it. And well. Retropie is the way to go.

    I am having some issues getting the Xbox 360 controller & the Xbox One controller working. Not together. Originally the 360 control wasn’t working so i tried the One controller with the same results.

    Heres what i have done.
    Using Win32DiskImager i have written the RetroPi pi2 img to my mirco SD. (4 times in an effort to get it to work and to use fresh settings etc)
    Followed a number of guides Basicly the following steps

    1) Install xboxdrv (Have done from terminal both via puTTY & direct KB access to PI). Also from the sudo ./retropie_setup.sh script setup (puTTy & direct) (updated ofcourse)

    2) After reboot setup the init script files exactly from these instructions https://github.com/retropie/RetroPie-Setup/wiki/Setting-up-the-XBox360-controller

    3) Rebooted. Then configured the Controllers from the Register Retroarch Controller option (puTTY & direct) Both controllers registered button press’s correctly.

    4) Rebooted into EmulationStation. It detects the gamepad on boot and i can successful config that for use with ES.

    5) Now heres the issue. I am trying to run SMB & SMW on the SNES emulator (tried all 3) and i can press start on the screen where all the characters are, goes into game selection screen. I can select game using D-pad and Start. I can start a 1P game. Then in Super Mario World it does the first initial popup (video here. http://youtu.be/rIQZR2799Q0) and it just stops responding

    Software
    I believe is the EmulationStation 2.6

    Hardware setup is
    Xbox 360 controller connected via Xbox 360 USB receiver
    Xbox One controller connected via usb cord (PI is powered sufficiently)

    Any ideas?
    Any help would be appreciated

    #91175
    Profile photo of Floob
    Floob
    Member

    Couple of things, Mario All Stars can be a problem with some emulators.
    Try this in Mario Kart instead.

    Also, retroarch appears to be detecting 4 controllers, which is how many the wireless hub can pick up.
    I’m no expert with xbox controllers, but this may help:

    http://dai.ly/x2i0ufc

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #91197
    Profile photo of flemo84
    flemo84
    Participant

    Hey Mate,
    Thanks for the reply.
    I have watched and followed this video twice. It was the best video i could find. Still didn’t have any luck

    #91230
    Profile photo of Floob
    Floob
    Member

    Have you tried blacklisting xpad?

    XBox 360 wireless controller – blinking lights

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #91257
    Profile photo of flemo84
    flemo84
    Participant

    I just tried blacklisting the xpad. still no luck.

    New day today so i am re writing the image and going to try again.

    I dont know if it matters but the Atari 2600 emulator works fine. I have been playing Enduro on that. So maybe it is working fine and the Rom is the problem. Once the clean install has happened i will try Mario Kart

    i’ll keep you posted

Viewing 5 posts - 1 through 5 (of 5 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar