Trouble resizing video

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of Roo Roo 2 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #87431
    Profile photo of gazjcollins
    gazjcollins
    Participant

    Hi all,

    I wonder if you might be able to help me.

    I am having trouble resizing the video output of RetroArch, particularly for the GameBoy emulator. I would like to have the display “shrunk” so that it sits in the centre of the screen – I am using a GameBoy overlay and would like the output to fit in the screen portion of this overlay.

    I have tried adjusting nearly every video parameter in RetroArch.cfg (the GB specific one) but to no avail. No matter what I try the output pretty much fills the screen.

    I would be very VERY grateful if anybody could point me in the right direction!

    #87449
    Profile photo of Floob
    Floob
    Member

    Which version of RetroPie are you using?
    2.4.0 and up allows you to press “x” as the game loads to set the resolution.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #87467
    Profile photo of gazjcollins
    gazjcollins
    Participant

    Hi Floob.

    Thanks for your reply – managed to fix this by finding my way to the rGUI, making the settings I needed and then saving the config. Then used this config to replace the retroarch.cfg in the GB folder so that it works each time I load it up.

    Thanks again 🙂

    #87481
    Profile photo of Roo
    Roo
    Participant

    this is my /opt/retropie/configs/gb/retroarch.cfg

    # All settings made here will override the global settings for the current emulator core
    
    video_shader_enable = true
    video_shader = /opt/retropie/emulators/retroarch/shader/bead.glsl
    
    input_overlay_enable = true
    input_overlay = /opt/retropie/emulators/retroarch/overlays/gb.cfg
    input_overlay_opacity = 0.70 # 1.0
    input_overlay_scale = 1.0
    
    aspect_ratio_index = "22"
    custom_viewport_width = "645"
    custom_viewport_height = "648"
    custom_viewport_x = "637"
    custom_viewport_y = "275"
    

    which gives me the picture attached

    Just curious what settings you’re using? I don’t see too many people using RetroArch shaders and overlays. To be fair, I tried on on the Pi 1 but performance suffered too much. With the Pi 2 I’ve been trying them again.

    Attachments:
    #87565
    Profile photo of Floob
    Floob
    Member

    Hi Roo,

    Could you share you gb.cfg overlay file?
    Looks really nice.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #87589
    Profile photo of Roo
    Roo
    Participant

    Sure, I am (pretty much) using the ones from here:

    http://retroarchborders.blogspot.com/

    I’ve edited a few of them to make it more like the consoles I remember growing up. For example SNES was not the US version.

    Be warned, borders in RetroArch can be a bit of a pain. If you move to a different display with a different resolution, you’ll need to change the viewport settings. And also, RetroArch on the Pi doesn’t seem to have the menu option to resize in the emulator. I end up figuring out the viewport settings on my PC and then editing the cfg file to match

    #87619
    Profile photo of gazjcollins
    gazjcollins
    Participant

    And also, RetroArch on the Pi doesn’t seem to have the menu option to resize in the emulator. I end up figuring out the viewport settings on my PC and then editing the cfg file to match

    To get to the menu – you need to enable a hotkey in the cfg file. Once you gave done this, you can press this hotkey and F1 on the keyboard to open the menu.

    #87650
    Profile photo of Roo
    Roo
    Participant

    I should have made that clearer 🙂

    I can get into the menu, but on the PC RetroArch I have the option for “Custom Ratio” where I can move the top left corner and bottom right corner to fit the overlay. On the Pi, I don’t see this option, it seems to be missing.

    Oh and gaz – see my post above. What settings are you using? I’d like to compare.

    Attachments:
Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar