Timing issues MSX emulator

This topic contains 1 reply, has 1 voice, and was last updated by  mhens 2 years, 10 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #89926

    mhens
    Participant

    Hi All,

    I received my Raspberry Pi 2B last Friday and installed RetroPie on it, so far I absolutely love it!!! But I do run into a VERY strange problem with the MSX Emulator.

    Here’s the deal; when I select any MSX game, the emulator starts and the game intro runs absolutely fine. Then, as soon as I hit the space bar on my keyboard; the game speeds up to ridiculous speeds. Pressing the space bar again results in normal game speed, etc. As you can imagine, this makes happy gaming a bit difficult 🙁

    My RetroPie version: Linux retropie 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l GNU/Linux

    I’ve detached WIFI and Bluetooth dongles and have only a wired keyboard attached.

    I’ve included a movie of my setup where you can see the difference when pressing the space bar each time at: https://www.youtube.com/watch?v=iDBCKjWaOe0&feature=youtu.be

    Any help would be appreciated!

    MSX timing retropie keyboard

    #90208

    mhens
    Participant

    Turned out that the retroarch.conf keymapping has space mapped to default as ‘toggle fast forward’. Overriding this setting made the problem go away.

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss