tht tht arcade 2 player usb controller

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project tht tht arcade 2 player usb controller

This topic contains 15 replies, has 5 voices, and was last updated by Profile photo of clownfish360 clownfish360 2 years, 4 months ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #84692
    Profile photo of rpiretropierpi
    rpiretropierpi
    Participant

    I tried to configure the 2 player controller.
    Only 1 controller works at the same time, also the 1/2 player selection button and the coin button does not work.
    Can someone help me ?

    #84713
    Profile photo of Floob
    Floob
    Member

    If you use MAME, you should be able to set all these keys with pressing TAB when the game has loaded.

    RetroPie help guides --> https://goo.gl/Yfy8kj
    Please read this before asking for help --> http://goo.gl/eLErnl

    #84723
    Profile photo of dpicc68
    dpicc68
    Participant

    Hey….. I too have a THT controller and so far have it set up for Mame, RetroArch (SNES, NES, SEGA etc)
    Having some issues with PiFBA.. But thick I’ll have a solution soon.

    Hang Tight… And I’ll post my setting / procedure when I get home from work.

    In the mean time…
    Perform a Jtest..

    Go to terminal and type-

    sudo apt-get install joystick

    Then

    jstest /dev/input/js0

    Click your buttons… And write down the “btn” and “Axes” values.

    You should draw out your CP and write the values over the layout. (Makes it easier to tweak)

    You should also hunt around the forums.. / floob have a number of tutorials on YouTube that should point you in the right direction..

    Hope that helps in the mean time.

    Sent from my iPhone using Tapatalk

    #85017
    Profile photo of dpicc68
    dpicc68
    Participant

    THT – Joystick Keyboard resolved….. Mame4All + PiFBA.

    Ok, first of all, I have only been using the Pi for a couple of months / newby when it comes to Linux… (more of a DOS 6.0 back in the day)

    I seemed to have fixed Mame4ALL 15+ Buttons + PiFBA 2 player js0 issue.
    It seems that THT joystick is the same of XinMo to which the guys over at PiPlay have re-compiled binaries / patched Kernals.

    Here it goes.
    – Fresh Install…… update binaries / setup script etc….
    – Test a few games…. then make a backup of SD Card….
    – Head over to – http://pimame.org/forum/discussion/1015/xin-mo-compatible-emulators-pisnesmame4allpifba/p1 and have a read through the posts…..
    I didn’t compile the Binaries, just copied them from the clone source.

    I would suggest you start with piFBA as it still has inverted joystick issues (could work that part out)

    Pi-FBA
    Open FileZilla or alike…. connect to Pi….
    Navigate to – $ /opt/retropie/emulators/pifba (from memory)
    create backup of “fba2x” file
    Go to :- https://github.com/ian57/Raspicade-pibfa-xinmo
    Then navigate to….. fbacapex….. click on description.
    fba2x raw file is in there…

    link – https://github.com/ian57/Raspicade-pibfa-xinmo/commit/87171341d14b74d04589d30d60dc868f234afe01

    Copy patched binary “fba2x” (its about 3.7Mb)into PiFBA folder.
    Run a jstest as stated above…. write down all your buttons.
    Then edit the fba2x.cfg (on pi….. look in forum for how to configure / location) – you can copy the text within the cfg found on Conno’s github clone source… and paste it into the Pi’s cfg file.
    Fire up Emulationstation.. start a game… you should now have 2 players working.
    Note that My Up/Down axes was inverted… for this I removed my CP panel and switched the wires….
    You should now have 2 players working…. happy days.

    Mame4All – Pi
    Open FileZilla or alike…. connect to Pi….
    Navigate to – $ /opt/retropie/emulators/mame4all-pi (from memory)
    create a backup of mame file
    Go to :- https://github.com/ian57/Raspicade-mame4all-xinmo
    Copy patched binary “mame” (its about 9.5Mb) into Mame folder.
    Launch Pi / Mame game…. press TAB on keyboard and configure controls.
    Now you have all 22 buttons working….;-)

    In order to configure all other emulators… search around the forum..which is pretty easy compared to the above.

    Good Luck….

    #85178
    Profile photo of edy80y
    edy80y
    Participant

    Hi dpicc68, thanks for the guide on sorting PiFBA. Im trying to follow your guide but the link for “Go to :- https://github.com/Conno123009/PiFBA-Xin-Mo” returns a 404 on the github site. Can you please fix the link??

    Cheers,
    edy80y

    #85200
    Profile photo of dpicc68
    dpicc68
    Participant

    Conno must have taken down his/her clone…..

    Try
    https://github.com/ian57/Raspicade-pibfa-xinmo
    (original source)
    Navigate to fbacapex… (select description) this shows up the two raw binary files.

    https://github.com/ian57/Raspicade-pibfa-xinmo/commit/87171341d14b74d04589d30d60dc868f234afe01

    that should work….(I have updated the link above)
    Let me know if it works for you.

    #85209
    Profile photo of edy80y
    edy80y
    Participant

    Thanks mate, i can access it now.

    And just so i understand your instructions, do i simply replace the fba2x and fbacapex files on my RPi with the ones in github and it should all work??

    Cheers

    #85210
    Profile photo of dpicc68
    dpicc68
    Participant

    Yep…
    I didn’t copy fbacapex…. But you can give it a go….

    Make sure you backup the files first… And set permissions to 777… (Not sure if this is required.. But doesn’t hurt)

    #85211
    Profile photo of edy80y
    edy80y
    Participant

    awesome, thanks πŸ™‚

    #85218
    Profile photo of edy80y
    edy80y
    Participant

    Just wanted to let everyone know that dpicc68’s method works perfectly.

    I too had to rewire the up/down but that only took 5 seconds and another 5 seconds to remap them again in ES and Mame.

    thanks

    #85219
    Profile photo of dpicc68
    dpicc68
    Participant

    Great…
    Im glad you got it working.

    I’ve got a copy of the amended binary files… So if the clone source above goes off line… Pm me.

    #87698
    Profile photo of clownfish360
    clownfish360
    Participant

    I am running the Xin-Mo Dual Arcade and having the same issue with the joysticks. The buttons seem to work fine for payer 1 and player 2 respectively but my joysticks player 1 and 2 seem to work as the same joystick. Strange.

    Here is my configuration of the two joysticks in retroarch.cnf. Should the index be 0 for both? Also should the axis be the same for both?

    input_player1_joypad_index = “0”
    input_player1_a_btn = “1”
    input_player1_b_btn = “0”
    input_player1_y_btn = “2”
    input_player1_x_btn = “3”
    input_player1_start_btn = “4”
    input_player1_select_btn = “5”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0″

    input_player2_joypad_index =”0”
    input_player2_a_btn = “11”
    input_player2_b_btn = “10”
    input_player2_y_btn = “12”
    input_player2_x_btn = “13”
    input_player2_start_btn = “4”
    input_player2_select_btn = “5”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”

    input_enable_hotkey_btn = “4”
    input_exit_emulator_btn = “5”

    I tried the patch above for Pi-FBA and am testing on SNES emulator.

    #87714
    Profile photo of dpicc68
    dpicc68
    Participant

    Might be a small thing…
    But you have the “start” and “select” 4&5 for both controllers.
    Mine are configured separately.
    In RetroArch, PiFBA and mame.

    #87726
    Profile photo of clownfish360
    clownfish360
    Participant

    Thanks for the suggestion. I removed the lines that you recommended but still not working. Here is my entire input config under /opt/retropie/configs/all/retroarch.cfg

    #### Input
    input_autodetect_enable = false

    # Keyboard input, Joypad and Joyaxis will all obey the “nul” bind, which disables the bind completely,
    # rather than relying on a default.
    input_player1_a = x
    input_player1_b = z
    input_player1_y = a
    input_player1_x = s
    input_player1_start = enter
    input_player1_select = rshift
    input_player1_l = q
    input_player1_r = w
    input_player1_left = left
    input_player1_right = right
    input_player1_up = up
    input_player1_down = down
    input_exit_emulator = escape

    # Applies next and previous shader in directory.
    input_shader_next = m
    input_shader_prev = n

    input_player1_joypad_index = “0”
    input_player1_a_btn = “1”
    input_player1_b_btn = “0”
    input_player1_y_btn = “2”
    input_player1_x_btn = “3”
    input_player1_start_btn = “4”
    input_player1_select_btn = “5”
    input_player1_up_axis = “-1”
    input_player1_down_axis = “+1”
    input_player1_left_axis = “-0”
    input_player1_right_axis = “+0″

    input_player2_joypad_index =”0”
    input_player2_a_btn = “11”
    input_player2_b_btn = “10”
    input_player2_y_btn = “12”
    input_player2_x_btn = “13”
    input_player2_up_axis = “-1”
    input_player2_down_axis = “+1”
    input_player2_left_axis = “-0”
    input_player2_right_axis = “+0”

    input_enable_hotkey_btn = “4”
    input_exit_emulator_btn = “5”

    #87740
    Profile photo of edy80y
    edy80y
    Participant

    Hi clownfish360,

    re-add the following start/select buttons for Player 2 (see below) but make sure you have set them with the correct value by running jtest.

    Here is an example of how mine is set up (sorry i can’t paste the entire contents, I’m not with my Arcade Cabinet). I have a P1 and P2 buttons on my cabinet, and in the middle i have a black ‘coin’ button. P1 and P2 are buttons “6” and “7” respectively, and “9” is used as select for both

    input_player1_start_btn = “6”
    input_player2_select_btn = “9”

    input_player2_start_btn = “7”
    input_player2_select_btn = “9”

    I also have my player 2 index set to “1” , as per below

    input_player1_joypad_index =”0″
    input_player2_joypad_index =”1″

    Lastly, and this could just be due to copy /pasting into the browser, but the button values that you have shows appear to be surrounded by different types of quote marks. for example β€œ7” versus ”0β€³. Mine appear like this “6”

    here they are in comparison so you can see the difference

    β€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œβ€œ (see your Player 1 Up axis)
    β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³β€³ (see your Player 1 Up axis)
    “”””””””””””””””” (mine are like this all throughout the .cfg file

    Again, its something i just noticed, and it may not be a problem when the cfg file is being read.

    Good Luck

    #87754
    Profile photo of clownfish360
    clownfish360
    Participant

    When I try

    input_player1_joypad_index =”0β€³
    input_player2_joypad_index =”1β€³

    My 2nd player joystick and buttons do not work. when I use

    input_player1_joypad_index =”0β€³
    input_player2_joypad_index =”0β€³

    then my 2nd player buttons work but not my joysticks.

    I also tried the following axis for player 2

    input_player2_up_axis = “-3”
    input_player2_down_axis = “+3”
    input_player2_left_axis = “-2”
    input_player2_right_axis = “+2”

    but that did not work either.

Viewing 16 posts - 1 through 16 (of 16 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar