Swapping gpSP for RetroArch GBA Emulator?

Welcome Page Forums RetroPie Project Everything else related to the RetroPie Project Swapping gpSP for RetroArch GBA Emulator?

This topic contains 13 replies, has 4 voices, and was last updated by  Raygan Kelly 4 years, 8 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
  • #1565


    I read on the official RPi forum that RetroPie-Setup had swapped out the RetroArch GBA emulator for the faster-running gpSP emulator. What steps do I need to take to switch over? Do I need to update my RetroPie and then run the setup again to install gbSP? If so, how exactly do I do that from the Raspbian command line? Also, do I need to delete the RetroArch GBA emulator in order for it to run off the new one?

    Thanks for the help.



    You need to update the RetroPie Setup Script first. To do so, change to the directory of RetroPie Setup Script,

    cd /home/pi/RetroPie-Setup/

    and update the script via git,

    git pull

    Then, start the setup script via

    sudo ./retropie_setup.sh

    change to source-based installation and select only the GBA emulator gpsp to be installed.

    Afterwards, re-enerate the Emulation Station configuration file from the “setup” menu.

    I have written this without explicit testing, please report any issues that possibly occur.

    Hope that helps!



    That worked perfectly. Thanks.



    That worked perfectly. Thanks.

    Glad to hear!


    Chris Southcott

    When I try git pull, I get this:

    pi@raspberrypi ~/RetroPie-Setup $ cd /home/pi/RetroPie-Setup/

    pi@raspberrypi ~/RetroPie-Setup $ git pull

    Updating 850f429..df1047e

    error: Your local changes to the following files would be overwritten by merge:


    Please, commit your changes or stash them before you can merge.


    Is there a way to fix this? Thankyou!


    Chris Southcott

    Disregard my previous post, figure it out 🙂



    Has anybody figured out a good way to re-program the joypad configuration?

    I’ve dug around and am not really sure where the config files are.

    As a follow-up to that, if that’s doable, does anybody know if there’s a way to program a controller button or sequence to quit the emulator?


    Raygan Kelly

    I installed this, and I was able to download the latest script and run the install from sources, but I don’t think it compiled properly. When I try to launch games, it crashes back to EmulationStation. I see this in the logs:

    `lvl2: /home/pi/RetroPie/supplementary/runcommand/runcommand.sh 2 “/home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp /home/pi/RetroPie/roms/gba/Astro\ Boy\ -\ Omega\ Factor.gba”
    lvl1: …launch terminated with nonzero exit code 32512!`

    I think it may not have compiled gpsp correctly, but I’m not sure where to look for the logs. For instance, it seems to be looking for /home/pi/RetroPie/emulators/gpsp/raspberrypi/gpsp but there is no “gpsp” file in that directory. I’m not at a level yet where I can troubleshoot what went wrong compiling from sources. 🙁



    I don’t know much, but I know the file it’s looking there for is the actual emulator. That’s where it’s located. You also have to find and download a file on the net called gba_bios.bin and put it in that same folder. But if that were the only problem, it would tell you. I’m guessing your compile failed somewhere along the way.

    Sorry, but I’m completely new at this stuff and can’t help you much more than that.


    Raygan Kelly

    I was able to sort things out by completely tossing out gpsp and reinstalling it manually by cloning from GitHub and compiling it.

    I used this port.

    I’m not sure which fork of gpsp RetroPie-Setup is installing, but Aloshi just updated his/her port today(!!!), and it now includes the ability to map keys with a config file as well as set hotkeys for things like exiting the emulator. It’s now a good RetroPie citizen. I’ve been able to launch games from the menu, play at full speed, and quit back to the menu when done.

    Just clone the repo, cd into the raspberrypi directory, and run “make”. Then create the gpsp_input.cfg file according to the instructions in INPUT.md, and customize with your gamepad’s keys, and edit .emulationstation/es_systems.cfg to point to the newly compiled gpsp.

    I haven’t figured out if there’s a way to map multiple-button hotkeys like you can do with RetroArch, or if I can map a hotkeys for savestates, but it’s definitely playable.



    I’m updating to that right now. How exactly did you map a joypad button to exit the emulator? If we can’t do button combinations, I’d at least like to be able to make ‘Select’ on my SNES controller exit, since very few games require use of the select button.


    Raygan Kelly

    I just added the following to gpsp_input.cfg:

    btn_quit = 0

    I used the X button on my SNES controller. Since the GBA only had two buttons, the X and Y buttons are unused. No need to use your Select button (which is used more often than you might think in GBA games.)

    I haven’t yet figured out if there is a hotkey I can add for save or load states, but SRAM saves work fine.



    Yeah, I decided to map select to X, and exit to select. That way I don’t accidentally exit during any furious button-mashing.

    However, I can’t get my remapped controls to work. I pulled Aloshi’s build, ran make… It appeared to work. Had a readout about deleting this and adding that and modifying a few other things. So then I went into RetroPie/emulators/gpsp/raspberrypi and created a file called gpsp_input.cfg and put in my preferred mapping. However, when I launch games with EmulationStation, I still get the same old broken controls as before. Trying to figure out what’s wrong. And as I know absolutely nothing about the Raspberry Pi, or Linux, or programming, it’s a bit tough.


    Raygan Kelly

    I’m not sure what’s the hold up there. I would recommend trying what I did; delete or rename the existing gpsp folder and clone from scratch. (Go into the RetroPie/emulators folder and type “git clone https://github.com/Aloshi/gpsp.git“, then try “make” again.)

    Here’s a copy of my gpsp_input.cfg file:

    joyIndex = 0
    axis_up = -1
    axis_down = +1
    axis_left = -0
    axis_right = +0
    btn_a = 1
    btn_b = 2
    btn_l = 4
    btn_r = 5
    btn_start = 9
    btn_select = 8
    btn_quit = 0

    key_up = up
    key_down = down
    key_left = left
    key_right = right
    key_a = z
    key_b = x
    key_l = a
    key_r = s
    key_start = return
    key_select = right_shift

Viewing 14 posts - 1 through 14 (of 14 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

PLEASE NOTE: All orders that are placed between January 14th and January 28th will be shipped on January 29th. Dismiss