Stumped on how to remove hotkeys

Home Forums RetroPie Project Controller Configuration in RetroPie Stumped on how to remove hotkeys

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of breakpack75 breakpack75 1 year, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #102442
    Profile photo of breakpack75
    breakpack75
    Participant

    Hey guys I’m enjoying the retro pie, but I’ve recently hit a brick wall. I updated my Raspberry Pi 3 beta through the actual Pi and I’ve been trying to disable hotkeys, specifically the Select + X button that calls up the menu, select + left and right D pad does that changes slots and also select + B button to reset. I have been racking my brain trying to disable these through the retroarch. cfg file. I also used the emulation station menu running the setup script to try to disable it but that didn’t have any effect . Is there any other place that the hotkeys are enabled that I don’t know about? What specific line of text in the. Cfg file should I be looking for? I only want to enable load and save states with select and the L & R buttons and exit emulator by pressing start and select. I’ve got the Buffalo controller and I’m trying just about everything…stayed up way too late last night trying to figure this out lol. I am so close to having the perfect setup that I want. Any help would be great thank you very much!

    #102446
    Profile photo of herbfargus
    herbfargus
    Member

    Are you using the new emulation station input function? If so it outputs an autoconfig file here: /opt/retropie/configs/all/retroarch-joypads/yourgamepad.cfg and that’s where you’ll want to change it. You can also check out the hotkey section on this page:

    https://github.com/RetroPie/RetroPie-Setup/wiki/RetroArch-Configuration

    #102498
    Profile photo of breakpack75
    breakpack75
    Participant

    Thanks for replying! I figured it out! I had the Retroarch RGUI Saving settings to ‘Configuration Per-Core’ set to On and that was causing the hotkeys to revert back to default settings per emulator apparently. I did a fresh reinstall and when I turned this on, that’s when I ran into problems! Everything is good now. Thanks again for helping, I can finally finish up this setup!

Viewing 3 posts - 1 through 3 (of 3 total)

Forums are currently read only - please visit the new RetroPie forums at https://retropie.org.uk/forums/

Skip to toolbar